Volumio 3 issues: hints and solutions

Please read this topic before reporting a new issue.
It will help you locate reported issues, together with theirv solution and/or a hint to solve it.
Volumio mods and devs will keep updating this topic actively.
NOTE: when you decide to open a new issue, please supply a system log together with your description of the issue. Fellow community members and developers will be grateful.
Howto: Send a log

To help yourself, but also the Volumio Team: please do not use Test mode with the released Volumio 3 version unless specifically requested to do so.
By using test mode and OTA you risk running into alpha versions which are not fit for release.
But in case you do want to live dangerously by keeping test mode, you are on your own.
Issue reports will not be accepted for alpha versions :wink:


Migration to v3

I did a lot of updates on Volumio 2, incl. plugins, lcd etc. Is it safe to update to Volumio 3?


Be careful, in this case it might be better to flash the Volumio 3 version onto a separate SD.

Volumio 3 does not work for me yet, some things I need are still missing or not working

hint with a link to the latest *Volumio 2* for PI, Tinkerboard or x86

You can revert to the last versions of your RPi, Tinkerboard and X86, using these downloads.
But please note that Volumio 2 will go EOL soon, there will be no maintenance.
Update to (or flash) Volumio 3 as soon as possible.


My device won’t start after the update from Volumio 2 to Volumio 3


There seem to be situations where this does not work.
Please reflash your SD with the latest version from the Volumio OS download page.

I lost my music after updating


Please setup your music sources and/or rescan your library.

Couldn’t find my device on the wifi network after upgrade to Volumio 3


The Volumio 3 OTA update resets all settings to “factory”.

You need to renew the device settings, including network setup.
When the device is using WiFi, Volumio created a wifi network “Volumio-xxxx” (hotspot).
Connect to this hotspot to configure your network settings.

SSID: Volumio, password volumio2

Note: all following OTAs won’t reset to “factory”.
The volumio 2-> 3 OTA had to do this because of technical reasons.

myVolumio Specific

Manifest UI

No CD ripping button on Manifest


This has been resolved with version 3.173

Rasperry Pi does not show up on activated devices for My Volumio (V 3.173)


I’ve upgraded my Volumio installation to V 3.173 after a few issues with connecting it to my network and everything seems to work now apart from the fact that my device does not show up in the My Volumio section, which means I can’t add Tidal as a source.
I have upgraded to a Volumio Premium membership, which is displayed as it should. I’ve accessed my device locally via my IP so usually after a few seconds it should show up?
For network settings, I’m using a wireless network with a static IP set (as automatic IP did not work).
It’s a Rasperry 3 with the Hifiberry DAC +.

Does Volumio store my MyVolumio password?


A link between a Volumio device and a MyVolumio account appears to be persistent, so I am wondering whether subsequent authorization is achieved through a session key, or rather whether my account password is stored on the device.

Volumio stores the session-key, not the password (front- and backend)

No plugin store anymore on second device (Virtuoso)


Since the update to Volumio 3.173, I no longer have access to the plugin store on my Pi Zero.
I get an error message: ‘MyVolumio required for plugins’
In the beta fase plugin store worked flawlessly

Plugins are still free, but a free myVolumio account is needed to access the plugin store.


Tidal is playing an MQA track, but Volumio 3 web interface shows 44.1kHz 16bit


Volumio plays the track as is and does not unfold. The MQA stream is forwarded to the DAC unmodified. When the DAC supports MQA, then it will do the unfold and plays MQA. Just ignore the display in Volumio in this case.

Tidal Connect - Fixed bit depth


Volumio Version: v2.915
Hardware: RPI3+
DAC: Soekris DAM1021
The DAC used in this case needs a fixed bit depth of 24 or 32 bit. (the DAC won’t accept 16bit).
So to use this DAC it is necessary to use a fixed “bit depth”.
In volumio you can configure the fixed bit depth. This is working fine on the native volumio player and also with Tidal stream service on the native player.

But when using the “Tidal Connect App” volumio is ignoring the fixed bit depth setting and is using the native bit depth of the song that is streamed/played.


Volumio3 will have a “Global Resampling option”, so this will fix your issue.
The Global Resampling option is still on the To-Do list.

Mounting a MAC share


I’ve got my music files under the Public (shared) directory of one of the users on my Mac mini on the latest OS. Using every option on the Network Drives including vers=2.0, I can not get Volumio to mount the share. Any ideas?

Create a specific user (e.g. fileshare) to be able to access the share.


IQaudiO Pi Digi+ not appearing in the I2S DAC list


There are only 2 IQAudio cards listed, the dacs.json has 3

It appears the alsacard setting is missing for the IQaudiO PI Digi+:

{"id":"iqaudio-digiplus","name":"IQaudIO Pi-Digi+","overlay":"iqaudio-digi-wm8804-audio","alsanum":"2","mixer":"","modules":"","script":"","needsreboot":"yes"},

The dacs.json entry should probably be like this (to be verfied)

{"id":"iqaudio-digiplus","name":"IQaudIO Pi-Digi+","overlay":"iqaudio-digi-wm8804-audio","alsanum":"2","alsacard":"IQaudIODAC","mixer":"","modules":"","script":"","needsreboot":"yes"},

Sadly, it still doesnt work, error:

ALSA failed to open “volumio”; no such device.

USB DAC Schiit Modi 3 not listed/ recognized in Playback Options


I have been running a Schitt Modi 3 with all of the recent Volumio builds prior to Volumio 3.
The DAC used to show up as a selection in the output device screen.
Now I do not have any USB option shown, just Headphones and HDMI.
The USB powers the DAC as the light is on.
I have also tried separately powering the DAC, but it is still not recognized by Volumio 3.
I have reset, reloaded, cleaned contacts, changed cables.


The log shows usb issues, this has been reported before for the Schiit Modi 3 DAC (and others).
Perhaps try another usb port or another usb cable?

Dec 09 19:02:32 volumioshop kernel: hub 1-1.1:1.0: USB hub found
Dec 09 19:02:32 volumioshop kernel: hub 1-1.1:1.0: 3 ports detected
Dec 09 19:02:32 volumioshop kernel: usb 1-1-port1: disabled by hub (EMI?), re-enabling...
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1: USB disconnect, device number 3
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1-port2: attempt power cycle
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1: new high-speed USB device number 8 using dwc_otg
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1: New USB device found, idVendor=0424, idProduct=2514, bcdDevice= b.b3
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Dec 09 19:02:32 volumioshop kernel: hub 1-1.1:1.0: USB hub found
Dec 09 19:02:32 volumioshop kernel: hub 1-1.1:1.0: 3 ports detected
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1-port2: Cannot enable. Maybe the USB cable is bad?
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1-port2: Cannot enable. Maybe the USB cable is bad?
Dec 09 19:02:32 volumioshop kernel: usb 1-1.1-port2: attempt power cycle

RPi with Allo Boss 1.2, DSD 256 (11.28 mhz/1 bit playback) does not come right. Sound is cut to pieces. I doubled buffer to 4mb, did not help


This is an open issue, devs will have look.

RBP Allo Digione signature issues with Volumio 3


I upgraded to Volumio 3.173 and upgraded to the new Premium plan.

  1. I m using Allo digione wit a RBP and there is no sound coming out of it after the upgrade, not with Tidal nor with Spotify.

  2. It shows my library as empty and it erased all my music files in the usb drive.

Open issue

Noise when switching from flac to dsd


When i switching music track format from flac to dsd, there are noise about 5 seconds (like white noise). What is the problem?

I have heard this with my proJect pre Box S2 Digital.
On a Khadas Tone and Tone2 Pro it is clean.
Can’t help with the reason for it

V3 doesn’t recognize HifiBerry Digi+


After upgrading, Volumio doesn’t recognize my Digi+ soundcard. I downgraded to V2 and everything works fine.

This is an open issue, there are more users with the same finding.

Volumio 3 on my Raspberry Pi, Nanosound DAC doesn’t work.


upgraded to Volumio 3 on my Raspberry Pi but now my Nanosound DAC doesn’t work. I see from their forums that they are working on a plugin.

Waiting for Nanosound…

Hifiberry Digi2 Pro not working/ Hifiberry Digi+ no sound


I have a Pi 3b+ with Hifiberry Digi2 Pro. I did have it working before briefly with an older version of Volumio, but settled on using HifiberryOS as Volumio didn’t have a digital volume control. I think I had the I2S dac switched to “Hifiberry Digi” as there was no specific setting for the Digi2 Pro.

Decided to check out the latest release as I assumed it would have been updated for the more recent hardware… apparently not yet!

Unfortunately I now can’t make it work at all, not getting anything from the HAT. USB works, but the DAC I want to use is much better via S/PDIF.

Any help on which setting to use? Be gentle, if I have to do anything other than click a setting in the UI I’m out of my depth!

Edit let me add, I did search, seems others have had same issues, but with earlier versions. I’ve tried using “digi”, digi+ Pro, and even DAC2, none of which are giving me any output. Interestingly the optical output is showing a red light, but the DAC is not locking onto whatever is coming out.

And, no, swapping the DAC doesn’t help!

Second report:

I have upgraded to the Volumio 3 on a RPi3B+ with a HifiBerry Digi+ board. Volumio is connected with a digital coax to the Yamaha RX-A1010.

Upgrade went smoothly, including configuration. Result: No Sound. I tested different config settings but no sound.

After Volumio 3 update: no more “snd_rpi_hifiberry_digi” into the audio driver’s list.


The update resets all settings to “factory”, you need to renew the settings including audio setup.
Enable i2s and select hifiberry digi and you should be ok.

“failed to open alsa” after update to volumio 3.165


I installed 3.165 Volumio version yesterday, played a little with Spotify and music from pen drive. Installed Tidal Source today and “failed to open alsa” message appears.
Can’t hear anything anymore, from what ever source.
Unistalled and Installed I2s and same result.
I’m running a pi4 plus allo digione transport.

Hint 1:
I was able to fix it by booting from system to factory settings. I have the doubt if the problem occurs when we reproduce files of different sources and resolutions.

I was able to fix it by booting from system to factory settings. I have the doubt if the problem occurs when we reproduce files of different sources and resolutions.

Hint 3
I decided to play back through the headphone socket on the Pi which worked. Then I reverted back to the the DAC and no more alsa failure message. I have restarted system and still working well. Just need to transfer my playlists across from backup and sort a couple of album images.

Tinkerboard, I2S configuration missing in the UI

Fix pending

The UI is not showing the I2S switch to select the I2S DAC board.

After fixing this, Tinkerboard should support

  • HifiBerry Amp
  • HifiBerry DAC
  • HifiBerry DAC Plus
  • HifiBerry Digi
  • HifiBerry Digi Pro
  • IQAudio DAC (not sure, as not seen in PI ??)
  • IQAudio DAC Plus
  • IQAUdio Digi Plus (WM8804 Audio)
  • Justboom DAC
  • Justboom Digi
  • RPi DAC

DSP machine - CHIPDIPDAC unsupported


When will the chipdipdac audio card be available in volumio?
Please contact the manufacturer.

Volumio would support this DAC as soon as the manufacturer adds the overlay to the Rasbian kernel.

Pre-release install workarounds from manufacturers do not fit in the PI image build process. This is very kernel version dependent and too complex way to maintain for a single DAC hardly anyone is using (yet).

Allo Cheapo DAC and Volumio on RPi

no action

So, a bit confused, I have to ask, before I dive in to problems.
A friend just dropped here an Allo Cheapo DAC.
I would like to put it on top of a spare RPi 3 B.
I see in some topics here, that it will not work, because the Cheapo is made for a Sparky board.
Allo says in manual, that it is fully Raspberry compatible.
Some topics here are talking about different DAC, which accidentally get reported as Allo Cheapo by the Volumio software. So This DAC somehow is mentioned in the Volumio code.
So before I put it al together and start a nightmare, is someone here, who can tell me, if it is possible or not?
Or that I have count with some workarounds?

The Cheapo will not work on an RPi. It has no onboard DAC, so only works with the Sparky SBC, with a 3 pin connector for audio connection between the two.

RP4+JDS Labs OL DAC = no sound


I’ve bought a used JDS Labs OL DAC (USB), that is connected to my old receiver via phono and to the RP4 via USB-A with external power.
Issue: I get no sound out at all
Tried: Reflashing to clean installation of Volumio, and upgrading to ver. 3. Rebooting all three devices
Volumio finds the OL DAC and displays everything as if it is working. Tracks also play fine from multiple sources, but there is no sound.
I have confirmed that the inputs on the receiver work with another device… any ideas?
I did have this working briefly when I just received the OL DAC, but now it doesn’t anymore…

Not sure what happened. I put the OL DAC in a different USB on the rpi and stopped and restarted a few songs and now I get sound output. I also put the startup volume at 100.
Very weird…almost seems to be a bug of some sort.

DSD files are played in PCM


The opposite behavior of the DSD settings


The opposite behavior of the settings - when I have direct DSD set (DAC displays PCM 352kHz), when I set “DoP” the DAC displays 2.8MHz DSD and plays, but you can hear crackling in the background. The set is Pi and DAC via USB and “Amanero”.

This happens on many devices, so it appears to be something generic in Volumio 3.
Apparently the issue is related to being logged in as a Premium user.

Solution according to @volumio:
We have fixed this issue, and we are just testing the fix internally to confirm everything works as expected before releasing it as an update.
I hope it will be a matter of days, we would love to get your Christmas filled with bit perfect DSD music…

Solved in Volumio version 3.179

Volumio 3 restarts USB DAC Amanero Combo384


I CANNOT PLAY FULL TRACKS when I upgrade my Volumio 2 to Volumio 3.
Volumio 3 can play 1/3 or 1/2 track and it restarts USB DAC Amanero Combo384 and it can not play the rest of the track.
When i re-play the track and it happened again.
Volumio 2 runs well with my tracklist.

Logs requested

DSD on Amenero Combo 384 will not play DSD


Amenero Combo 384 will not play DSD native

cat /proc/asound/card5:

Status: Running
Interface = 2
Altset = 1
Packet Size = 272
Momentary freq = 176424 Hz (0x16.0d90)
Feedback Format = 16.16
Interface 2
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 5 OUT (ASYNC)
Rates: 32000, 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
Data packet interval: 125 us

Solution: Update firmware, see below.

But, let’s start from the beginning.
Though Amenero claims the DAC supports DSD direct, the above output shows that this particular model does not!
After checking the USB Audio driver, specifically the quirks list, Amenero does support, but only for specific revisions: 0x199, 0x19b or 0x203.

The user requested support from Amenero and got the following response.
"to install the native DSD endpoint on the Combo384SE there is this dedicated code firmware_2006be15r2_8804_TXRX and CPLD_1082_8804_TXRX. "

After the user updated the firmware, cat /proc/asound/card5 show:

Status: Running
Interface = 1
Altset = 1
Packet Size = 272
Momentary freq = 176424 Hz (0x16.0d90)
Feedback Format = 16.16
Interface 1
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 5 OUT (ASYNC)
Rates: 32000, 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 70 5600, 768000
Data packet interval: 125 us
Bits: 32
Interface 1
Altset 2
Format: S32_LE DSD_U32_BE
Channels: 2
Endpoint: 5 OUT (ASYNC)
Rates: 32000, 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 70 5600, 768000
Data packet interval: 125 us
Bits: 32

User’s procedure to update firmware
(see The opposite behavior of the DSD settings - #44 by wojtek_alfa)

To upgrade Amanero firmware you shoud Download tool www.amanero.com/oemtool117u.zip
Erase the board (like no the picture) www.amanero.com/erase.jpg

Run ConfigTool.exe and insert on the first form shown oemid nativedsd (replacing combo384)

at the bottom of the available firmware list selector box there is for
CPLD CPLD_1082_8804_TXRX firmware_2006be15r2_8804_TXRX
select CPLD_1082_8804_TXRX

then when done select
and press FLASH CPU
it installs the native dsd support with 8804 rxtx

PS Amanero to replace firmware should be connected via USB to the computer with installed drivers.


Where do I find the plugin store?


You need to create a free myVolumio account and log in.
Then from the menu >> Plugins.

I cannot find the plugin I’m looking for


Not all plugins have been ported to Volumio 3 yet. Most plugins are created and maintained by community member. Please contact the author of the plugin directly.

Also, have look at this: volumio-3-plugin-migration-status

Volumio 3 Can’t access Plugin Store though I’m logged in to myVolumio


I’m on the Virtuoso yearly plan and just updated to Volumio 3.
I can’t acces the plugin store as Volumio keep telling me to login to MyVolumio althoug I’m already logged in to Volumio and can see my plan under my name in the top.

Spotify-Plugins doesn’t work in Volumio3


is there a way to get the Spotify-Plugin back to work in volumio3 ? “Please check Username and Passwort …” - the same credentials works fine in volumio2.

Volumio 3 Spotify Connect not working


We have 5 Volumio players in our house. I have uppgraded one of them to Volumio 3 and it sounds great, but I can´t get Spotify Connect to work.
The normal Spotify plugin is working fine, but Volumio 3 does not show up as a device in the Spotify app on my phone. I made a new installation of Volumio 3, but with the same result.
The HW in this player is RPi3+ and HIFIBerry DAC+ Pro.

I’m having issues with the fusionDSP plugin


This is work in progress, the author is investigating, together with the Volumio dev team.
There is a separate topic in the Volumio Development section, which may help you with details.

I upgraded to volumio 3 and now I cannot find the GPIO button plugin.


Not all plugins are available yet – Volumio 3 Plugin migration status
There are suggestions to manually install it, but we advise against it.

Multiroom issues

Multiroom: issues with DSD


This is under investigation by the volumio devs, some improvements were already made (3.173)

Multiroom: detection problem / takes very long


I’m very happy with the new multiroom feature but most of the times it takes very long (several minutes or never) until the two instances find each other. (until the second instance appears in “group devices”)
Is there a way to make it faster and/or more reliable?
log_instance1.txt (21.4 KB)
log_instance2.txt (6.3 KB)

To be investigated

Is there any way to create a permanent group with 2 devices?


I wonder because I already have snapcast- clients around the house. And with the new multiroom integrated the snapcast server only runs when you add a group. And then I can use my snapcast-clients to get the synced music. Or have anyone tested if the “old” snapcast plugins works with Volumio 3? I have snapcast clients on orangepi zeros and so on. so cant install Volumio 3 on them.

Someone will answer this one asap
Volumio 3 for Orange boards are not available yet, please ask the author of the portings.

Common issues

Volumio 3 issue: music library folder names do not work with special characters anymore


have a USB stick attached to my RPi with a lot of music, ordered in directories and sub-directories.
This worked perfectly in Volumio 2.
I could use the music library and play them, play entire folders, add to queue etc.

Now in Volumio 3 nothing works.
First, the folder structure stops working after clicking through a few levels, then it sees only one folder named “???”.
And when entering that folder, there are 4 random songs (out of thousands).
But even in the levels above (that still show up normally), nothing works. I cannot play a song or add it to queue. A notification appears of the action, but nothing happened.

(Note: This is observed using many methods: using WebUI, my app, app of Joni, typing REST API commands in browser)

Volumio 3 and automount problem


After Volumio 3 came out, I updated my system. Updating itself went without any problem. However Volumio 3 is unable to automatically recognize and mount external USB drive if it is formatted into ext4(Linux). With Volumio 2 this was not an issue

It appears the user has wrongly formatted the disk device.
There was no partition table, which is necessary for udev to trigger an “add partition” device action.
Check this with (presuming the device was added as /dev/sda, other then modify the command)

sudo parted -s /dev/sda unit MB print

When this returns something like this

Model: Seagate M3 Portable (scsi)
Disk /dev/sda: 1000205MB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags: 

Number  Start   End        Size       File system  Flags
 1      0.00MB  1000205MB  1000205MB  ext4

Then Partition Table “Loop” indicates that ther is no partition table.
This happens a lot, also when you format under Windows.
So be carefull, always create a partition table before adding a file system.
You can also check with

lsblk /dev/sda

When you only see “/dev/sda” and no partitions “/dev/sda1”, then the partition table is missing.
Volumio cannot use such disks, it does not matter how the disk was formatted.

Apple USB CD Drive compatability


I have an Apple USB CD drive that I use with my Mac Mini for burning copying CD’s to storage. Will this or any other USB CD drive work with V3 on a R Pi 4? is an unpublished plug in required?

Apple SuperDrive works out of the box with RPi4 (+ payed Volumio subscription)

(RPi) artist/album/search functions stop working


The issue is that some functions stop working. If I go to the artist page, I should see all artists listed along with images but often (after a day of uptime) this page becomes blank. The thin green progress bar slowly moves to the right but the page never appears and the search function never returns a result. Same happens with the album page.

Log: http://logs.volumio.org/volumio/KbIWPzf.html

This a typical issue encountered with FusionDsp enable.
Work is going to be done on this…

Jump in playlist when deleting song at the bottom


Discovered the following Bug in the Userinterface
In the list of currently playing songs (multiple pages): When a song at the bottom is deleted from the list the list jumps automatically to the song currently playing.
Version: “3.173”

Volume slider behaviour - rescale to max. Volume settings and increments


using Vers. 3.173 at the moment with an iQAudio DAC+ as headphone amp.
I set the max. Volume setting of the hardware mixer to 50%, as my headphones are really easy to drive.
This setting is respected and the Volume slider always drops back to 50% when I try to go higher. But the volume increment setting is always at 5%, it does ignore the “one click volume step” setting I did. So I can only change the volume I am listening to in very big steps. And it is very sensitive to set (small movement results in big change).
I would love if the volume slider would be rescaled between zero volume and the max. Volume setting. And of course the volume step setting should be respected as well.
Link: Volume slider behaviour - rescale to max. Volume settings and increments

Start of selected song cut off


Details: Start of selected song cut off

This appears to be a long existing issue!

Select a track and the next one is played instead - same as in V2


RPi 3b / Kali
OTA update on Android.
Streaming Qobuz
I’m still getting the select a track from a playlist or favourites list, and it doesn’t play that track, it plays the next one.
So I have to go to the one above the one I want, to play.
This was the same in the V2 iterations.
It starts happening after a while of listening, searching, changing playlists, going back to home and reselecting Qobuz
as source, usual things you do - I don’t have Spotify or Nas set up at this point (I did on V2), only Qobuz.
I have also jumped to and used other apps, running Volumio in the background and reselected Volumio - not sure if this could be a trigger.

Comment of another user
This is backend issue which will eventually happen on spotify and tidal as well, no matter which interface you use to control your volumio device.
I don’t think I’ve yet to get this happen with local files which might be a way to narrow down the search of the bug.


Volumio - Android App - Volume controls


Volumio 2 and or Volumio 3

Samsung Galaxy S10e
Android: Android 11 (december 1 - 2021 latest kernel patch)
App: Volumio (official remote control app)

Since the beginning of december the volume control buttons on the phone won’t respond anymore within the Volumio App. I suspect google changed something in their code.

Anyone noticed the same issue?
And is there still some development in the “Volumio Android App” that might solve this issue?

Volumio IOS App - disconnect one instance - reconnect to another


Some of us run volumio in a number of locations. It would be great if the APP could allow disconnecting to one instance and then connecting to another without rebooting the phone.

Volumio + Audirvana


I use Volumio with Audirvana, after upgrading at 3 version Audirvana doesn’t work (@maurilio)
It is working OK with Volumio 2

Can’t display usb device custom name, after upgrade to Volumio 3


Steps to Reproduce

  1. Plug usb device (scandisk usb key fat32 formatted) with custom name : MUSIC_A
  2. Find this one in music library/usb
  3. Device’s name displayed is “E2D1-33F8”
    No problem with V2


Perl: warning: Setting locale failed


PRETTY_NAME=“Raspbian GNU/Linux 8 (jessie)”
NAME=“Raspbian GNU/Linux”
VERSION=“8 (jessie)”
SUPPORT_URL=“RaspbianForums - Raspbian
BUG_REPORT_URL=“RaspbianBugs - Raspbian
VOLUMIO_BUILD_DATE=“Tue Dec 22 14:39:52 CET 2020”

Fix: Make sure the locale is included/uncommented in /etc/locale.gen and regenerate locales with sudo locale-gen

I think it would be helpful to mention this issue in the Volumio docs about logging in with ssh, and also say how to stop the warning being printed if this should occur. I don’t think any changes are needed to Volumio itself.

We have a topic “Guides” in the Help section, it could be added there.

One could you also add a note here GitHub - https://github.com/volumio/volumio-developers-docs/blob/master/docs/ssh.md

OpenVPN x Spotify Connect


RPi400 4gb
Volumio 3.173
OpenVPN UDP connection to ProtonVPN
dhcpcd.conf untouched (previously forcing static domain_name_servers= in an attempt to quell dns leaks breaks tidal connect)
I have openvpn running on boot. I can play Tidal and Spotify from Volumio.
Tidal Connect sees and can play to Volumio from devices on my local network.
Spotify Connect does not detect Volumio when openvpn is active.
What would be causing Spotify Connect not to be advertising a Volumio endpoint while openvpn is active?
Suspect DNS, but Tidal Connect works?

Spotify != Spotify Connect :slight_smile: Please go to the volspotifiyconnect2 plugin settings and then I believe it’s called “multi-user device” or something like that, toggle that off and enter credentials again…

Spotify Connect requires mdns packets to “discover” clients in the local LAN. When you connect via the VPN, this might break.

Spotify (the other one) needs only to connect to Spotify’s servers, so works via the VPN with no issues.

Run first config wizard appears 2-3 times


This annoying but does no harm. A a known issue we are looking into.
Logs are available

I Installed Volumio 3 with Touch screen and Now playing plugin. But HDMI is not working.


Please toggle the switch in the Touch Display plugin, you may have to toggle on and off once or twice. Also make sure the screensaver is set up correctly.

Issue with setting up a custimized device name

cosmetic, open

This appears to be a cosmetic issue (UI) and will be fixed.

Suggestion: remove the md5 file from the pi image .zip


This suggestion has been picked up for implementation by the team.

Volumio 3 cannot find NAS


I upgraded, with the original setting erased, i need to re-mount my NAS, However i cannot seems to mount it even though Volumio could find the NAS on network. It used to be connected when I input "vers=1.0’ in the option box. But this is not working now.

Open issue, log requested

Volumio and SYNOLOGY NAS CIFS/ SMB mount issues

solution/ hints

I do not manage to get my Synololgy NAS connected to Volumio.

Some hints

  • To enable CIFS (SMB) on Synology
    Control Panel > File Services > SMB/AFP/NFS
    enable SMB
    Advanced settings
    set maximum SMB version = 3
    set minimum SMB version = 1
    enable “local Master Browser”

  • Share permissions
    Make sure user guest is added with read-only permissions (write permission does not make sense). Advanced Permissions should be left empty.

  • Using the Synology share with cifs (SMB) with manual entry

    • Enter an Alias, this will be shown in the Music Library later.
    • Enter the IP address of your NAS or use its name (e.g. MYNAS, no additions like ‘.local’)
    • Enter the share name
      Do NOT use Synology’s “Volume1” in the share name, just the share name itself.
      When you set up the NAS like shown above with max and minimum version, you can press “Save
  • Using Volumio’s Browse function

    • Use “Add Share” and wait until scanning has finished
    • Click “+” on the listed server which represents your NAS
    • Select the share you wish to use
    • When you set up the NAS like shown above with maximum and minimum SMB version, you can press “Save

In both cases, when you left maximum and minimum SMB version default (untouched), then you need to add “vers=1.0” to the advanced option before pressing “Save

Timer Display Numbers rendering


Volumio Version: 3.173
Hardware: Pi 400
DAC: IQ Audio Pro
My counter is being weird: Loom | Free Screen & Video Recording Software | Loom

Open issue

Is an “Apt upgrade” safe?


In Volumio 2, apt upgrade would brick the system. I gather the build system has changed in Volumio 3. Is it now safe to do an apt upgrade in Volumio 3?

Technically you could, but you would still run into issues.
Unsupported, better to ask for help in case you think you need to upgrade.

Updated to V3, no good airplay


I updated volumio primo hifi superstar to version 3 yesterday.
since this update i have no good airplay anymore.

Open issue

Can we play an ISO DSD with Volumio 3?

not supported yet

This is not supported yet, to be noted though

I run my installation on an Odroid/ PineA64/ Rock64/ Khadas/Nanopi board. When do I get Volumio 3


Volumio 3 has been released for the three officially supported platforms, Raspberry PI, Asus Tinkerboard and X86.
This is following the normal process, community portings always come afterwards.
Based on the PI and Tinkerboard experience, the community portings will be done in a second stage.

Not by the Volumio Team but the community member which created support for the board.
Work on Odroids has started, the others will follow.
Ofc I can only speak for the ones I have done.
There is no ETA, my (gkkpch) honest guess sometime Q1 2022.

New mobile web interface - change devices


Volumio Version: 3.173
Hardware: Pi 3b
DAC: HiFi Berry + Pro
Not sure if this is just me…
I seem unable to switch between devices unless I am in the “Now Playing” screen when something is playing.
Otherwise the option is no there on any screeen.

Open issue

Volumio 3 - Cannot complete music database


For details see topic Volumio 3 - Cannot complete music database

Open issue

Volumio 3 PI 3B+ restarts every time, its a loop


Volumio Version: v 3.173
Hardware: raspberry pi 3
DAC: off
I updated to version 3.173 today. While listening to music the Volumio 3 restar and display this message
Screen Shot 2021-12-08 at 15.16.12 , this happend every 1 or 2 minutes
I reverted back to 3.165 and all is well again. I will wait awhile before I try 3.173 again.

Asked for a log and more info.
It is not clear what actually happens.
It looks more like there is no reboot, just the message re-appearing.

How to clone an existing Raspberry Pi installation?


I did a bit of tweaking (MPD upgrade, etc) and it works like a charm.
It works so well that I consider buying more hardware and clone my Volumio setup so that I can enjoy multiple UPnP renderers at home.
Is there a way to do it?
I’m guessing it’s not as simple as copying the microSD content to another one, is it?
Is it possible to create an img file out of an existing Volumio installation, or do I need to start from scratch?

In windows and Mac One of the easiest ways to backup / clone a RPI Volumio installation is with Paragon Backup & Recovery.
its quick as it only backs up the data written on the card,
when restoring you are not limited to the same size card, you can use a smaller card assuming there is enough room for the data
Its free
Free Data Recovery software | Paragon Backup & Recovery Community Edition

Volumio 3 - UPNP seems to be broken


I have a USB Audioquest DragonFly 1.5 connected to my RPI 4 running Volumio 2.917. My Dac is not a full MQA unfolder, only an MQA render device.

As Volumio can’t unfold MQA, I’m using another software to connect to Tidal and play tracks. On that other software, I set the output for UPNP Volumio. I’m using Volumio as a kind of transport node between my laptop and my stereo system. Volumio is there to act as a sort of “gateway” between my Lan and my usb Dac.

Works fine until I upgraded to Volumio 3.

With Volumio 3, I got some sluggish performance, can take up to 30 seconds to load up the first track. After two or three tracks, the link between both devices (my other software and Volumio) seems to be broken. I can’t play any new tracks, the track won’t never start.

Rebooting the RPI fix the issue for two, or three tracks, as the same issue start again.

Went back to Volumio 2.917-2021-10-06 and works fine.

Volumio 3 and BubbleUPnP


Anyone else tried with Android BubbleUPnP app? Volumio 3.173 & RPi 3B+ with fresh install to SD it just doesn’t work properly. With Volumio 2 Upnp renderer was working like a old fashion train toilet.
Volumio 3 will show up twice in the list of scanned renderers (OpenHome and UPnP/AV). Volumio 2 shows only as OpenHome. Volume control works only with OpenHome renderer (I have HifiBerry Digi+). Track duration resets to “0:00” for player events such as pause or volume change or if refreshing client (web or Android app). Seek is not working when applied from Volumio side. But otherwise things are running pretty smoothly

I don’t normally use UPnP that much, but since I have both BubbleUPnP and mConnect installed on the phone I did a quick check. On BubbleUPnP Volumio 3.175 shows up twice as blamphos reports, the UPnP/Av renderer do not seem to work at all and the Open Home (?) kind of works - but not as smooth as on Volumio 2, can’t skip tracks, time is not synced etc. mConnect only sees the UPnP/AV renderer, so that does not work at all.

No bueno in Foobar, same as for BubbleUPnP that Volumio 3 shows up as two different UPnP renderers and kind of same issues.

hint from an x86 user

I’m on the free version of volumio 3.173 and I use it to play Tidal. For me it works perfectly and without a hitch for the first time. It was always a bit iffy on previous volumio versions.
For those who have had bubble upnp on their phone for some time I suggest deleting it and reinstalling it. You might notice that it did not update properly previously. With the latest version it works flawlessly. But you have to switch off battery saving mode. Enable gapless play and you are good to go.

V3 UPNP gapless doesn’t working


If i set gapless mode music stops after 2 songs.
And if i set “Force track advance” music plays with pause between tracks.
Volumio Information
Volumio Version: v3.173
Hardware: RPi4
DAC: Rotel 1572mk2 via USB

Does Amazon Alexa Integration work


Issue is being tracked – Does Amazon Alexa Integration Work for Anyone? Not for me - #5 by volumio

Howto do a Factory Reset with a USB Stick

  • Create a fat32 formatted usb stick
  • Create an empty file called “factory-reset”

Will Volumio 3 resolve the sampling rate synchronization issue that leads to the beginning of tracks getting cut off on playback via digital outputs?


Will Volumio 3 resolve the sampling rate synchronization issue that leads to the beginning of tracks getting cut off on playback via digital outputs? As discussed here - @volumio any news on this? Hoping to buy new hardware and Volumio 3 subscription if this issue has been resolved!

Volumio 3 Music Library Scanning: How to focus on 1 folder


Currently there is no option to do that.
Suggestion: add a request to the “feature request” topic in the Volumio Development section

Volumio 3 unable to boot


I have been very happy using volumio for the last year or so, however since flashing volumio3 to an sd card it wont boot on RPI4 with iqaudio dac pro. Showing a recovery elf and recovery4 elf ect not found error…
I have since reflashed four times on two different cards following the volumio directions each time, but still have the same problem… Have i missed/forgotten something?

The elf messages indicate that is an SD card/ flash issue.
The image has not been written properly, therefore the PI can’t boot the software.
Perhaps using Rufus instead of balenaEtcher?

Volumio and privacy


I am very privacy conscious so i opted out for the telemetry data in Volumio. Using a Pi-Hole i now see a large number of connections made by Volumio. Some of them are explainable:


So an update check and a “push” channel to send the updates but what are these:


I did not yet “monitor” the traffic that is send / received to/from these servers ! As a test i blocked all these connections and Volumio just works fine without them. I do notice that Volumio tries to connect to pushupdates.volumio.org like every minute quickly earning first place in my “blocked top 10” in the Pi-Hole.

So why do i block the update check / push? I installed the update and lost all settings and all plugins. In the new version these plugins are not (yet) available so i re-installed the previous version for now.

My question remains, what are all these connections and where are they used for?


WiFi issues

Volumio 3: Issue with 5 GHz network


I used Volumio 2 with my 5 GHz Wifi without any issues.
After upgrading to Volumio 3 (fresh SD install),
Volumio can’t find my 5GHz network anymore that I’m using for app my devices.
I’ve set the country code to DE via SSH as this was suggested somewhere else but to no effect.
As of now I can’t use Volumio 3 despite upgrading to the new Premium tier as well.
Any suggestion what the issue might be and how to handle this apart from downgrading to the latest V2 build?

hint 1 from @ashthespy/@turbo_2288
1: Mount your sd card into a pc.
2: Open the /boot directory [There are actually 3 partitions!]
3: Create a text file and name it “wpa_supplicat.conf”
4: Make sure you have the 2 letters “iso country code” for your country, in my case Canada → “country=CA”

hint2 from user @Brian2001
The only way I can get my 5G wifi network working on Volumio 3 is to login first to the 2.4G network. Once logged in, the 5G network will appear a few seconds later…

hint3 from user @SimonE
(This one seems to be the best one)
First I renamed my 2.4G SSID to NAME2, keeping the 5G as NAME.
Then I created a file in /boot using

sudo nano /boot/wpa_supplicant.conf
In that file I put:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
country=[your country code - 2 letters, caps, mine is NL for Netherlands]

ssid=“your 5G SSID”
psk=“your wifi password”
Then save the file and reboot. Remember the quote marks for ssid (wifi name) and psk (password).

WiFi disappears with Volumio 2 and 3


I have a Raspberry Pi 4 and seem to always have issues with wifi, specifically my network will disappear from Volumio. Had the issue with Volumio 2 and now with 3. Everytime it happens, a reboot doesn’t fix it. I have to use a wired connection to be able to load Volumio again. At that point, it sees the wifi network and I have to login again. And on 3, I have to first login to the 2.4G network in order for Volumio to see the 5G network. I know it’s a Volumio issue because it’s doesn’t happen if I use RoPieeeXL.
I’ve been using Volumio 3 for 2 days and I’ve already had to use my 25 ft Ethernet cable 3 times to get it back up and running on wifi. This is also the reason I stopped using Volumio 2 and started using RoPieeeXL. I don’t want to go back to RoPieeeXL. I did have a static IP assigned but went back to automatic IP. That didn’t solve the issue. Anybody have an idea as to what the issue could possibly be?

Is your Pi in a metal case? Mine was reducing the wifi signal. I occasionally have the same problem and hard rebooting my router (switch off, count to ten, power on) fixes it.

My WiFi shows the Volumio hotspot, but I can’t see my network SSIDs


This is a known issue with some wifi components on X86 devices, they can’t scan and be a hotspot at the same time.
For a notebook, go to the system/ network menu and disable the hotspot.
Then wait a little, network should restart and a little later your screen will also update. Then connect to the wifi network.

First connection to wifi


I installed volumio 3, I searched among my available networks, the relative volumio, once identified, I clicked connect, at the request enter the network security key I first typed volumio2 and then 3, but nothing doesn’t let me enter .

Open issue

Volumio 3: Wifi off at reboot and SSH not enabled


WiFi issue has been resolved in 3.173

SSH issue cannot be reproduced.

Volumio Primo issues

Please contact our dedicated support:

Volumio Primo revert from version 3.x to 2.x


How to flash a Primo or Tinkerboard’s eMMC?


Because I have issues with version 3.x (e.g. DSD playback problems). I’d like to revert to ver. 2.916. I downloaded the volumio-2.916-2021-10-01-tinkerboard.img and flashed to an usb drive. But how can I set booting from usb and copy the image to the internal emmc memory? Thanks for helping

  • remove the eth and/or wifi and power connector
  • remove any other usb device
  • open the Primo case
  • connect the thinkerboard’s micro USB to a PC
  • this will boot the Primo in so-called UMS mode

Now the Primo or Tinkerboard will show up as an USB drive on the PC.
Flash as you would an SD card.
Important: When finished, eject before disconnecting!!

Volumio Primo - no signal at HDMI output


I can not find a way to get a signal on the HDMI output of my Volumio primo. I have now waited for version 3.xxx but again no output of the signal at the HDMI output. Audio Output is on USB Output to a DAC. HDMI Output is ON at the settings. What do I need to consider?

your dedicated tech support may be able to help with this:

Contact Us | Volumio

x64 - x86 Issues

There is no OTA update for x86 to v3?


I’m Trying to install Volumio 3 on a Laptop PC: “Selected Boot Image did not authenticate”


Using a usb key and everytime I’m trying to boot from it it gives me that error

Disable “secure boot” in the notebook’s BIOS.

Boot fails, dropping to a busybox shell


I flashed the img on an usb stick (fat32).
Booted the PC from the usb stick.
Now I get these errors:

findfs: unable to resolve 'UUID=71ab3e29-2f21-412e-94bc-14fca9db74f2
findfs: unable to resolve 'UUID=58D2-553A
findfs: unable to resolve 'UUID=8f37fff1-fda1-4aa4-a1c7-1c29a371b21a

BusyBox v1.30.1 (Debian 1:1.30.1-4) built-in shell (ash)
sh: can’t access tty; job control turned off.

This is often caused by an incorrectly or incompletely flashed usb stick.
Windows users:
If you want to make sure you have a clean device, just remove the partitions with diskpart.
Do not pre-format the usb stick to FAT32 or anything else.
We have seen several users with balenaEtcher running into this boot issue.
You are strongly advised to use Rufus instead!
Unzip the downloaded file and flash the .img to your usb device.

Linux and Mac users:
Simply use dd like this after unzipping the file

unzip -p xyz.img | sudo of=/dev/sdX bs=1M

Replace xyz.img by the name of the downloaded zip file
Replace X by the correct driver letter. Do not add a partition number!!
Do not forget to sync or eject the drive before disconnecting.

Install to disk failed: undefined


Opening a terminal (Ctrl-F1 or via SSH), uid volumio, pwd volumio
Then do an fdisk -l to locate the device name of your harddisk/ssd
then wipe your disk like this, but replace /dev/sdb by your device!!!

sudo wipefs -a /dev/sdb

Is there a way of having the PC be on Volumio OS permantly or do you have to have the usb key in all the time?

- or -

How can I copy Volumio to the PC’s harddisk?


See System Menu >> install to disk







This topic will be updated on a regular basis