Song limit on volumio

Volumio 3 Issues?

Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------


Is there a limit to songs you can add to Volumio?

I had a usb stick which I took out as I was steaming from a network mount but I’m missing loads of songs, I’m stuck on 11990 tracks. I keep updating and rescanning but it doesn’t update


No limit, but rescanning will take longer with large libraries. I have a similar sized library to you: a bit over 12k tracks, and that updates in 2 or 3 minutes. Rescanning I do very rarely, but I can make and drink a cup of coffee whilst waiting.

1 Like

I do not know if Volumio has hard limit for library size. I have approximately 15K tracks and still growing and no problems. There is queue size limit in mpd.conf. Queue is not music library size, but number of items that can be placed into queue for playback.

For missing tracks You should look into mpd log. There may be hints, why all tracks are not added to library. May be permission problems or non compatible file formats. I use ext4 on my music disk and one time had permission problems.

cat /var/log/mpd.log

1 Like

Thank you


I’ve just seen, it appears to be copying the files to the volumio directory from the Nas not streaming. I assume there’s a way to stop this and just stream?

Unless this is a shortcut from the Nas I’m seeing in the SD directory. Hard to tell from the directory in my phone.

No it is not copying the whole music which would prolly exceed the systems memory but building an index db for mpd


1 Like


I factory reset because it wouldn’t let me delete the mount and I couldn’t get all the music to show up. I thought maybe it was corrupted from when I had put the usb stick in previously.

Anyway. Took such a long time loading (which it was doing before the reset to be fair but I couldn’t log in even with a physical ethernet cable & the IP displayed. Tried hotspot, wouldn’t connect, managed to connect with a laptop but it wouldn’t load the web page, tried logging in with the touch screen & keyboard, it typed the username volumio fine but every time I typed the password no characters would displayed. Tried typing the password volumio2 anyway and it kept saying it wasn’t correct. I tried various different password combinations, caps etc.

Flashed the original image I had done first time, but same as above. Nothing connects. Now it continues to boot. Starts of with “freesize is:” then I see the Volumio log then back again🤷

The SD card is showing no errors on windows, it’s the latest image of volumio and it’s a raspberry pi 4 2gb newly bought

It does say “failed to start RPC bind portmap service” during the start up

Okay, update on this. After about forty minutes I’m now presented with the username prompt. Still doesn’t allow any connections though

Try to download a previous version which you cannot find anywhere so in the end I got fed up. Went with Mo0d player instead. Much faster and better with touch screen & no subscriptions.

Just asking from curiosity, did moode solve these problems? Problems with indexing and connection.

It did, well at first but I couldn’t get the Bluetooth speaker output working, there were options there so it was probably just my ignorance.

I gave up in the end. I found the interface clumsy though to navigate. I guess I’m just used to iTunes on pc, which I just use instead.

The touch screen interface was much better than volumios though. There’s certainly more options.

I’ve got 25.000 tracks residing on a NAS (RPi 4 w/ HDD) and they take about 2 hours to load on a wired connection. Because my Volumio is on a RPi 3B the speed is only 100Mbit/s.

Some years ago I noticed that Volumio is MUCH slower to scan if all tracks are in the root or in one folder as opposed to being divided into folders (/artist/album).

That may have been the issue then. Thanks, good to know