USB DAC SMSL DO300 not recognized

Volumio 3 Issues?

Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------

Yesterday I added an external one to my equipment; the DAC s.m.s.l. DO300.
I connected it to my DIY RPi 4B streamer, on USB port. My Pi4 already includes HIFI sound card Berry DIGI + pro (for S/P DIF output only), but volumio didn’t recognize the new DAC.
Is there a procedure, a special setting for that DAC? I found some posts in this forum, but without solving the problem.
Then I tried the DAC with fanless MINI PC with standard Windows 11 player and the result is amazing. Indeed I have compared many and same FLAC files, in the same conditions on my YAMAHA RX-V1200 and Infinity Delta n40. The sensation is like turning on the light or pulling a wool cover off my speakers. A really big improvement.

Is it possible that there is no way to connect the new DAC to Volumio?

I assume from your post that you have a HiFBerry Digi + Pro attached to your Raspberry Pi. If you look at Playback Options you should have I2s On and Hifiberry Digi + Pro selected as DAC. If this is the case connect to your s.m.s.l. DO300 using a coaxial cable or optical cable from the HiFiBerry. That worked for me. :smiley:

Yes, but it’s not the same thing. The best way is to connect the Pi4 directly to the USB port of the DAC, exactly as I did with the Windows mini PC. Let’s take the case where I remove the minus DIGI+ card, there are at least 2 good reasons for this practice. 1) Avoid frequent “ALSA errors” 2) Converting to an optical signal from electrical digital adds jitter. 3) SMSL requires a USB connection as the preferred input.

best thing you can do is to boot without the SMSL connected.
Then when Volumio is up, connect the DAC to your usb port, followed by generating a log file.
How to create a log
Post the URL here for analysis.


I don’t see anything being connected to any usb port after starting volumio.
Are you sure your cable is OK? Does the DAC have a led or something to show it is switched on? I know, stupid questions, just making sure…

Remember that I’ve already checked that usb port works fine (used also as external file storage). The cable USB is the same on mini pc setup (works fine)


After USB port setting on the DAC

Your last log shows the smsl dac connecto to port usb 1-1.2
And aplay -l shows the DAC as card5, the way it should be.

The other logs don’t show any smsl device connecting to a usb port.
I guess with the last one it works?

Thank you gkkpch, but I don’t find the DAC in the list DAC model… at volumio config. How does Volumio Calls the DAC as card5?


Ok, now it works. Need to turn-off I2S DAC flag, and remove also coax/optical cable connection from RPi4. Maybe It depends from contemporary presence of Digiberry + card.
Thank you guys :slightly_smiling_face: