My usb device was erased!

I have bben using Volumio on Rpi3b+ with PIFI hat for a month or so, all working perfectly. My music library is on a 128 gb Samsung thumb drive, working perfectly!
Yesterday i plugged my chromecast audio power lead into one of the Pi’s usb ports just to power it up, worked perfectly.
However, I then noticed my music library had completely dissapeared, all of it! removed stick and checked it on my PC, empty. Volumio still worked, and another stick worked OK!
How can it be that the PI, or Volumio can erase ausb stick???, fortunately I have a back up, but a bit annoyed, to say the least!
Volumio 3 Issues?

Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------

System logs would have been useful here, after noticing the library not being there, but before you rebooted your device.

How to send system logs.

Edit: your “Chromecast power supply” point didn’t register with me on the first time of reading. So, a lower powered supply than recommended for the RPi was used. Not sure how likely that is to corrupt your USB stick: power cuts yes, but lower power?

OK, thanks, didn’t think of it at the time, too busy trying to get it working again. I will bear this in mind, if it happens again, and also be very careful not to plug anything in the usb ports whilst anything else is mounted!!!

Voltage drops due insufficient current are worse than total power loss most of time, and this holds for all electric devices.

1 Like

OK, so I usually have my chromecast powered from my Brennan B2, which works on a Raspberry PI 1, so I would have thought the power would be the same! Maybe I used a USB data lead for it rather than just power, that could have corrupted it. But very surprised it erased it completely!?!
BTW, I am not blaming Volumio per se, just very curious as to what has happened!

1 Like

We all are, this is one of the nastiest issues we have with Volumio 3, it has not been located yet.
And impossible to reproduce by the Volumio team so far.
Several members are helping with logs, but we’re all waiting for the one final log telling us what exactly happened.
Any help we can get here is very welcome, hopefully someone will be able to reproduce it repeatedly.

I,m currently putting all my music back on to the usb stick, then i will back that up to my PC. Then i will put the stick back in the Pi and try and replicate the problem. If i do, I can send you the log, and maybe it will help!

Thanks, we really need that to solve this issue. And believe me, we want to solve it asap

I will do what i can, and hope it does not damage any of my gear! Bit like crashing a car to help find a problem!:joy::joy: May be a couple of days.

1 Like

Not disputing that at all. I was just questioning whether this would translate through to a USB stick, which will draw a maximum current of ?? Anyhow, quite happy to be corrected… the system logs were the important bit.

yeah it’s all about endurance, retention and type. the more layers how shorter its life. (SLC, MLC and TLC) more to the right the crappier, bigger and cheaper they get and more sensitive to events around the medium. and easier to get corrupted.

The rPi should always run on a SLC (Single Layer Cell), If an SD is put into flash (write) mode and a power dip occurs, the write bit is still set, so the rPi can’t use that data (write bit set, so data in cells is corrupted) and boot failures will occur. (Mostly caused by temp files.)

So with the USB it seems that the MBR get damaged…

You seem to be very very knowledgeable about this.
Do you have some pointer of what might be the root cause of this?

What changed from Volumio2 to Volumio3 regarding this is:

  • Jessie to buster (might be a new bug in latest fuse version? )
  • We use a nodejs mount handler which listens to udev events

Anything that comes to your mind?

Only thing I can imagine is that on booting the CPU gets busy and draws current from the PSU. During this time the USB access kicks in, which causes a new request for power. If this request causes a peak > 500mA, the rPi lowers the voltage on the USB port. For some reason the rPi won’t recover from this voltage drop (measured with a calibrated DMM)
As I’ve read on this forum, people were able to recover the USB. This indicates nothing has happened to the data. The only thing left is the MBR table gets corrupted. As the MBR holds the start position to the “table” for the content of the USB.
For the same reason this is the reason why all manufactures tells you to not pull the USB thingy, without proper ejecting it. Both USB and SD have no logic to validate what is written or what is being written.
(very basic explanation)

So I expect this can be narrowed down to manufacturer/model/series and used chipsets.

If I look at the opening post, it confirms some power related issue.

For sure, this is nothing that can be solved by Volumio. Other than instruct people not to use the rPi as power source and if they do this can happen. If they want to use an USB powered DAC, don’t combine it with an USB thumb.
A USB HDD/SSD won’t show this behavior as there is a controller in place that takes care of this. (USB thumbs and SD-Cards lack this controller)

The usb was erased, nothing in it, apart from system volume info! Have just put music back into it, and am heading for my PI now!

you did validate this with a HexEditor, or is this based on the fact that the USB seems empty when you looked at it?

I don,t know what a hex editor is! I am not a PC whizz! All I know is that nothing showed on the disc in my file manager!!! I am just trying to help here, I don’t have your skills!

No personal attack, sorry if you thought I did.
Just trying to get as much info as possible to have this resolved.
As erased is something different than showing empty.

Hey, no problems, no offence😉 I did look at the property box in file explorer and it showed only a few kb used of 128 gb! Could there still have been hidden folders?

Difficult to guess from a distance, most likely it was possible to recover them.
Since you have a backup, maybe you can try the same actions again and see if you are able to reproduce it. It will certainly help the peeps from Volumio!!

Yup, I’m going to recreate my car crash! Later!