Can't connect Volumio to wifi, so it doesn't work

Hi all,

I’m just setting up Volumio for the third time, but this time I can’t make it work.

I can’t get the Volumio device to connect to wifi.

Here’s the exact process I went through.

  • I flashed the card with the latest img
  • I booted RPI -
  • The volumio wifi hotspot appeared.
  • I connected with the Volumio app on IOS , and went through the set up steps, including adding my wifi password.


  • I can still see the hotspot
  • When I run ifconfig on the raspberry pi, wlan is showing the IP (which I think is the IP of the hotspot, not the IP it should have)
  • I can connect through the hotspot and use volumio.local - but I can’t see volumio.local when connecting through my wifi.
  • If I try to reconnect volumio to the network (by going to Network → finding my SSID, adding the password and clicking “Connect” nothing changes
  • I tried editing wpa_supplicant, and rebooting, but this made no difference

Can anyone give any advice? I’ve never had this problem before. I’ve gone through the whole process three times now.

Any help appreciated!

Volumio 3 Issues?

Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------

Update: It works fine if I plug it in via ethernet. Very odd.

if you’re in the network setting of Volumio, when connected to a wire. Do you see the WiFi gets populated in the top right corner, when you finish the configuration?
And a log might be helpfull.

Hi Wheaten,

Thanks for your reply

Yes, the wifi is populated, and says it’s connected and gives the right IP address (the one I would expect it to have).

However, for example, if I disconnect the ethernet, and click the “shopping” icon on the bottom left hand corner, nothing appears on the page.

Here’s a log

Note that now I’m trying some other things, I’m getting lots of problems. These could be related, I’m going to post separately about these.

Can you try and disable the hotspot and see if that correct the problem?

Hey Wheaten I just checked and I had already disabled it.

Any other ideas?

From where did you get the image for Volumio?

From here on the volumio website

Please roll back to V3.569 release and don’t update to V3.601. Seems there are some issues.

1 Like