Unofficial Volumio3 images (with MyVolumio) for OrangePi SBCs with H3 processor

OrangePi devices with H3 processor are old but good enough to run Volumio.

Please find below the unofficial (a.k.a. community porting) images for some OrangePi devices, with updated kernel and Volumio backend. Those images include MyVolumio, so plugins can be installed from the Plugin Page, after logging in with a MyVolumio account (either Free or Premium).

They are based on the work done previously by @ashthespy and @VyacheslavS, a big thanks to both of them!

DISCLAIMER: those images are unofficial, released “as-it-is”. No official support will be provided for those devices, but help from other community members is more than welcome.

Updates will be released from time-to-time, without a regular schedule. They can be applied with OTA update or by flashing the new image on the SD-card.


  • Onboard Analog (on OrangePi PC and OrangePi Zero)
  • I2S Master on GPIO connector
  • I2C interface on GPIO connector
  • Plugins from Plugin store
  • Manifest UI
  • OTA update

Version 3.569 (Update Volumio backend, support for Tidal FLAC)
OrangePi One
OrangePi Lite
OrangePi PC use this image also for OrangePi Zero 1 /LTS

Version 3.512 (Update Volumio backend, Supersearch and Infinity playback RC)
OrangePi One
OrangePi Lite
OrangePi PC use this image also for OrangePi Zero 1 /LTS

Version 3.503 (Update Volumio backend, Supersearch and Infinity playback Beta)
OrangePi One
OrangePi Lite
OrangePi PC use this image also for OrangePi Zero 1 /LTS

Version 3.456 (First release, kernel Armbian 5.15.93, with additional WiFi drivers)
OrangePi One
OrangePi Lite
OrangePi PC use this image also for OrangePi Zero 1 /LTS

kernel headers


Thank you very much for your work. I’m already testing it on Orange Pi PC.
Pluses - Spotify worked from the plug-in store. Good connection with the application for Windows, better feedback than through the Chrome browser.
MPD OLED is not installed from the store. It is installed manually according to the instructions from mpd_oled/ at master · antiprism/mpd_oled · GitHub, but it does not work correctly. For some reason, the screen does not update, although the plug-in used to work in Orange Pi PC on builds from @VyacheslavS.
The rotary encoder 2 plugin didn’t work either. Although the @Saiyato plug-in on Volumio2 used to work - Volumio 2 on Orange Pi Boards - #194 by Radiomanoff

happy to hear that it works well on your side, besides the issues with plugins

regarding the Rotary Encoder II plugin available in the plugin store, it has a different implementation compared to the old one from @Saiyato , it makes use of dt-overlays available only on Raspberry Pi, so it won’t work on other platforms. You might give a try to the old one, but it might require some adaptations to work on Volumio3

regarding MPD_OLED, the developer applied some changes recently, that might cause issues on Volumio. I suggest to ask for help in the dedicated thread

1 Like

After all, it was possible to launch MPD_OLED on this image. Here on the forum there is a link to Packages for mpd_oled - OLED spectrum display on Volumio on Raspberry Pi Zero W - #287 by Adrii
I just downloaded the older version from 09-25-2022 and it works -
And then the usual installation:

wget -N
sudo bash
sudo mpd_oled_volumio_mpd_conf_install
sudo mpd_oled_service_edit -o 3 -a 3c -B 0 -b 10 -g 1 -f 20  //# display ssd1306 128x64 for I2C0

well done! nice setup too!

Hi Radiomanoff

If your commands are pasted correctly, it looks like you downloaded but then ran (which perhaps you previously downloaded) and so it looks like you have installed the latest version of mpd_oled.

There is an issue of the current version of mpd_oled not working when installed over an old version, with behaviour like you described, so maybe that was the initial issue. This issue and fix is described at

MPD_oled over MoOde audio rel 8.3.2 · Issue #84 · antiprism/mpd_oled · GitHub

Although you are not running an official Volumio distribution, I am happy to review issues on any system where mpd_oled could reasonably be expected to run.


Hello Adrii.
So I was wrong, I have already corrected it

sudo bash

I also tried installing the latest version of MPD_OLED manually from a script
This is how it is installed, even an image appears on the display, but it is static, not updated

Hi Radiomanoff

The static display is a symptom of installing the current version of mpd_oled (with the change to the mpd_oled service) over any previous version of mpd_oled. If this is the case, then you should be able to fix it by running the commands from the issue I linked to

MPD_oled over MoOde audio rel 8.3.2 · Issue #84 · antiprism/mpd_oled · GitHub

[EDIT: but use your mpd_oled options in the final command]


Dear Adrii, unfortunately, even on a freshly installed Volumio on a formatted SD card, MPD_OLED of the latest version on this image from Darmur Orange Pi PC does not work, the image on the display does not change.
I tried your instructions to no avail. I want to note that it was Orange Pi PC after all, and not Raspberry Pi, maybe that’s why there was no result.
And if you install an older version, according to my instructions above, after the command

sudo apt remove mpd-oled

everything works

Hi Radiomanoff

Yes, and it can be a very small difference that stops things working.

The mpd_oled update issue with the static screen on Moode is that cava (mpd_oled_cava), which is the program that calculates the spectrum, crashes when mpd_oled starts it. I am not sure of the exact origin of the issue, but the situation is that the current version of cava must be run by a user that has a home directory, indicated in an appropriate environment variable (e.g. HOME), and this isn’t set when mpd_oled is run from a script from systemd service (as it would be for a normal user). I set the HOME variable explicitly in the mpd_oled launch script, and cava starts without crashing and mpd_oled starts normally.

If you see something printed correctly on the OLED then the issue is probably something small that can be easily fixed, but that doesn’t mean it will be easy to track down! For the HOME issue above, I had access to the machine and it still took me a while to find it.

Anyway, I won’t delete the old mpd_oled packages, and there is no new development, so if the previous package works it is as good as the current package. The only reason for fixing it is that the issue may be affect mpd_oled running on other systems too, but if this is important then someone will report it when they encounter it.

Thanks for the feedback!


1 Like

There was a problem - I have a fee Orange PI Plus. I recorded the image, but the board does not appear on the network, there is no indication of network operation. I had to connect a monitor - it showed that webUI is located at The study of the topic showed that in my PI Plus there is a 1GB network card, and it is connected directly, and in PI PC there is a 100MB network card connected via a USB bridge. Here, either look for an image for a similar board on an H3 and 1GB network card, or connect a USB network card and try to load drivers for it. But I am completely zero in this :frowning: If someone can help, I will be very grateful to him.

sorry but you have a different SBC (Orange Pi Plus), not mentioned anywhere in the release post.

the only supported ones are the following:

Orange Pi One
Orange Pi Zero
Orange Pi Lite
Orange Pi PC

Orange Pi Plus is not part of this list

Hello everyone, we are testing the image further.
The GPIO Buttons plugin is installed from the plugin store

pin numbers are determined from this table, BCM tab


1 Like

does it work?

Yes, everything works

1 Like

awesome! well done!

The GPIO_control plugin also works from the plugin store. You can, for example, connect LEDs to indicate operating modes

1 Like

Greetings. Installed on Orange Pi PC. There are questions - other themes are not applied in the settings, only Manifest UI. Is this a bug or by design? Also, when clicking My Web Radio, when returning, it gets stuck in the window with my links to web radio. You cannot return to the list of sources. : Frowning: And when using the pcm5102 DAC, there is no volume control. The settings don’t change anything.

Приветствую. Поставил на Orange Pi PC. Есть вопросы - в настройках не применяются другие темы, только Manifest UI. Это баг или так задумано? Еще при нажатии Моё веб-радио, при возврате застревает в окне с моими ссылками на веб-радио. Вернутся в список источников нельзя. :frowning: И при использовании ЦАП pcm5102 нет регулятора громкости. Настройки ничего не меняют.

you can change the UI in the “system setting” page, at the bottom

the PCM5102 chip does not have Hardware volume control, the only option is the software one