[Solved] Cannot switch the User Interface back

i cannot switch the UI back to Classic.
When I do so in “System Settigs > Legacy User Interfaces” it switches back to “Manifest”.
Is there any way to do so?

1 Like

This was a bug in one of the old Beta’s for Version3.

  • Which Volumio version are you running?
  • Which hardware are you using?
  • Can you post the results of: ls -al /data/
  • please post a log, when you try to change the interface
1 Like

Thanks, will do:
Version 3.423
Raspberry Pi 3

volumio@volumio:~$ ls -al /data/
total 55
drwxr-xr-x 1 volumio volumio  1024 Feb  4 11:16 .
drwxrwxrwx 1 root    root     1024 Jan  1  1970 ..
drwxrwxrwx 2 root    root        3 Jan 24 15:44 INTERNAL
drwxr-xr-x 6 volumio volumio  1024 Mar 31  2022 albumart
drwxr-xr-x 2 volumio volumio  1024 Mar 31  2022 backgrounds
drwxr-xr-x 2 volumio volumio  1024 Jun  4  2022 cddb
drwxr-xr-x 6 volumio volumio  1024 Mar 31  2022 configuration
drwxr-xr-x 2 volumio volumio  1024 Jun  4  2022 favourites
-rw-r--r-- 1 volumio volumio 31004 Dec 14 16:39 laststates.json
drwxr-xr-x 2 volumio volumio  1024 Jun  4  2022 myvolumio
drwxr-xr-x 2 volumio volumio  1024 Mar 31  2022 playerstate
drwxr-xr-x 2 volumio volumio  1024 Jun  4  2022 playlist
drwxr-xr-x 3 volumio volumio  1024 Feb  4 07:24 plugins
-rw-r--r-- 1 volumio volumio   346 Feb  3 07:05 queue
-rw-r--r-- 1 volumio volumio    22 Feb  4 07:46 volumio-update.tmp
-rw-r--r-- 1 volumio volumio     0 Feb  4 11:16 volumio2ui


fixed it! this did the trick:

touch /data/manifestUI

after this I could switch back to contemporary UI
@Wheaten thanks for pointing out the old issue and everything!

1 Like

darn, was just writing what you needed to…
But it’s solved now



I have been able to change the interface following Maegashira’s solution above but can someone tell me how to change the background picture following a re-install of the latest volumio? I listen to a lot of classical music and the (excellent) picture of a drummer doesn’t quite do it for me.

Thanks in advance


ssh into volumio

sudo nano /data/configuration/miscellanea/appearance/config.json

there are two sections that you need to edit “background_title” and “background_path”
leave the .jpg in place when editing “background_path”

You have the choice of
galaxy (which is not a galaxy lol… its a nebula)

Write out ( ctrl o ) then exit ( ctrl e )

reboot volumio and refresh your browser

1 Like

Thanks - it worked a treat :grinning:


I have just updated to v3.449 and now have the exact same issue. How, where do I enter that command.
I know there are ways to connect to the Raspberry Pi with networks but I don’t understand any of that.
I have Volumio on a microSD card in a Raspberry Pi 3b with a HiFiBerry DAC Pro+ and access it with my phone on Android using the app or on my PC using Opera web browser.

1 Like

Enable ssh:

connect with putty and login to the console and type:

rm /data/manifestUI
touch /data/disableManifestUI
touch /data/volumio2ui

@Kihon @Wheaten

There is also a much easier way of getting the “Classic” UI without SSHing into Volumio.

Select the top left burger menu, then select system.
Scroll down to “Legacy UI interfaces”. By default it is on “manifest”
Do not select anything from the drop down box … just click “Save”.

Scroll down again to “Legacy UI interfaces” and this time select “Classic” from the drop down menu and click “Save” which should now work as normal giving you the Classic UI

But…If you want to change the background in Classic you still have to edit a file to achieve this

1 Like

Hi everybody,

Is there any way to replace the background picture in Classic UI with solid (black) color? As I can see it is already black, but it has a jpg loaded above it.

Thank you in advance.

Yeah, in the example I posted above on how to change the background picture.

The section that say “background_type”
change the value from “background” to “color”

1 Like

Just freshly installed vers.3.449 and had trouble switching from Manifest. I recalled someone having the same problem and after a bit of searching found this topic. The ‘save first - change later’ method worked so thanks for that.

Should this now be working? Was I doing something wrong?
If not I can imagine this being a bit confusing / annoying for a newcomer to Volumio.

Nope… Its still a bug in this version (3.449)
Maybe on the todo list for the next version.

1 Like

Hi There. Just found this thread after getting the same problem with version 3.512.
The ‘save first - change later’ method worked for me too! Thanks for `explaining this.
PS.Interesting thread - I didn’t realize you could alter the backgrounds - must try this.

Hi guys.

Today i tried to change the background image of my Volumio v. 3.546 but i couldn’t do it. Here my questions.
[Q1] Is it no longer possible to change the Volumio screen?
[Q2] How to change the background image?
[Q3] In which folder to save the new image?


I was able to change background image on 3.569 by the method described by @M1ck on this page, here. Background images are in /data/backgrounds.

The theme change method described here works as well, thanks @M1ck !

Hi everyone.
First I wish everyone a happy new year.
I hope 2024 brings us a bug-free system release.
now try changing the wallpaper with the method described by @M1ckin in his post, but it would be nice if it was simpler.
Thank you.

Working on it, we thought it was not important since we have the manifest UI as default, but we listened.