X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Hello friends!
Can you ask me a question? How to connect volumio (PC) to the TV screen and display the interface window like on mobile!
I connected via HDMI cable to the TV, but only the command interface (Dos) is displayed.
Thanks a lot!
Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------

What hardware are you using?

If a rPi, install the “touch display” plugin

I am using volumio on x86 computer

Then all you need to do is, go to:
System => Video Output Options =>

1 Like

@phungmac I know this is all a bit confusing, but the x86 image has HDMI enabled by default.
You can switch it, that is what the previous post is about.
In your case it looks more like a hw compatibility issue, the current version of Volumio for x86 is known to have issues with newer hardware, when not yet supported graphics cards are used.
Could you please submit a log to verify this?
This article shows how to do it

The other option is to install this version, it is brand new with the latest hw support and therefore not officially supported yet: Volumio-3.576-2023-11-10-x86
An official version should be released soon.

1 Like

Thank you for responding!

it is possible to add new entries to the Windows Bootmanager for example with the easybcd-tool. It was no problem to add an entry for the kde-neon-installation. It was just important to install the bootloader of that installation into the root-directory.

Why i want to use the Windows-Bootmanager is because i use two WIN 10 Installations on that System. One for a normal Windows with Fidelizer and another with Audiophile-Optimizer. When i use the Bootloader of KDE-Neon (GRUB i think) it will always detect the two Windows as One or in other words it detects the Windows Bootmanager. So after choosing WIN i have another Boot into that Bootloader and choose again and then sometimes one or two more Boots until i finally arrive.

This is why i tried to include the Linux into the WIN-Bootloader although i think the NEON-Loader looks better. And this works very fine for this first disk. Could i add Volumio into this Menu it would be the AUDIO-Machine of my dreams.

Is there anybody who ever tried to add Volumio to the Windows 10 Bootmanager?

#H

Probably me to answer this one, this is a very tempting feature which went through my head many times.
It did not get done, not because we wouldn’t want to, but the problem is that the current Volumio install is based on an image flash and we miss the specialist ressources and skills Microsoft and Debian can make use of to create an installer.
In case someone has the skills and time to support us, please let us know.
Manual additions to the Windows bootmanager, Linux grub2 or Syslinux won’t survive a Volumio update.

1 Like

Thanks for your interesting answer. I am not much of a programmer and have to admit although i am fiddeling with linux-installations since 1998 i still do not really understand what i am doing when i copy and paste those terminal-commands that do the jobs.

I am totally convinced of Volumio after comparing it with other solutions. The sound is amazing.

When i understand the Windows-bootmanager correctly it works like this: in easybcd i add an entry to the menu and give the additional information to which kind of bootloader this entry leads. In the case of the kde-Neon it is a GRUB2-link.

When i saw a Syslinux-information in the volumio-bootup i thought ‘that’s it’ and added that in easybcd and directed the bootmanager to the bootpartition of the volumio-drive. But that didn’t work. Why? Isn’t there a bootloader installed in that 171mb-Partition? One that could be linked with my boot-manager?

When i reinstall Volumio on that second drive the bootmanger in the first drive is not affected. I tried that. So maybe it is possible to get Volumio integrated without too much fuss?

1 Like

You can experiment as much as you wish, google chainloading bootloaders, windows BCD and also refer to the syslinux wiki, there is some information which may help.
I prefer not to get involved in this as it has no real value for Volumio.
Just a warning: even when you get this working, there is a big chance that the system breaks as soon as you do your next Volumio update.
So you’re on your own with this, sorry.

Hey it just works now! Since i took from your suggstions that syslinux is the actual bootloader for Volumio i just tried again to add an entry in the WIN 10 Bootmanager via EASYBCD.

I chose linux as the target OS and the 171MB boot partition on the Volumio-Drive as target-partition.

After Reboot and choosing VOLUMIO in the Windows-Boot-Manager the system went there and showed the ‘BOOT ERROR’ message as before. But this time i did not turn off the computer BUT just hit a key (ENTER). And then Volumio started absolutely normal from the drive.

Tried to start all OS’s for several times now to make sure everything works and it does. Fantastic!!

I think this is of a certain value for Volumio because it makes it a lot more convenient to use it on a Laptop/PC that is not solely dedicated to AUDIO. And i don’t think that an update of Volumio will break this bootloader-chain since the modified Bootmanager is on a different hard-drive which does not get altered by a Volumio-Installation.

Thanks for all answers and the help they provided and greetings from berlin,
H

This is great . Can you give a step by step instruction of how to do it please?

@jocoman Who are you replying to? If you wish @heinrich to answer, you need to add him with @… to your post or reply to him using the post reply, not the topic reply you just did :wink:

Will a Lenovo ThinkPad 10 Windows tablet be good for installing Volumio? Will the touch screen work?

1 Like

just flash to a USB thumb, boot from it and check.

1 Like

I’m asking because I’m about to buy it

Unable to tell, no clear or very limited specifications are there to find. It might contain:

  • Realtek® ALC5672 codec
  • Intel Atom Processor Z3795 SoC Quad Core
  • Intel HD Graphics 4600 in processor

No info Wifi chipset etc.

@gkkpch
Any idea of this might work as the configuration seems a bit exotic?

Not exotic, I believe (but NEVER give a guarantee for devices I did not test myself :wink: ), it should work ok., including touchscreen
I usually try to get of info from the internet, often

There are no negative comments towards the Thinkpad 10 tablet, all vital components seem to work.
Note, there is some confusion about the audio part, it is supposed to have an rt5640 audio codec, but is said to have an rt5671. Not sure whether the current headphone plug/ unplug implementation properly switches to speaker (with rt5641 it works fine).

The DAC will be connected to this tablet via USB. This is exactly the Lenovo ThinkPad.


If I do that while a song is playing the song will stop playing as expected. That’s fine as I usually won’t switch sources while listening to music.

Step-by-step description:

  1. Set output device to Up2Stream DAC and save
  2. Set Volume Options to Hardware/PCM and save
  3. Play song; confirm that audio plays.
  4. Stop song
  5. Switch input source on amp - Observe “Out Device is not Available” notification
  6. Switch input source back to DAC on amp - Observe “Player successfully restarted” notification
  7. Play song; no audio plays although the song progress bar moves along as expected
  8. Click Save on Volume Options - observe “Mixer Control Settings Updated” notification
  9. Audio starts playing after a few seconds

Note that in step 8 I didn’t actually change/reset any settings - I confirmed this after some experimentation. All I needed to do was click Save again on the Volume Options to get the audio playing again, so it appears to me that the Volume Options are not restored correctly after I switch back to the DAC audio device.

Here are the logs: http://logs.volumio.org/volumio/0Rg8cso.html

Please disable all plugins, especially DSPFusion when doing this test. to make it easier to determine the root cause.
I see multiple entries like the one below, but with increasing device numbers.


Dec 01 06:19:48 volumio volumio[918]: error: FusionDsp - WebSocket error: [object Object]
Dec 01 06:19:51 volumio volumio[918]: info: CoreCommandRouter::executeOnPlugin: mpd , getMyCollectionStats
Dec 01 06:19:55 volumio volumio[918]: info: CoreCommandRouter::executeOnPlugin: mpd , getMyCollectionStats
Dec 01 06:19:56 volumio kernel: usb 1-1: USB disconnect, device number 6

Moved this to the correct topic, as it’s x86 related.
Please create a new log and make sure to stop after the error, dont’t fix it.

1 Like