X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Hey it just works now! Since i took from your suggstions that syslinux is the actual bootloader for Volumio i just tried again to add an entry in the WIN 10 Bootmanager via EASYBCD.

I chose linux as the target OS and the 171MB boot partition on the Volumio-Drive as target-partition.

After Reboot and choosing VOLUMIO in the Windows-Boot-Manager the system went there and showed the ‘BOOT ERROR’ message as before. But this time i did not turn off the computer BUT just hit a key (ENTER). And then Volumio started absolutely normal from the drive.

Tried to start all OS’s for several times now to make sure everything works and it does. Fantastic!!

I think this is of a certain value for Volumio because it makes it a lot more convenient to use it on a Laptop/PC that is not solely dedicated to AUDIO. And i don’t think that an update of Volumio will break this bootloader-chain since the modified Bootmanager is on a different hard-drive which does not get altered by a Volumio-Installation.

Thanks for all answers and the help they provided and greetings from berlin,

This is great . Can you give a step by step instruction of how to do it please?

@jocoman Who are you replying to? If you wish @heinrich to answer, you need to add him with @… to your post or reply to him using the post reply, not the topic reply you just did :wink:

Will a Lenovo ThinkPad 10 Windows tablet be good for installing Volumio? Will the touch screen work?

1 Like

just flash to a USB thumb, boot from it and check.

1 Like

I’m asking because I’m about to buy it

Unable to tell, no clear or very limited specifications are there to find. It might contain:

  • Realtek® ALC5672 codec
  • Intel Atom Processor Z3795 SoC Quad Core
  • Intel HD Graphics 4600 in processor

No info Wifi chipset etc.

Any idea of this might work as the configuration seems a bit exotic?

Not exotic, I believe (but NEVER give a guarantee for devices I did not test myself :wink: ), it should work ok., including touchscreen
I usually try to get of info from the internet, often

There are no negative comments towards the Thinkpad 10 tablet, all vital components seem to work.
Note, there is some confusion about the audio part, it is supposed to have an rt5640 audio codec, but is said to have an rt5671. Not sure whether the current headphone plug/ unplug implementation properly switches to speaker (with rt5641 it works fine).

The DAC will be connected to this tablet via USB. This is exactly the Lenovo ThinkPad.

If I do that while a song is playing the song will stop playing as expected. That’s fine as I usually won’t switch sources while listening to music.

Step-by-step description:

  1. Set output device to Up2Stream DAC and save
  2. Set Volume Options to Hardware/PCM and save
  3. Play song; confirm that audio plays.
  4. Stop song
  5. Switch input source on amp - Observe “Out Device is not Available” notification
  6. Switch input source back to DAC on amp - Observe “Player successfully restarted” notification
  7. Play song; no audio plays although the song progress bar moves along as expected
  8. Click Save on Volume Options - observe “Mixer Control Settings Updated” notification
  9. Audio starts playing after a few seconds

Note that in step 8 I didn’t actually change/reset any settings - I confirmed this after some experimentation. All I needed to do was click Save again on the Volume Options to get the audio playing again, so it appears to me that the Volume Options are not restored correctly after I switch back to the DAC audio device.

Here are the logs: http://logs.volumio.org/volumio/0Rg8cso.html

Please disable all plugins, especially DSPFusion when doing this test. to make it easier to determine the root cause.
I see multiple entries like the one below, but with increasing device numbers.

Dec 01 06:19:48 volumio volumio[918]: error: FusionDsp - WebSocket error: [object Object]
Dec 01 06:19:51 volumio volumio[918]: info: CoreCommandRouter::executeOnPlugin: mpd , getMyCollectionStats
Dec 01 06:19:55 volumio volumio[918]: info: CoreCommandRouter::executeOnPlugin: mpd , getMyCollectionStats
Dec 01 06:19:56 volumio kernel: usb 1-1: USB disconnect, device number 6

Moved this to the correct topic, as it’s x86 related.
Please create a new log and make sure to stop after the error, dont’t fix it.

1 Like

I installed Volumio on a Lenovo ThinkPad 10 tablet. Everything’s fine. USB signal to Arcam irDac. The touch panel works. Now what’s missing; - there is no on-screen keyboard available. Is there any plugin for this? - Is it possible to somehow set the size of the interface to make the subtitles larger? The album covers are a good size. Are there any other useful plugins? How to install plugins that are not in the settings?

And for bigger font-size look at the “Now Playing” plugin.
Because the tablet has a high resolution compared to it’s size, it’s very very small.

Good to see everything is working, for sure a great device (especially with the dock) to run Volumio.

Provide example settings for the now playing plugin. I change the font and nothing changes. For example, I entered 20, 24, 30. Do I have to restart after each change?

I cannot install the virtual keyboard. Message that the product is unavailable.

Did you hit this button?

1 Like

you have to add px after the value


the playlist still has a very small font

to change this you need to break in to vanilla coding, which I will not support. Sorry

I cannot install the virtual keyboard. Or maybe this method was good for volumeio 2