X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

I did a reboot after the last json change… So something seems still not to match…

yes, that can be corrected, it can basically be any name we choose. Volumio maps on device number and displays whatever is in cards.json.

I will try with “name”: “SoundCard [Xonar SoundCard]”, {…}
It seems like there is an issue with identifying the card by correct the name (?)

No, that won’t work, you will need either “SoundCard” or “Xonar SoundCard” (with a capital C for card).
Don’t use what you see in aplay -l, it does not work that way.

Thanks for the remarks what does not make sense to try. That makes it easier to focus on what could make sense.

Both suggested variants we tested, but result KO. Strange that it works on command line well.

aplay -D plughw:SoundCard,2
aplay -D plughw:SoundCard,3

Unless you have some other good idea i will continue to try out some things.
If i get some success i will of course let you know.


The “HDA ATI HDMI” card I added, now gives “HDMI 0” and “HDMI 1”
So it should be “Xonar SoundCard”, anything else cannot work.

cards.json (2.9 KB)

Unfortunately nothing changed after applying the new json and reboot.
Only the devices of the type “plughw” are to be taken into consideration , right?

No, the plughw name is only a parameter for the aplay cli command, it has nothing to do with the way Volumio handles it internally. It needs the full card name (which is “Xonar SoundCard”), uses it to map with an entry in cards.json and matches device number with prettyname (the name which is displayed in the dropdown list).
So if you would select “USB Audio #2” (when it works), it would take subdevice 2 to stream to.

I fear there is an incompatibility somewhere, remember, we never enumerated usb audio subdevices before. Need to have a talk with the devs.

My card.json file had a typo (getting too late)!!
Correction cards.json (2.9 KB)

YES! Awsome! Now i see the 4 entries in the dropdown, and i do get light on the optical output when i play some mp3.
I will test maybe later or tomorrow if the light also turns into sound, as i dont have it plugged into the receiver currently which is in another room. But light should mean also sound.

For now i assume that it works. But i will update here on the final results.

Will this enhanced config be added to future releases some day?
Until then, as a workaround, I know now how to apply it manual by adding the line.

Thank you so much for your support.

Sorry about the hacking, doing other things at the same time made it complicated, combined with my typos.

Yes, some day, there is no guarantee it will get to the next release, but I will submit a patch after you tested tomorrow and then try to push it through.

I would like to know which subdevice does what, presumably 2 and 3 are spdif, but is there a difference? I would name the subdevice accordingly, otherwise just spdif #1 and spdif #2.

Are 0 and 1 perhaps for analog output? I don’t have such a card, thats why I’m asking.

Meanwhile use the cards.json file you have now.

That is what i will update after the test. I can only guess that the toslink might have a “line in” and a “line out” mode. So i assume that one of the two sub devices will not play, but the other one will.

I will update my results here for sure.

As this is one of the few sound cards available to buy on the market for a quite fair price which has a set of higher quality chips (Cmedia CM6620A - up to 192KHz/24bit + S1220A - up to 32-Bit/192 kHz) + does fit into a small case due to low profile format, i think adding it to the official distribution could be a benefit for some other users as well, when they plan their hardware build.

It will be done, don’t worry.
It is low hanging fruit, which improves usb sound card support on x86 in general.

Now i tested it to be sure it works perfectly.

USB Audio #0 → analog line out - sound works
USB Audio #0 → no sound (i assume it is analog “line in”?)
USB Audio #2 → optical line out - sound works
USB Audio #3 → light on but no sound (i assume it is “optical line in”?)

Thanks again !

Right, thanks!
I will only configure the ones that were confirmed to work and call them
“Xonar Headphone/ Analog out”
“Xonar S/PDIF (optical) out”

Reconfig the alsamixer does solve it.
But it looks like it’ needed everytime after rebooting the nuc.
But if thats all…i can life with that

@Wil Just post the system log, then we can figure out how to get this enabled out-of-the -box and avoid having to touch alsamixer at all. So far that has been realised with a load of other soundcards.
You would do other users with a similar nuc a favor :wink:

My older mini pc runs Jriver. Now I created a Volumio usb stick but, and I remember this problem, the stick is not recognized due to the older hardware.
Whatever I try, tried Belena, Ventoy and Rufus no success.

How do I install Volumio now?

@kees_flower “My older mini pc runs Jriver” and “the stick is not recognized” are not much help, there are ten thousands of different pc’s and even more sticks on the market.
Please give some more info, or we won’t get anywhere.
At least give brand, model and anything else which could help to identify your PC.
Is USB boot enabled in your BIOS?
Does the PC show anything at all on the screen?

PC works, usb boot is on. It just gives me the error: no boot system. It is a DQ55 mainboard, it needs the older usb stick alignment to be recognized by the bios.