X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

so RPC pipe file system not able to mount is a VM issue?

ill copy the vm to a new vm setup but dunno how it broke was working then power out and volumio broke after the power out
re downloadining a new version of volumio to copy in its place to see if the configuration is broken

again, volumio didn’t break, your vm setup did.
My last comment.


I have a Wyse 3040 with the built-in WiFi (it’s an M.2 SD card - “SDIO standard”, as this thread says “who knew?”).

I just installed Volumio on it - goal is to get it working as a Roon bridge, and to be honest I’ll likely use it minimally other than as a Roon bridge, I just thought Volumio might be easy.

It works great over ethernet, simple set-up, just as desired. But every time I try to turn on wireless networking I get the little grey modal that says “Wireless networking successfully restarted!” and then the page refreshes, and wireless networking is turned off. So it never gets an IP address / registers on the network. I’m hoping the answer isn’t “just get a WiFi dongle” because part of what I love about the form factor is that it’s so durable and can handle being knocked about (at least a little) without getting powered off or otherwise bothered - in a way that RPi’s and other similar small devices do not. Right now I just have power and the USB headed to a DAC, and all that is fairly secure - a dongle seems unlikely to be.

Any thoughts? Thank you!

Yes, I’m aware of the original M.2 wifi module in the Dell Wyse.
It is an Azurewave AW-CM389MA which is, as you mentioned, an SDIO version. You need to be careful, not to use the PCIe version, which stupidly is also identified as CM389MA.
I never tested with it, so have no idea whether the necessary driver and firmware are present.
These modules are nearly impossible to get hold of.

Could you please boot the Dell Wyse and, when done, submit a log and post the URL here?
How to submit a log

I’m curious to see whether we will find this line in the log to start with

mmc1: new ultra high speed SDR104 SDIO card at address 0001

Thank you!

Ok, I had some progress. I reflashed, and this time, after some fiddling about, I was able to enable wireless networking and it “stuck” (eg, it didn’t turn the toggle off again a few seconds later). However, now when I try to join a network it says “wireless networking restarted” and never successfully joins. I’m fairly certain I’ve typed the correct password - several times. No idea why it worked this time!

And yes, at least this time, the line you were looking for appears:

Nov 06 19:28:57 volumio-wyse1-wifi kernel: mmc0: new ultra high speed SDR104 SDIO card at address 0001
Nov 06 19:28:57 volumio-wyse1-wifi kernel: mmc1: new HS200 MMC card at address 0001

Thank you for your help with this!


The result looks like this. Maybe the drivers are there but they’re not working as desired?

Nov 06 19:34:28 volumio-wyse1-wifi wpa_supplicant[3051]: wlan0: Trying to associate with 74:ac:b9:c1:7b:f1 (SSID='ign@tz' freq=2462 MHz)
Nov 06 19:34:28 volumio-wyse1-wifi kernel: mwifiex_sdio mmc0:0001:1: wlan0: changing to 2 not supported
Nov 06 19:34:28 volumio-wyse1-wifi wpa_supplicant[3051]: wlan0: Association request to the driver failed
Nov 06 19:34:28 volumio-wyse1-wifi kernel: mwifiex_sdio mmc0:0001:1: wlan0: changing to 2 not supported

Update: 30 minutes later I came back, and WiFi had connected. I’d kept the password in. Eventually it worked. Everything was wonderful. And so I tried rebooting to see if it was stable. Nope, now I can’t turn networking on again - so it can’t even see the available networks, let alone connect.

I believe we had a case like this

Can you make sure you create a partition table before you create and format a new partition? Use gparted. Volumio currently won’t automount a device without a partition table (which is rare, but sometimes people forget it).

This issue has been logged, it will be checked whether a device can be automounted even when a partition table is not present.

Do you create a partition table? Creating a partition and formatting it does not suffice.
Windows does not support ext4.

Then could you please boot without the disk connected, wait until Volumio is up and running, then insert the disk.
Could you submit a log following that?
How to submit a log

You should not touch /data/INTERNAL, you do not need to mount anything yourself.

Volumio is not Ubuntu and not meant to create disks and partitions.
Please submit the log as instructed and post the URL.
We’ll take it from there.

Ok @gkkpch first, thank you - this is incredible support!

Second, I created logs again after getting WiFi to work - connected to network, accessed wirelessly without ethernet connected (I don’t know how) and then rebooting, and then it doesn’t let me turn on WiFi networking at all.


Looks like it can’t even find the device now.

Nov 06 21:02:43 volumio-wyse1-wifi systemd[1]: Starting Wireless Services...
Nov 06 21:02:44 volumio-wyse1-wifi wireless.js[2369]: WIRELESS: No wireless interface, exiting
Nov 06 21:02:44 volumio-wyse1-wifi iw[2380]: command failed: No such device (-19)
Nov 06 21:02:44 volumio-wyse1-wifi iwconfig[2383]: Error for wireless request "Set Power Management" (8B2C) :
Nov 06 21:02:44 volumio-wyse1-wifi iwconfig[2383]:     SET failed on device wlan0 ; No such device.
Nov 06 21:02:44 volumio-wyse1-wifi systemd[1]: wireless.service: Succeeded.
Nov 06 21:02:44 volumio-wyse1-wifi systemd[1]: Started Wireless Services.
Nov 06 21:02:44 volumio-wyse1-wifi sudo[2367]: pam_unix(sudo:session): session closed for user root
Nov 06 21:02:44 volumio-wyse1-wifi volumio[1950]: info: Discovery: A device disappeared from network
Nov 06 21:02:44 volumio-wyse1-wifi volumio[1950]: info: Discovery: Device volumio-wyse1-wifi disappeared from network
Nov 06 21:02:48 volumio-wyse1-wifi volumio[1950]: info: Discovery: Started advertising with name: Volumio-Wyse1-WiFi
Nov 06 21:02:49 volumio-wyse1-wifi volumio[1950]: info: CoreCommandRouter::executeOnPlugin: wizard , reportWirelessConnection
Nov 06 21:02:49 volumio-wyse1-wifi volumio[1950]: info: CoreCommandRouter::executeOnPlugin: network , getWirelessInfo
Nov 06 21:02:49 volumio-wyse1-wifi sudo[2388]:  volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/sbin/ifconfig wlan0

Sorry, I have no time for such things.
My goal is to support you with Volumio and x86 issues, not to teach you how to use ssh and the shell to create a partition table, ext4 partition and to format it.
I asked you to submit a log, so I can see what is happening with your disk.
If you don’t want to create one, then that descision is yours.

This can be a bit tricky at first.
Just reconnect with eth. Then switch of the hotspot and create the wireless connection.
Make sure to wait for the toast messages, especially after connecting to the network. Wait until networking has restarted AND the network settings page has been redrawn with the eth and wifi ip details.
When you don’t and reboot before that, the data may not have been saved properly.

This is not x86 platform related so I can’t comment on that.
Best to enter this in the general “Feature request” section.

Your choice, you don’t want to know why the disk is not accepted then, fair enough.

Found this:

volumio-wyse1-wifi kernel: mwifiex_sdio mmc0:0001:1 wlan0: renamed from mlan0

You’re lucky, a while ago someone had a Marvell Wifi card and the driver apparently used “mlan0” instead of “wlan0”, which we do not support.
It was fixed by adding a rule to rename a loaded mlan0 device to wlan0.
Otherwise the AW-CM389MA, which also has a Marvell chip, would not have worked with the Dell Wyse either.

That’s amazing. I tried to search for this issue, and couldn’t find it… do you know how to point me to the resolution? I wouldn’t know how to create such a rule.

You do not need the rule for Volumio anymore, it is now a standard build rule in the x86 Volumio images.
But when you insist and need to use it for something else, then I would need to look it up in my notes.

1 Like

This was my patch, adding a network link.

  log "Some wireless network drivers (e.g. for Marvell chipsets) create device 'mlan0'"
  log "Rename these to 'wlan0' using a systemd link"
  cat <<-EOF > "${ROOTFSMNT}/etc/systemd/network/10-rename-mlan0.link"

Yes, the label needs to be one of

"issd", "ihdd", "Internal SSD" or "Internal HDD"

anything else will be skipped, just to make sure that other internal disk devices are not scanned, which can be unneccesary, time-consuming and even unwanted (think of an internal windows disk with its huge list of short beep and whistle sound files becoming part of the music library).