X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

I am writing to understand why Volumio OS latest version does not recognize the Mini PC’s internal wifi card. The wifi card is a Realtek 8821CE Wireless LAN802.11ac PCI-E NIC. I tried two external dongles and Volumio sees them and I can connect with wifi, but when I remove the dongle, Volumio doesn’t see the internal wifi card. Even if I try to restart and select the wifi network it doesn’t see the internal wifi card. Compatibility issue with Realtek chip 8821CE? Someone have the same problem? Thanks

Very simple just finish the first configuration wizard on your phone or PC, then once done, restart the system.

I recommend doing a factory reset before doing that, as you’ve installed some custom stuff which will break updates otherwise.

This won’t help. The graphics device on a NUC11 is not supported with our 5.10 kernel, the NUC is too new for it.
Volumio on a NUC11 will be headless for the current versions and nothing quick can be done about it.

1 Like

Please submit a log as explained in this guide.
I’m sure the RTL8821CE driver was enabled in the kernel, but perhaps the log can tell us whether the card was not recognized or the driver failed loading the corresponding firmware.
I have not seen a Volumio installation with this PCIe module yet.

You could also try the version as mentioned in the link below.
It is a beta version, not with the latest Volumio functionality, but good enough to check if your issue would be solved with an upcoming release (note, no ETA!).
Let us know.

Link to the beta version with kernel 6.1.y with latest drivers and firmware.

I misinterpreted then…

You could try the version as mentioned in the link below.
It is a beta version, not with the latest Volumio functionality, but good enough to check if your issue would be solved with an upcoming release (note, no ETA!).
Let us know.

Link to the beta version with kernel 6.1.y with latest drivers and firmware.

Thank you. I just made all you told to me. Now i try beta version with kernel 6.1.

No, you didn’t :wink:
You forgot to post the log link here as decribed in the guide…

Sorry. I posted the log link on help support. The log link is: http://logs.volumio.org/volumio/YYzwiUt.html
Thank you.

In the meantime I installed the beta version kernel 6.1 on a USB stick and started Volumio (without installing it on the disk). Works great with the internal wifi card. Furthermore, at startup the Volumio graphic screen is displayed on the PC where the USB stick with Volumio is inserted. However, the problem of the WiFi card not being recognized occurs when I install Volumio on the hard disk (starting the installation from Volumio already installed on the USB stick). I can’t understand why.

Thanks for the Beta Version of Volumio.

WebUI via HDMI Works on the Beta But Only After Rebooting a Few Times.

Upon Booting, Sometimes It Gets Stuck on the Grey Screen and the Other Times It’s Just a Black Screen and Nothing Else.

1 Like

Incredible now it doesn’t work with internal wifi card while Volumio is on USB stick.

it’s not recognized, or are you unable to connect to your network?
if the latter, disable hotspot, reboot and test again.
If I recall correctly I had similar issues when testing Kernel 6.1

When hotspot was active, I could not connect to the network, SIDD’s didn’t even show up.

Internal wifi card is not recognized. On Volumio network page I have only wired connection with a correct ip and the wireless connection that have an inexistent ip on my network . I just tried to activate wireless and then reboot, but i have the problem that the wireless ip is the same (inexistent). Then i tried to install the Volumio img file (kernel 6.1) to the hard disk with balena etcher, but nothing. I haved only the result that i can see the Volumio graphic screen displayed on the PC where the USB stick/HD with Volumio is installed. With Volumio version VERSION: 3.546 downloaded from the site i can see only first text page (login).

Would you please submit logs when something does not work?
Submitting a log after a change with a positive result is a plus.
Without logs, it just ends up in guess work, which helps no one.

As for your first log, that did give very useful information.

Oct 24 14:31:24 volumio kernel: rtw_8821ce 0000:01:00.0: rfe 6 isn't supported

This means the chip revision of your 8821ce module is not supported with kernel 5.10 in the current Volumio versions.

It also shows the following

Oct 24 14:31:24 volumio kernel: i915 0000:00:02.0: Your graphics device 4e61 is not properly supported by the driver in this
                                kernel version. To force driver probe anyway, use i915.force_probe=4e61
                                module parameter or CONFIG_DRM_I915_FORCE_PROBE=4e61 configuration option,
                                or (recommended) check for kernel updates.

This means your graphics device is not supported either, that is why you will not see the UI on the PCs hdmi connection, this cannot be corrected for the current Volumio versions, it would need a Volumio x64 OS update.
(Which is what the beta version is about).

So, please submit logs for the issues you have with the beta, not here, but in the thread where you downloaded the beta from.

I solved, but only with your .img file (kernel 6.1), in this way.

  1. i mounted img file with balena etcher on my ssd.
  2. from ssd i installed Volumio.
  3. i disabled hotspot option in Volumio.
  4. restarted Volumio.
  5. activated wireless network.
  6. restarted Volumio.
  7. only now i can see the list of wifi networks.
  8. then i selected my wify and then inserted password.
  9. restarted Volumio
  10. only now i have my wifi connection.
  11. disconnected the LAN cable.

Without restarting Volumio it’impossible to activate internal wifi card (while with a usb wifi dongle isn’t necessary to restart Volumio).

Now all is perfect, thank you for your beta version.
I send my log with beta version fully working.
Thank you very much, i’m sorry for my orrible english…


Thanks for your feedback, this helps other users reporting similar issues.

Just a warning, the beta cannot be updated to a release version.
Once we release the 6.1.y based Volumio version (no ETA yet) you will have to reflash.

stuck on the grey screen only happens at first boot, this is a known issue for which we do not have a solution yet (happens with the released version as well).

@Wheaten Could you move this conversation to the x86 thread please?

Yes, i tried to update beta version and it’s impossible to do.
What means ETA ?
Thank you again.

ETA stands for Expected Arrival Time.
No ETA in plain english: we have no plan yet for release (though in this case it is certain it will come).