Lost ssd connection on change to new disk

If I recall correctly, you need to re-label drive to “ihdd” or “issd”

Right, I recall that issue now. But it seems not enough, the disk is still not recognized. When I searched for “issd” in the forum threads, some people mention that it also must be formatted in a certain manner.

The disk works just fine on my laptop, btw.

It would be good if someone from Volumio could clarify what the issue is with 2TB SSD’s-

Yesterday, I revived an Rpi4 with the latest volumio. Same result
I will try to create a dedicated entry in the fstab, this helped in the past, when there were problems with ssd disks in general.

Well, creating a manual fstab entry definitely solved the issue on the Rpi4. So, this must be a bug or limitation of Volumio.

I’ll wait over the weekend for replies. Perhaps there is a better way to solve the issue on the Rivo than tinkering with fstab :grinning:

Please let us know, which exact usb enclosure/ adapter you are using with the 2TB SSD and whether you used the same for the 1TB version.

Thanks for your reply. I use two different SATA adapters:
Both are from Inateck, see https://www.amazon.de/gp/product/B01E3QSG3Y/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1 and https://www.amazon.de/gp/product/B01ESQZG6Y/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Both work well with the 1TB disk.

Looks like your drive is not recognized at all.

Maybe a power issue? Do you have a powered USB HUB? If yes, can you try connecting the HDD via the hub?
If not, can you try another USB port?

Thanks for coming back!

I am not sure whether it is a power issue. After all, I got the 2TB disk to work on my Rpi4 with an explicit entry in /etc/fstab that contains the uuid of the disk. I can try the same with the Rivo, but I am a bit reluctant to tamper with it.

Unfortunately, I don’t a have a powered USB hub at hand. And the Rivo has only one USB port for input, right?

Yeah I would advice against using an entry in FStab.

Rivo has 2 ports. Maybe try to change also the label of the disk?

Rivo has 3 USB ports, one optimized for a DAC (but you can try it), and two for general-purpose

the port closer to the Ethernet port has higher current capability

Thanks for your suggestions.

I had re-labeled the disk to “issd” already.

I had used the USB port close to the ethernet port so far.

Now I tried the *middle" one, but same result, no connection.

Can you try that:

  • Power on Rivo, without the 2TB attached
  • 30 seconds after the LED becomes Blue, attach the drive
  • Send us a LOG and paste link here

Let us know which format is the HDD




The disk is formatted ext4 (like my 1TB which gives no problems)

I think I have seen this before.
Could it be, that the ssd does not have a partition table?

Indeed, the disk has no partition table. This must be problem.

However, on my Ubuntu laptop the disk is auto mounted …

Volumio is not Ubuntu :wink:
My post above describes the mechanism, it also triggers scanning the drive.

I see. Thanks for the explanation

It works now, the issue was correctly identified. Thanks a lot for your help!

Would it be possible to document in the operating instructions that ssd’s connected via USB need a partition table? The issue is slightly subtle and it took a little while to figure it out …

Thanks again & Best Wishes
– Reiner

1 Like

Well done Gé!

Maybe at this point we should fix the mounting code so we take into account also this scenario.