X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

I have a Z83II box, which runs Volumio3 (beta version currently under testing) well. In any case, it’s simple enough to try running from a USB flash stick without installation to the hard disk.

Hi and thanks for the answer.

I ask because i have not yet bought the machine.

In case you confirm that you could provide me with the beta version I would buy it.



The latest volumio 2 version available does not work with the z83: it does not recognise the wifi hardware.
Could you please let me download Volumio 3?


If you encounter problems then please respond in that thread (making sure that you read carefully about what info you need to provide, including how to post a system log).

Hi again,

Still problems with the wifi
I get this message:

I do mot know if anything can be done

I think that something might possibly be done, and that @gkkpch might well be interested in your problems with this device. Please have a look at this post, and add your device details and problem (wifi). It is important that you read the first post carefully, and add all the requested information.

Yes, this is a typical symptom of a missing driver, actually more likely missing firmware, for the embedded wifi hardware module.
Without the info @chsims1 pointed to, there is nothing much that can be done.
Please use the referred post, also to prevent other members getting similar issues in the future.

Dear all,
after 1 year I have retried with the installation of the latest version of Volumio (Volumio-3.378-2022-09-30-x86_amd64) and faced the same problems with the wifi (same error message received)
Following your instructions I have created a log file: http://logs.volumio.org/volumio/6D6QW65.html
Please let me know if you think that the issue can be solved or if I shall leave aside the installation on this HW. If I you need more support from my side I will give.
P.S. with the LAN cable connected the system works, only for test since I cannot leave the cable pass by.
Thanks for your kind support.


Did you read the topic as previous requested?

  • You gave full image name
  • You gave the log
  • but missing the Output from “lspci” and “inxi -Fxxxz”

I looked at the log and apparently it complains about an unrecognized wireless (version?) chip.
As @Wheaten mentions, output from “inxi -Fxxxz” would be welcome as it will report the hardware details like network components etc.
Looks like Bluetooth fails for similar reasons.

I have read that inxi -Fxxxz is a tool to get info from the configuration of the system.
Is there a post on how to use it? Or a step by step procedure.

just open a ssh connection to your device and type:
inxi -Fxxxz

I am building a kind of colture on this, at least for me.
I have installed Open SSH client and server on Windows.
I have opened the terminal and digited: ssh volumio@
the system asks for the password; I have tried with “volumio” and “Volumio”, but these are not recognised as correct password…

For some reason I doubt the the given IP is correct. is the machine where you opened the SSH session.
You need to enter the IP of volumio.
So type
ssh volumio@<ip of volumio>

There is no need to install the server part as your windows machine will not act as a SSH server.


Where do i find the IP of Volumio in the system?

I would turn IP- Automatico on.
You can’t just enter some random values and expect it will work.

  • You can only reserve an address if your router can handle this, or set the address fixed in the router matching your network topology;
  • You can’t have a DNS like
1 Like

Previous log says the ip address was
I suggest to re-flash the usb stick and boot with ethernet (LAN) connected.
In a normal situation you would get the same ip address again.
Then enable ssh and use it to get the inxi info.