X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

thank you all for your support.
I found the IP address into the router set up page:
here below the output of inxi -Fxxxz

It did not report any wireless device, so I googled the error from your logfile

brcmfmac: brcmf_chip_tcm_rambase: unknown chip: BCM43454/6

The driver obviously needs an an update, which is not included in the current kernel.
According to the information found, the update was introduced with kernel 5.15.
Unfortunately we’re still on 5.10

End of October there was another report, about a Realtek wireless device with a chip revision for which there is also no driver support in 5.10, but with an updated driver in kernel 6.0
For this I tested kernel 6.0, it works perfectly.

This would also solve your issue, I will probably ask you to help testing it.
First kernel.org has to confirm the next Long Term Support kernel version to be 6.0.
Presumably this will happen some time this month as stable version 6.1 is about to be released.
After that I will plan the update.

Of course I will test it!
have a nice week end.

Done

Volumio Version: 3.378
Hardware: Sony VAIO FZ31B (Very old system)
DAC: Audio Breeze DAC PD-001 and FIIO Q1

Steps to Reproduce

  1. Start system with Audio Breeze DAC and volume is very low
  2. Unplug first DAC and plug in FIIO DAC on the same USB port (if plugged in on different USB port, wont be able to playback songs, play button wont respond) then the volume would be loud
  3. Plug Audio Breeze DAC again (same USB port) and volume would be loud as well but upon restart volume will be very low again

*** Adding to this issue is, whenever I change something on the settings, play button would stop responding for like 3 minutes and media folder won’t display anything, no icons, no nothing. But I guess that’s for a different topic.

My FIIO DAC is used when I travel, since its a mobile AMP/DAC and the Audio Breeze is the one for my home setup. I’ve used these DACs on other systems and never had any issues, but Volumio is just beautiful and has almost everything I wanted for a media server/streamer and sounds really awesome compared to other software media streamers. I hope this gets fixed. :slight_smile:

btw, FIIO DAC has a volume control while Audio Breeze one does not.


I use a budget DAC like yours in my cellar when listening to webradio. Using an x86 installation, never had an issue with it.
Keep volume control as “hardware” and you should be fine. No idea were else this volume change would come from.

Nice! Thanks @gkkpch

I will try a fresh install, and I mean fresh. Like everything formatted.

btw, checked my settings and mixer type is set to hardware and everything else is set to default.

Did a fresh install . . . Volumio drive and the USB stick I used all reformatted.

Same thing . … but I found a fix! I have to unplug and re-plug the USB cable from the DAC and magically volume would normalize.

Not really sure what’s happening . . . easy fix, so I’m sticking with Volumio!

Thanks again @gkkpch!

Hi @gkkpch!

Just a quick question?

How long does your system boot Volumio up?

Thanks!

With x86 this is very device/configuration dependent, the mentioned x86 device boots in approx 30-35 seconds. Its an Intel Atom, devices with faster cpu/memory will do it in 20-25, but also depends on the amount of subdevices which need to be initialised and drivers to be loaded

I still have this low volume on my Breeze Audio DAC.

Not sure if this will help but I did a dmesg | tail upon bootup while volume is low and this is the result:

volumio@volumio:~$ dmesg | tail
[ 27.698181] intelfb: Version 0.9.6
[ 31.216396] wlan0: authenticate with e8:01:8d:61:be:b4
[ 31.219783] wlan0: send auth to e8:01:8d:61:be:b4 (try 1/3)
[ 31.220344] wlan0: authenticated
[ 31.223844] wlan0: associate with e8:01:8d:61:be:b4 (try 1/3)
[ 31.224655] wlan0: RX AssocResp from e8:01:8d:61:be:b4 (capab=0x11 status=0 aid=3)
[ 31.225853] wlan0: associated
[ 142.075103] Bluetooth: RFCOMM TTY layer initialized
[ 142.075113] Bluetooth: RFCOMM socket layer initialized
[ 142.075121] Bluetooth: RFCOMM ver 1.11

Now, unplugged the DAC and plugged it back in and result is:

volumio@volumio:~$ dmesg | tail
[ 241.162298] usb 6-1: config 1 has an invalid interface number: 3 but max is 2
[ 241.162302] usb 6-1: config 1 has an invalid interface number: 3 but max is 2
[ 241.162306] usb 6-1: config 1 has an invalid interface number: 3 but max is 2
[ 241.162309] usb 6-1: config 1 has no interface number 2
[ 241.187299] usb 6-1: New USB device found, idVendor=262a, idProduct=9023, bcdDevice= 0.01
[ 241.187304] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 241.187308] usb 6-1: Product: Bravo-X USB Audio
[ 241.187311] usb 6-1: Manufacturer: SAVITECH
[ 241.193817] input: SAVITECH Bravo-X USB Audio as /devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/0003:262A:9023.0004/input/input14
[ 241.251384] hid-generic 0003:262A:9023.0004: input,hidraw0: USB HID v1.00 Device [SAVITECH Bravo-X USB Audio] on usb-0000:00:1d.1-1/input0

Now volume is good.

Also, tried plugging the DAC on other USB ports and same result.

I am no Linux guy, but just hoping this has something to do with what’s happening to my system and maybe get this sorted.

it is of no use doing dmesg after the kernel loaded with the dac attached, you need a complete boot log.
Why not boot your device with the dac connected, then do the volume test, followed by an unplug/re-plug and repeated volume test.

Then create a normal volumio log and it will show exactly what happened since the start.

Howto: Send a log

Hi @gkkpch!

Thanks for the info! Here’s my volumio log:

http://logs.volumio.org/volumio/nlj4ZKx.html

@Wheaten could you move this issue to the x86 thread please.
Not confirmed that it is only an old Sony Vaio x86-specific issue, but could be.

@Jo_Arimbay: I’m not giving any promises to fix this.
Hardly used budget hardware on old hardware prevents me putting it high on my list, I hope you can understand.
Especially as it is working fine on a Dell Wyse 3040.

The log does not show anything unexpected.

Hey! That was quick!

All good @gkkpch! BTW, just upgraded to 3.396 just now.

If it gets fixed that’s awesome, if not, not a big deal. I still love volumio! hahaha

muchos gracias!

A post was split to a new topic: rPi kernel update question

The volume cannot be adjusted when the output is HDMI.
Volumio Audiophile Music Player for PC (X86/X64) VERSION: 3.396
other ok at the moment

including @gellert
No way to support you with that as I don’t have such a device to explore its capabilities (and have no intention acquiring one).
Do play around with mixers though, when you find one which makes volume control work, let me know.

I can confirm this.

Just downloaded Volumio for PC, flashed it on a USB stick, and tried to install on a new Intel NUC. I saw a brief Linux message about setting up Volumio, but then just a black screen. It sat there for 20 minutes doing nothing before I rebooted it and tried again. It still just sitting there with a blank screen. Over 10 minutes now. My router sees it and it has an IP, but I can’t access it via Chrome. Also, I get nothing from the Volumio app when it searches.

Am I supposed to be seeing something of this install process or is it completely invisible?