X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Cool. Will it be included in the next release?

I have an old Mini86 with 500 GB music files on the internal volume which i like to upgrade to Volumio 3.

Unfortunaly to backup the files over network with samba does not work. The connection always breaks due to timeouts.

Any recommendations how to backup the internal volume?

Guess the OS is on the same volume as the data files?
If so, then you can only do this over the network,
The timeouts, are you connecting via WiFi or copper.

Guess the OS is on the same volume as the data files?
Yes, correct.

The timeouts, are you connecting via WiFi or copper.

Would it be possible to connect an external USB hard drive and copy the data files over the shell to the external drive? If somebody could provide me the paths and commands? I have no idea where the data files are located.

If you connect a powered USB device this is possible.
You media is located at:

cp -r /data/INTERNAL /media/<name of USB thing>
1 Like

I’ve been using a 2006 MacMini with Volumio for years. It has 4Gb ram, Cor2Duo processor, 2.1Ghz type. In it, the system is set to a 1Tb SSD, music is everything. It drives a Topping D10 DAC, I have no problems with it except powering it up. You have to de-energize the thing for that, so I never turn it off. He has a beautiful voice and is also flashy. It has an external WI FI, and the internal CD DVD player plays CDs or rips them perfectly. Is breast better than this?

I had this error too. I solved my miniPC problem by changing the UEFI boot option (changeable) to traditional, old-fashioned Boot. From then on, all my problems were solved. My machine is a small Chinese machine. Your house is nice. I don’t know his name.


Hi Gé,
Experimenting to get OLED running on a x86 (HP EliteDesk…) machine, but run into a snag. Instead of me breaking things I thought let’s drop the question.
Need to run make to get a USB-I2C driver installed, but it keeps erroring out:

volumio@volumio-x86-s2:~/i2c-ch341-usb-master$ make
make -C /lib/modules/5.10.139-volumio/build M=/home/volumio/i2c-ch341-usb-master modules
make[1]: Entering directory '/lib/modules/5.10.139-volumio/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/lib/modules/5.10.139-volumio/build'
make: *** [Makefile:9: all] Error 2

Running V3.378,
uname -r = 5.10.139-volumio
Kernel headers = None.

if I run below command, only available 4.19.x kernel-headers are shown
sudo apt search linux-headers


volumio@volumio-x86-s2:~/i2c-ch341-usb-master$ sudo apt-get upgrade linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-5.10.139-volumio
E: Couldn't find any package by glob 'linux-headers-5.10.139-volumio'
E: Couldn't find any package by regex 'linux-headers-5.10.139-volumio'

Any safe way to get the correct headers loaded (V5.10.139)?

let’s take this on PM and report the results here (when we have some) as I’m fairly busy with things besides x86 support. Can take some time…

Thanks for your support, Loading the kernel modules and creating the symbolic link did the trick.
USB driver is loaded and device is recognized:

Bus 003 Device 003: ID 1a86:5512 QinHeng Electronics CH341 in EPP/MEM/I2C mode, EPP/I2C adapter

volumio@volumio-x86-s2:~/i2c-ch341-usb$ ls -l /dev/* | grep ch341
crw-rw---- 1 root ch341   254,   0 Nov 24 14:40 /dev/gpiochip0
crw-rw---- 1 root ch341    89,   9 Nov 24 14:40 /dev/i2c-9
volumio@volumio-x86-s2:/dev$ sudo i2cdetect -l
i2c-3   i2c             i915 gmbus panel                        I2C adapter
i2c-1   i2c             i915 gmbus ssc                          I2C adapter
i2c-8   i2c             AUX C/port C                            I2C adapter
i2c-6   i2c             i915 gmbus dpd                          I2C adapter
i2c-4   i2c             i915 gmbus dpc                          I2C adapter
i2c-2   i2c             i915 gmbus vga                          I2C adapter
i2c-0   smbus           SMBus I801 adapter at f040              SMBus adapter
i2c-9   i2c             i2c-ch341-usb at bus 003 device 005     I2C adapter
i2c-7   i2c             AUX B/port B                            I2C adapter
i2c-5   i2c             i915 gmbus dpb                          I2C adapter

Hi I’m not sure this is the right place to post this, but i am really struggling to install x64 volumio on a HP t520 thin client. I know the t520 works because it boots other img files and i already have one running volumio 3.0. I looks like the issue might be multiple partitions that are created on the usb drive when the image is burned to it.

Do you know of an issue??


How are we supposed to help with “it’s not working”, surely you can do better than that😉
What do you mean with not working? Not booting? Stops with error message(s)? Nothing happening at all?
Why do you think the partitions are the issue?
Volumio has 3 of them.

You know something forget it, I’ve fixed it, there is no need to be so rude!!

when you feel this was rude, then sorry. But asking for help without supplying information is not very clever either. Curious to hear your solution, others could profit.

1 Like

You should read my original post I never simply said it’s not working. I said I was struggling to install so that’s clearly a boot issue isn’t it, as for telling you how I fixed it you’re obviously the smart arse you figure it out. What a uplesent little man you are

1 Like


Not sure if your complaint in regards to be rude is valid, looking at your reply.
At least @gkkpch apologized if the reply sounded to harsh.
Please keep in mind that people support you in their free time and only request adequate information.

Your info is very limited, like HP t520 and doesn’t boot.
For us there is no way to support it.
you made a remark:

Did you read the topic header yourself?

If you want to reply, I am open to it. But please react wiht some decency.

Hi i install the so in win but cant see interface. I can in webui but no in laptop screen

I presume you installed on a usb stick and booted from there on your laptop?
But that is pure guessing. You need to tell us a bit more, to be able to help you. Which laptop, which version of Volumio?
Look in thread X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)
Read the first post, it tells you what we need.
Then add your issue as a new item.
Report back in case you get stuck


Just got a TP-Link AC1300 MU-MIMO USB adapter, which I can setup and connect to my wireless network. However after every reboot the connections is lost. No clue why?

Version: Volumio V3.378-x68
Log: http://logs.volumio.org/volumio/R9tGCD6.html

volumio@volumiox86:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 36)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 36)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 36)
00:11.0 SD Host controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SDIO Controller (rev 36)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 36)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 36)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 36)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 36)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

inxi -Fxxxz:

volumio@volumiox86:~$ inxi -Fxxxz
System:    Host: volumiox86 Kernel: 5.10.139-volumio x86_64 bits: 64 compiler: N/A Console: tty 0 dm: N/A
           Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop System: Dell product: Wyse 3040 Thin Client v: N/A serial: <filter> Chassis: type: 3 serial: <filter>
           Mobo: Dell model: Cherry Trail CR v: A00 serial: <filter> UEFI: Dell v: 1.2.4 date: 01/18/2018
CPU:       Topology: Quad Core model: Intel Atom x5-Z8350 bits: 64 type: MCP arch: Airmont rev: 4 L2 cache: 1024 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11520
           Speed: 609 MHz min/max: 480/1920 MHz Core speeds (MHz): 1: 525 2: 872 3: 848 4: 888
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers vendor: Dell
           driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b0
           Display: tty server: X.org 1.20.4 driver: none unloaded: fbdev,modesetting,vesa tty: 143x24
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: cht-bsw-rt5672 driver: cht-bsw-rt5672 message: bus/chip ids unavailable
           Device-2: Intel HDMI/DP LPE Audio driver: HdmiLpeAudio message: bus/chip ids unavailable
           Sound Server: ALSA v: k5.10.139-volumio
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: e000
           bus ID: 01:00.0 chip ID: 10ec:8168
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: TP-Link type: USB driver: rtl88x2bu bus ID: 1-4:3 chip ID: 2357:012d serial: <filter>
           IF: wlan0 state: up mac: <filter>
Drives:    Local Storage: total: 7.28 GiB used: 3.10 GiB (42.5%)
           ID-1: /dev/mmcblk1 model: H8G4a size: 7.28 GiB serial: <filter> rev: 0x8 scheme: GPT
Partition: ID-1: / size: 3.61 GiB used: 2.21 GiB (61.3%) fs: overlay source: ERR-102
           ID-2: /boot size: 168.4 MiB used: 61.2 MiB (36.3%) fs: vfat dev: /dev/mmcblk1p1
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 165 Uptime: 4m Memory: 1.86 GiB used: 365.9 MiB (19.2%) Init: systemd v: 241 runlevel: 5 default: 2
           Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32

volumio@volumiox86:~$ sudo lshw -C network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 15
       serial: 54:48:10:e8:2c:0a
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.10.139-volumio duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:16 ioport:e000(size=256) memory:91404000-91404fff memory:91400000-91403fff
       description: Wireless interface
       physical id: 1
       bus info: usb@1:4
       logical name: wlan0
       serial: 1c:61:b4:7b:45:70
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl88x2bu driverversion=5.10.139-volumio ip= multicast=yes wireless=IEEE 802.11AC

Currently solved by doing a factory reset.

Can you conforme that the mini pc model z83f is compatibile with volumio?

Thanks and best regards

|Dimensioni del collo|‎20.6 x 13.2 x 5.8 cm; 600 grammi|
|Fattore di forma|‎Fattore di forma ridotto|
|Marchio processore|‎Intel|
|Tipo processore|‎Atom|
|Velocità processore|‎1.92 GHz|
|Numero processori|‎4|
|Dimensioni RAM|‎4 GB|
|Tipologia di memoria computer|‎DDR3 SDRAM|
|Dimensioni Hard-Disk|‎64 GB|
|Descrizione Hard-Disk|‎EMMC|
|Interfaccia Hard-Disk|‎USB 2.0|
|Coprocessore grafico|‎Intel HD Graphics 400|
|Descrizione scheda grafica|‎Intel® HD Graphics 400|
|Tipo memoria scheda grafica|‎DDR3 SDRAM|
|Interfaccia scheda grafica|‎Integrato|
|Tipo di connettività|‎Bluetooth, Wi-Fi|
|Tipo wireless|‎802.11bgn, 802.11ac|