Qobuz skipping to the next track early

I found this thread that seems to exactly describe my problem, but there is no resolution. I just cancelled Tidal in favor of using Qobuz with Volumio for my high res solution, so if we don’t have a fix for this, could someone please let me know if this a frequently-occurring problem? I can’t live with this long term.

If you don’t want to follow the link to the older thread, here’s the tl,dr: 1-3 times per album, the track will skip ahead to the next track early. It happens on 16/44.1 and on 24/96+ albums.

Could it be caused by input from HDMI CEC or the wireless Logitech USB dongle?

Volumio Information

Volumio Version: 2.882
Hardware: RPi 4B, 4 GB RAM
DAC: Schiit Modi Multibit via USB

1 Like

There have been issues reported with the rPi4, WiFi and HDMI.

That’s interesting, but I’m hard-wired into my network. I do have a one of those cheap micro HDMI adapters, though. There’s visible noise on my TV, but it’s not a big concern for music playback. Maybe I’ll have more reliable performance if I unplug the hdmi and run in true headless mode?

Maybe the same “self-repairing-miracle” as mine…no issues since then.

1 Like

This was placed in your opening post, so I expect you run Wireless.
“Could it be caused by input from HDMI CEC or the wireless Logitech USB dongle?”

But if you don’t need HDMI, remove the cable.
Is the power to your rPi adequate. As this is also a cause for strange behavior when the voltage lingers around 5V

I also see this while streaming qobuz.

I am also using Rpi 4 but not hdmi or wireless.
DAC: qutest using usb from pi
Ethernet: 1 gbps into 100mbps fiber internet
No hdmi or wireless

Eh, I don’t need HDMI, but this is my first Pi, and was playing with the different features. At present, I was just using my TV as a non-touch “touch screen” so I could see the album artwork and bitrate as I listened.

So I unplugged that HDMI and we’ll see how it goes today.

As for power, I ordered the PSU that PiShop recommended: USB-C Power Supply, 5.1V 3.0A, Black, UL Listed - PiShop.us

Well those prices are much better then here in Europe.
We pay triple that amount.

Let’s see if an adequate PSU will solve your issues.

That’s the PSU I’ve been using. Does it look inadequate to you? I added the Pi 4B to my cart, and PiShop said I should also buy that PSU.

Nope, should do the trick. With the version Sold over here, there has been a batch with a lower output. Causing issues. As the voltage drops below 4.85V, the rPi lowered the max USB current, which caused a lot of strange behaviors.

I see more topics are opened regardig Qobuz. They are looking into it.

1 Like

Hi Jon,
I had the same Problem, with Qobuz and the Volumio Primo Hifi.
The failiure is to stream from the apple device with the Qobuz app, how I know after an interesting phone call withe the german importeur.
Streaming from the Qobuz app it isn`t HighRes and the Qobuz App for Mac skips to early.
You have to use the Volumio Webbrowser or the Volumio app and everything works gapless and in HighRes.
Hope that helps, Dirk

1 Like

Nah, I’m not using airplay. I’m using the volumio app.

1 Like

Another new observation: after the track skipped ahead early, the next track reported its play position incorrectly as well. But this time, it said I was about a minute into the 4:30 song when I was actually more than halfway through. When the song ended, the app indicated there was more than a minute left, but then it smoothly transitioned to the next track without any audible weirdness.

So… Somehow volumio loses track of where it is in a song. I can say that I was actively browsing and adding music to my queue when it skipped ahead. Maybe I need to stick to Spotify Connect when playing DJ.

still exactly the problem I had when I made the “mistake” to stream from the Macbook via Qobuz.
With the Volumio app, it doesn’t matter whether I use the iPhone or Macbook as a remote control.
I’m curious what comes out, Dirk


I unplugged all unnecessary peripherals and cables. I’ve been experimenting with audio buffer settings, and it doesn’t seem to make a difference.

This is really making me nuts because this morning I was able to listen to maybe 1.5 hours of music before the first track skipped. As soon as I heard it, my mood was spoiled, and now I’ve stopped my reading, put down my coffee, and here I am fussing with volumio settings and reading the forums. How much money do I have to spend to get something that is foolproof? I’m so over this…

1 Like

I am experiencing the same trouble . Tracks either stopping earlier or blinking (very annoying).

Using Volumio app for android, wired internet 1GB/s. Volumio Version: 2.882
Hardware: streamer: allo USBRIDGE SIGNATURE PLAYER (volumio)
DAC:Denafrips ares ii

Here’s a similar problem from a similar service:


This user has a lot more technical insight and he was able to solve his own problem. He observed that the problem of skipping tracks seems to occur on longer tracks (4 min +) and I think I concur. He also devised an experiment to reliably reproduce the error: pause playback for a few minutes, resume playback, and then the audio will play for a few more seconds before skipping to the next track. When I run this experiment on Volumio, I get the same result! It plays for about 20 seconds and then the next track starts.

Update: I installed BubbleUPnP Server on my PC and that is broadcasting Volumio as an OpenHome renderer on my network. I’ve been using BubbleUPnP on my phone to stream Qobuz to Volumio, and it works pretty well! I guess this is the old school way that lots of folks did it before Qobuz was fully integrated with Volumio?

Unfortunately, I’m experiencing exactly the same behavior when I stream it this way. After a couple of days without any problems at all, my playback skipped ahead to the next track without any input. Also, when I pause for four minutes and resume, I see exactly the same behavior: the buffer runs out and it skips to the next track.

My PC and my Pi are hard wired to my router. I even restarted the router for good measure.

Well, I found a rock solid solution that worked for me, and it involved switching to Moode Audio. I’ve set it up as an OpenHome renderer and I control it with BubbleUPnP on my phone. Being able to browse in the Qobuz app and use the “share” intent to queue/play tracks directly to the Moode player is the best experience I’m going to get outside of proper Qobuz Connect integration. I’ve been testing it for a few days and it hasn’t missed a best. It’s fast and utterly solid.

I’ll eagerly renew my Volumio subscription if Qobuz Connect is implemented, but I understand that the ball is probably in Qobuz’s court for that feature.

Hi there, I found a solution for me. Cancel Volumio. Download RopieeeXL (is for free/or pay as much as you want). Insert the microSD with the RopieeXL, insert it into my allo USbridge signature. Let the software install by itself. Connect Denafrips Ares ii. Open BubbleUPnP app on my Android phone. Select the renderer (RopieeXL-UPnP). Open Qobuz on BubbleUPnP, choose an album. Open a beer. Relax.
I have been trying and trying and waiting on Volumio. no good results for me. Thanks Jon_ss. I liked you input.