Mount Volumio across network to Mac


I have Volumio 2 running on a Raspberry Pi 3 and it’s working fine. I have a USB powered external hard drive attached with my hi-res music on it . All works fine.

What I’d like to be able to do is add new music to the hard drive on the raspberry pi without having to unattach it, plug it into my mac and copy across and remove and reattach to Raspberry pi.

The easiest way appears to be to mount the drives onto my Mac and drag and drop new music files. I can see the Volumio computer in networked devices but when I try and mount it it asks for a username and password. I have tried using the default ones: username: volumio; password: volumio but it doesn’t work. I have also tried the username and password I have selected for my hotspot - doesn’t work either.

Can anyone give me some idea what the (default?) username and password might be to allow me to do this or offer me another solution?

Thanks in advance


Hi! I’ll bump this question as I’m having the same problem… any workaround?

You can connect to Volumio SMB share as guest from macOS.

Should it work right out of the box? I installed the latest version and cannot access my USB stick via smb from mac; I can see it but accessing the usb drive is refused due to insufficient rights. :cry:
I edited some config files in an older version of volume to achieve this, but this was a bit complicated.

Hi Thanks - I was able to mount the USB disk on to hard drive this way. However I can not drag and drop anything on to the hard drive. It asks for a username and password to do this and when I put that in I get:

“Items can’t be copied to “Lossless” because you don’t have permission to read them.”

I can drag files off the drive to my desktop - just not the other way!

Any ideas?
Screen Shot 2017-09-27 at 17.06.22.png
Screen Shot 2017-09-27 at 17.06.14.png

Hi I can mount the USB drive now - thanks but I am also getting insufficient privileges when I try and drop a file on to it (it’s ok dragging a file off to the desktop though). It also asks for my Mac username and password just prior to attempting to copy the file across.

I have tried formatting the disk to different formats - Mac OS Extended Journalled, ExFat and Fat 64 and no joy. I have also tried changing the permissions of the disk on my mac and through SSH when connected in Volumio.

Any ideas? I’ve been trying to do this for weeks.



If you’re happy with the commandline, you can use ‘scp’ or ‘rsync’ to move files between your Mac and the Rpi.

Personally, I find it most convenient to manage my music library in iTunes (edit metadata, etc), and I use ‘rsync’ to propagate the changes to my NAS.

Sorry that’s a bit technical for me. Can you elaborate?

TBH if we could just unlock that drive when mounted on a computer so that we can add to the music library that would be the most seemless approach.

Hi all

I think I have sorted it.

Change the permissions of Volumio root folder:

sudo chown -R $USER:$USER $HOME

Then change permissions on the drive you want to share:

sudo chmod 777 /media/Music

Where Music is the name of my drive.

This seemed to work.

I then:

  1. followed these previously so am not sure if they had an impact: volumio-access-usb-drive-network-t4642.html - read very last post

  2. changed my drive format to Mac OS Extended (Non Journaled) using

I’d be interested to know if the last two steps were required or not.



Just done this for a second time and sussed it.

Take a drive, plug into mac and erase and format as Mac OS Extended (Non-Journaled (important)).
Mount new drive on mac directly.
Click/highlight drive on desktop
Go to Finder>File>Get Info (command i)
Change sharing and permissions: all must read Read & Write particularly Everyone.
Unmount drive
Plug into Volumio machine and voila

Dominic- Thank you for posting this! I only wish I had found it sooner. Would have saved many hours of poking around in Linux ( unfamiliar territory to me but now I know a little bit more.)

I can confirm that you DO need to format the USB drive as macos unjournaled. I used extFS for Mac as you recommended. Without this I could see my drive and sub-directories but I could not manipulate the files remotely from my mac. During my research I found that a mac cannot do chmode remotely on a FAT or exFAT formatted drive.

Aside from that I followed your description with two exceptions.
I had to do a restart after the chown command before I could continue.

And I used

sudo chmode -R ugo+w /media/volumename

after everything else in order to have write privileges on the sub-directories. The “-R” makes it recursive so it filters all the way down. Without that I could write to the drive but not into the sub-directory (folders).

Now I can manage everything remotely through the mac including placing newly ripped music into the collections I wish.
Thanks again!

1 Like

this is the only thing that worked

Hi Ken_Sky

Let me know how you get on with it. I’ve found it stops working after a reboot or software update (not sure) and then you have to reconnect direct to mac and follow “Go to Finder>File>Get Info (command i)
Change sharing and permissions: all must read Read & Write particularly Everyone.
Unmount drive
Plug into Volumio machine and voila”

God knows why!

1 Like

Hey - I just discovered syncthing and it solves this problem perfectly. It was really easy to install on both my Mac and the pi and just keeps everything up to date without having to do anything.

1 Like

Can you give us more details?

Hey, happy to If you can clarify what you’d like to know?

I just installed it on both Mac and raspberry pi according to the instructions on the website and it worked pretty perfectly out of the box.

What happens when you update the volumio system? Do you have to reinstall?

I don’t know what you mean here - I didn’t say anything about updating volumio.

You just need to install Syncthing