[3.512] Album ART & track info displays one track in front of whats playing


Volumio Information

Volumio Version:3.512
Hardware: RPI4
DAC: Topping D10

Debug Log


Steps to Reproduce

  1. Reboot, then load up a play list where the first track is longer in time than the second.
  2. Track will play, then ~6 seconds before the end of the track the album art will change to the next track.
  3. Then when the track actually changes it will display the album art of the third track. When the third track plays it then displays the album art and info of the 4th track...so on and so on...but Eventually it may sort itself out.

Additional Information

This device is behihind a firewall and is not connected to the internet., hence the paste site.
Web Album Art is OFF.

I initially came accross this bug 18 months ago Album ART displays one track ahead of whats playing and could not put my finger on exactly how to reproduce the bug.

I’m almost ( ha ha ) certain it is to do with track length in position 1. Start with a playlist where the first track is shorter than the second and this does not happen.
This will only happen on a cold boot or reboot. Press pause and go back to the first track it wont happen again.

1 Like

Had another look at this on the latest version 3.512 and its still a problem.

It is definitely to do with track length of the first track.
It happens from playlists, a persistant queue and even albums where the first track is longer than the second.
With abums its not as noticable as the album art does not change, but the track info is still one track ahead
It will remain displaying one track ahead until it comes accross a track that is longer than the previous then sort itself out.

I did a fresh install of 3.512, no plugins, no mods , just a vanilla install using manifest.
In the video below,(1Min) I chose the GnR album AFD as the first track is longer than the second.
Non persistant queue.

Reboot, search for album then play.
The displayed clock is synced with volumio clock (if that helps looking through the log)

At 00.36 (16:00:53) it change the track info to track 2 whilst still playing the rest of track 1
At 00.49 (16:01:20) the music changes to track 2 and also the info changes to track 3

I’m seeing similar behavior with similar hardware.

RPi4 into Topping E50 DAC.
Volumio version - 3.538

Also, countdown timer of current song seems to start relative to total time of first song.
Also if songs are different types the bit rate and type stays as per first track.

Queue a 44.1kHz 16 bit FLAC track of 5:20
Queue a DSD64 track of 3:10

Couple seconds before first track finishes, artwork of second track pops up and countdown timer range stays at 5:20 but counter starts somewhere in the 3 minute range. Bit rate and type display stay as 44.1/16bit FLAC for duration of song. Note: Bit rate shown on my DAC is correct so the file is being played as expected…

1 Like


To help the dev team you really need to upload a debug log.

Start by rebooting, recreate the bug, go to the /dev page and upload the log
More info here Sending logs for troubleshooting - Volumio Documentation

And thanks for posting :+1: Been thinking I’m alone on this one for the last couple of years

Another video and log ( better quality and with sound) 3:35 total, 5 tracks, bits in middle sped up
A playlist deliberatly made with a track list of descending track lengths. It will always display the info and art from the next track until you press stop, then start the playlist again.

rebooted, “clear and play” selected playlist
Log should be in sync ~ with time displayed in the video

13.26.53 Displays track 2 art while playing track 1
13.26.56 Displays track 3 art while changing to track 2
13.32.03 Displays track 4 art while changing to track 3
13.36.18 Displays track 5 art while changing to track 4
13.39.56 Displays track 5 art but does some thing spanky with the progress bar


Completely off topic…love your taste in music!

Just replicated bug in WebUI.

Log file: http://logs.volumio.org/volumio/5a2LYhB.html

Tracks in queue:

  1. “The Mole”, 44.1kHz | 16 bit, FLAC, 5:29
  2. " Riverside:, 2.82MHz | 1 bit, DSD, 3:06
  3. “Good Morning Judge”, 192kHz | 24 bit, FLAC, 2:56


  1. With 6 seconds left to play on track one (ie @ 5:23), cover art switches to track 2, file type switches to Track 2 (DSD).
  2. With 0 seconds to play, cover art switches to track 3, bit rate switches to Track 2, file type switches to Track 3 (FLAC). Track 2 plays, DAC shows correct bitrate for Track 2 and timer resets with 3:06 to play (correct for Track 2).
  3. When counter reaches 3:06, Counter goes back to 2:57 and continues counting, Track 3 starts playing. DAC shows correct bit rate for track 3.
  4. When counter reaches 3:06, it stops counting, display ceases to change. Track 3 continues to play until end.

Note: Subsequent uninstall of plugins, including crossfader did not fix issue.
Note: Factory Reset did not fix issue.
Note: Fresh install using v3.449 + manifest UI - did not fix issue

Just a random selection, although this is how I consume my music.
Depending what sort of mood im in, tracks that pop into my head get added to the queue.
I usually set persistant queue then after a few weeks save my queue as a playlist and start again. Then for the evenings where youre so done in, you want to listen to music to unwind just pick a random playlist and youre away.
Probably why Ive noticed this bug such a long time ago.

Same queue as above (descending) except…
I have created a silent mp3 file 900ms long and inserted it a position 1

This stops this issue from happening.


For what it’s worth…same issue happens with a Raspberry Pi 3B+

Also same results for the x86 version. Makes me wonder if the premium priced Primo does this too.

Been trying to have a look if this is also the case with earlier versions too. Its done it for me with all Volumio 3 versions I have tried.
So I tried the earliest version of Volumio 2 that I could find.Version 2.457 does NOT display this behaviour so is a bug introduced after then.

@volumio Please take a look.

To summarize…

The album art and info displays one track ahead of the actual track playing. ( see any of my videos )

To reproduce… boot or reboot and load an album, playlist, or even persistant queue where the first track in the queue is longer than the second.

This happens because first track in the queue is longer than the second. OR more likely the second track is shorter than the first as this continues to happen until the next track is longer than the previous.

Either… albums where the second track is shorter than the first. or…playlists where the second track is shorter than the first or… even the persisatnt queue.

I have tested the above using a playlist with descending track lengths. Simply by adding a track in position one which is only 900ms long will stop this issue.

http://logs.volumio.org/volumio/RIFlykX.html Queue with track lengths descending.

http://logs.volumio.org/volumio/yhj39m6.html Same queue but the 900ms first track and no issues.

I cannot see any difference between them, but i’m just a dumb muggle :slight_smile:

This bug is also present using a viarity of hardware, including the x86 version.

It is NOT present in version 2.457 but is in 2.773 and there after, obviously getting introduced some where between the two. I cannot narrow it down further as I do not have access to any version between the two.

Also thanks @dmonds for testing this on his equiptment.

1 Like

As stated here, I also have the same issue with a Raspberry Pi Model 3B+ with an Allo Digione.

Any updates on this bug? Is it possible to know if the Volumio team has taken it on and when can we expect a resolution? No rush on my part, just looking for reassurance that it’s on the list for work.

Thank you! :slightly_smiling_face:

I Originally Posted about this over 2 years ago.
Since then narrowed it down to being introduced into Volumio 2 between Sepember 2018 and May 2020 and being passed on to Volumio 3

Judging from that, I do not think its very high on their priority list, if at all.
Which is a shame, with screens becoming cheaper and easily attached to display what is playing especially with the “Now Playing” Plugin ( great work @patrickkfkan ) Will be noticed by more people.
Possibly leading to embarrassment of the Volumio name. Ive had friends comment, this thing dont even know whats its playing lol

Maybe easiest to ask @volumio if this is on their list over things to be fixed in a future release…

I’m a lifetime premium user and I don’t think this should guarantee me preferential treatment, but perhaps a response from @volumio… That would be nice! To me, but especially to @M1ck, who first identified the issue and detailed it perfectly months ago.
The issue may not be of great seriousness, but it’s quite annoying. Is it possible to know if it’s been addressed?

Ok, so I’m no expert, but surely this can’t be that hard to correct?

Especially if @M1ck is correct and narrowed down when the problem was first introduced.

Just checked again to be sure…

This bug is NOT present in volumio-2.457-2018-09-17-pi.img

But is present in volumio-2.773-2020-05-05-pi.img

Obviously being introduced somewhere in between

If @volumio or anyone can give me official volumio links to versions in between 2.457 and 2.773.
I will test if it helps to narrow it down further and get it sorted.

Hi! Thanks for the pointers!

We tracked when this bug was introduced, and it was here:

However, very tricky to solve without other regressions. It will take a while but we are on it.