X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

The title of the next song in the playlist does not appear. The time progress bar is going correctly. It’s the same in the smartphone app. Volumio x86.The first song from the playlist is always on the screen. This problem does not occur if playback is via tidal connect.
And one more thing: this page is displayed during startup. Why?

I have searched the forums trying to find an easy way to expand my 256 ssd running Volumio latest build I have read about gparted and putty but I’m a noob and not sure what to do. All I want to do is put music on the unused portion of the ssd steps with images would be helpful?

On first start (and every reboot), Volumio will try to expand the data partition to the maximum size of the device. This is by design, you cannot add your own partition because there wouldn’t be any space left.

my advice, use the smallest possible internal ssd size for volumio (8Gb is plenty) and add another drive labeled “issd” or “ihdd” to put your music on.

edit: yes, you can put your music on Volumio’s data partition, but should you ever need to do a factory reset, that data will all be wiped.

Ok throw in a nvme into its slot can I transfer music from network share to that drive across network and how?

1 Like

Hello,

i am new to volumio and try it on an intel nuc8 i7 that was the home of my roon core before. in the nuc is an 128GB m.2 ssd for the system and a 4TB SSD as music drive.

how can i add the ssd to my library for scanning music? i only can add network drives but i wont do that :frowning:

df -h shows me that the music drive is not mounted :frowning:
but volumio sees it because in prefs it asks me if i want to install volumio on it.

any solutions? :-/

make it with label “issd”

and a partition :slight_smile:

Sorry im noob :grin:

How do i mount a harddrive on volumio without changes on it? Its the data drive of my roon core initialised at exfs4.

Depends on the file system of the 4TB. how to label it
NTFS => ntfslabel
exFAT => exfatlabel

I expect the drive you see in system to install volumio is most likely the M2.

@BMPBrother
As you said, with Roon Core it was “ext4” formatted, the correct command would be

sudo e2label /dev/sda1 issd

where /dev/sda1 is just an example.
Better start an SSH terminal first after booting Volumio and then do

sudo fdisk -l

to determine which is the proper disk to re-label.
No mounting needed, just re-boot afterwards.

Drop the output from fdisk here in case you are not sure.

1 Like

Output of sudo e2label usw.:

e2label: Bad magic number in super-block while trying to open /dev/sdb
Found a gpt partition in /dev/sdb

:face_with_raised_eyebrow:

Why the :face_with_raised_eyebrow:?
Realise we, as a community, only try to help.
Instead, show what you got from fdisk, helps a lot more :grinning:

Hello Helpful Forum,

I have some new hardware the Fujitsu Futro S740 Thin Client, its a Intel Celeron J4105 x64 machine.

The issue is the unit only boots pure UEFI and does not support legacy boot. I burn volumio to a USB then boot off that USB on the Futro, it boots and allows me to install to internal drive no problems however when I come to boot from the internal drive the computer doesn’t recognise the drive as a bootable drive.

I can temporarily fix the issue by booting a Linux live usb and using efibootmgr to add BOOTX64.EFI to the EFI boot list. The problem is that doesn’t seem to persist after power loss(Time and date are retained fine by CMOS battery).

Is there some way to modify volumio so it is recognised as a boot device please? Windows and Ubuntu installations are recognised fine as bootable and automatically added to efi boot list.

Thanks in advance,

Alex

Edit: I heard the Futro needs GPT partitions, i tried converting the ssd to GPT but still not recognised. one time I could get grub to be recognised with GPT but it then didn’t boot volumio.

Good afternoon I tried several times to use Volumio on a mini PC based on an Intel Celeron N100 processor. Problem is that in the audio output settings Volumio does not see DACs connected via USB (I tried different ones - SMSL, VIIM, KEF active acoustics), and it also does not see connections via HDMI. Another problem is that no plugins are displayed in the plugin settings.What could be the problem?

Not sure about the USB and HDMI issue but plugins won’t show unless you log in to MyVolumio on the device. Are you logged in?

Alex

Yes, I’m logged in.

1 Like

The problem is that you did not read the very first post in this thread :wink:

But rest assured, many don’t, so please read the post and supply the information as mentioned.
In your case, you can start with submitting a log file.
Any other hardware info is appreciated, but not mandatory at this point.

First, there is no need to convert the SSD’s partitions. That will not work and is not necessary either as Volumio already uses GPT partitions.
The image is a “hybrid”, it will boot with SYSLINUX, when supported OR with UEFI, but I guess, once installed on the SSD, UEFI has priority.
You are the very first one reporting a UEFI bootmanager issue (since it’s introduction mid 2017), so likely something else is the problem.
There appear to be other forum members successfully using the Fujitsu Futro S740, so it is unlikely a hw issue.

With just “does not recognize the drive as a bootable drive” I can’t do much.
Could you please supply it bit more info regarding your hardware and especially the SSD?
For the hardware part, please submit a log while booted from usb.

1 Like