X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Yes, swapping on USB ports is one of the first things I tried, and I’ve tried again now, with no results.

In the meantime I got 2 more USB DACs, a Topping DX3 Pro and a Fiio BRT5, both obviously connected via USB, and magically, without changing anything, these work.

Another strange thing that I noticed, while doing experiments, is that by accessing via cable (while Wifi is not working) changing something in the wifi card (for example switching from dynamic IP, and subsequently to Static IP, after having selected SSID and provided password , the Wifi starts working, turning it off and on again, everything stops again.

And finally the final twist, by removing the T2U WiFi dongle and replacing it with TP-Link Wireless N Nano, even the DACs that didn’t work before now work, although I must say that the connection is really slow and you lose a lot of the enjoyment of the system.

At this point, with all these variables in play, it seems to me that pulling the rabbit out of the hole is almost impossible, only the tests and the experience acquired remain, which I think could be useful to other users in the future.
Greetings.
Thanks for your patience.

Thanks for the replies.
Booting occurs from the PC’s SSD disk, not from USB.
I’m sure because on the video I see some Linux commands being executed and then it gets stuck on the Linux login page and the Volumio program isn’t loaded and the network isn’t seen.
I will try to look at how to get the log log.
Thanks again.
PS Io sono italiano.

1 Like

Yes, I apologize, I read in a rush and didn’t quite understand the terms of the problem.
PS Sono italiano anch’io :grinning: :grinning: :grinning:

he llegado a instalar volumio 2. con exito pero sin que llegue a funcionar el wi-fi. tiene solucion?
usa la tarjeta de sonido Intel PRO/Wireless 2200BG
por lo que he podido ver en internet
traducido con google translate

I have managed to install volumio 2.xx successfully but without the Wi-Fi working. it has a solution?
uses Intel PRO/Wireless 2200BG sound card
from what I have been able to see on the internet
translated with google translate

There is no way to get the Intel PRO/Wireless 2200BG working on Volumio 2, it would need a driver and firmware update. However, Volumio2 is EOL for a long time already, meaning no support and no more updates.
For Intel RPO/Wireless 2200BG support you must install Volumio 3, unfortunately it is only available for 64-bit devices.

Hello,

I’ve Just Installed Volumio 3.546 on Intel NUC11 Essential NUC11ATKC4 [16GB RAM & 512GB NVME SSD] But the UI Won’t Load at All. I’m Stuck at the “Welcome to Volumio” Screen When Connected to an External Monitor Via HDMI.

I Can Access the UI Via the App on My Phone and Everything Seems to Be Working. Wi-Fi and LAN Works Flawlessly. But WebUI via HDMI Won’t Get Past the “Welcome to Volumio” Screen.

I’ve Tried Restarting/Reinstalling the mpd Service But No Luck.

Also. Volumio Works Flawlessly on my Intel NUC7CJYHN [8GB RAM & 120GB SATA SSD]. Even the WebUI via HDMI Works Well. But for Some Reason WebUI via HDMI Doesn’t Work on the Intel NUC11 Essential.

Please Help Me.

Log #1- http://logs.volumio.org/volumio/uMkHxmg.html

Log #2- http://logs.volumio.org/volumio/QQ34EbV.html

I am writing to understand why Volumio OS latest version does not recognize the Mini PC’s internal wifi card. The wifi card is a Realtek 8821CE Wireless LAN802.11ac PCI-E NIC. I tried two external dongles and Volumio sees them and I can connect with wifi, but when I remove the dongle, Volumio doesn’t see the internal wifi card. Even if I try to restart and select the wifi network it doesn’t see the internal wifi card. Compatibility issue with Realtek chip 8821CE? Someone have the same problem? Thanks

Very simple just finish the first configuration wizard on your phone or PC, then once done, restart the system.

I recommend doing a factory reset before doing that, as you’ve installed some custom stuff which will break updates otherwise.

This won’t help. The graphics device on a NUC11 is not supported with our 5.10 kernel, the NUC is too new for it.
Volumio on a NUC11 will be headless for the current versions and nothing quick can be done about it.

1 Like

Please submit a log as explained in this guide.
I’m sure the RTL8821CE driver was enabled in the kernel, but perhaps the log can tell us whether the card was not recognized or the driver failed loading the corresponding firmware.
I have not seen a Volumio installation with this PCIe module yet.

You could also try the version as mentioned in the link below.
It is a beta version, not with the latest Volumio functionality, but good enough to check if your issue would be solved with an upcoming release (note, no ETA!).
Let us know.

Link to the beta version with kernel 6.1.y with latest drivers and firmware.

I misinterpreted then…

You could try the version as mentioned in the link below.
It is a beta version, not with the latest Volumio functionality, but good enough to check if your issue would be solved with an upcoming release (note, no ETA!).
Let us know.

Link to the beta version with kernel 6.1.y with latest drivers and firmware.

Thank you. I just made all you told to me. Now i try beta version with kernel 6.1.

No, you didn’t :wink:
You forgot to post the log link here as decribed in the guide…

Sorry. I posted the log link on help support. The log link is: http://logs.volumio.org/volumio/YYzwiUt.html
Thank you.

In the meantime I installed the beta version kernel 6.1 on a USB stick and started Volumio (without installing it on the disk). Works great with the internal wifi card. Furthermore, at startup the Volumio graphic screen is displayed on the PC where the USB stick with Volumio is inserted. However, the problem of the WiFi card not being recognized occurs when I install Volumio on the hard disk (starting the installation from Volumio already installed on the USB stick). I can’t understand why.

Thanks for the Beta Version of Volumio.

WebUI via HDMI Works on the Beta But Only After Rebooting a Few Times.

Upon Booting, Sometimes It Gets Stuck on the Grey Screen and the Other Times It’s Just a Black Screen and Nothing Else.

1 Like

Incredible now it doesn’t work with internal wifi card while Volumio is on USB stick.

it’s not recognized, or are you unable to connect to your network?
if the latter, disable hotspot, reboot and test again.
If I recall correctly I had similar issues when testing Kernel 6.1

When hotspot was active, I could not connect to the network, SIDD’s didn’t even show up.

Internal wifi card is not recognized. On Volumio network page I have only wired connection with a correct ip and the wireless connection that have an inexistent ip on my network . I just tried to activate wireless and then reboot, but i have the problem that the wireless ip is the same (inexistent). Then i tried to install the Volumio img file (kernel 6.1) to the hard disk with balena etcher, but nothing. I haved only the result that i can see the Volumio graphic screen displayed on the PC where the USB stick/HD with Volumio is installed. With Volumio version VERSION: 3.546 downloaded from the site i can see only first text page (login).