X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

I bought a usb-to-eth adapter for these situations, a TP-Link UE300 (v4), it has an rt8153 chipset which is well supported with our kernels.

Thanks Gé,

Turning of the Hotspot solved indeed the issue.
Wasn’t aware that could happen, the first box that ran into this.
Weird though, it produces the same error with other USB dongles. Most likely related to the internal cards, which can’t be turned off.
What is working:

  • WiFi
  • BT
  • Keyboard
  • Touchscreen
  • FN Volume control

and ap-force did not make a difference?

I think internal wifi cannot be switched off easily, but with a udev rule a or systemd network link you could change the wlan0 name to something else, like mlan0. In that case your dongle would get wlan0.

Going through something similar with someone’s Dell 3040, which has the original Azurewave M.2 wifi card mounted. This has a marvell chipset, driven by the mvwifiex module, which creates a mlan0 decive name, Volumio cannot handle that. Trying to solve this with a systemd network link by renaming it to wlan0.

Hi everyone
I’ve installed volumio3 on x86/x64 platform based.
My config:
Asrock d3160dc
8g ram
1tb ssd seagate barracuda.
With this configuration i can’t connect to internet and log in. I’ve solved the problem installing a network card on pci express.
Anyway I 'd like to use the lan onboard: indeed I need the pci express slot to install an internal audio card.
How can I solve my problem?

By producing a log incl. the information found in the first post of this thread : https://community.volumio.com/t/x86-hardware-issues-wifi-dac-disks-boot-etc/50280

This will show vital information about your configuration, which will help to discover why the onboard network controller fails, Could be a firmware or driver issue we did not cover yet.

Hello people :slight_smile:
I have been using Volumio with Rpi4 a lot. Recently started building a new streamer based on Intel NUC8i5.

I started with a 14.1" screen with 1920x515 resolution with controller board. No issues there.

Then I tried a normal TV…no issues there.

Then I bought this screen:

I get nothing, no picture, not even portrait mode. Only some faint lines horizontal (landscaoe mode).

Picture
[20230504-221217 hosted at ImgBB — ImgBB]

I know the screen is ok because it works with my Windows PC…
[20230504-221401 hosted at ImgBB — ImgBB]

Any help would be appreciated

Intel NUC 8i5PB, volumio 3.435 from April 2023, screen is a hdmi 1920x480

Danny

P s. Dont know how to post a picture…sorry

The Touch Display plugin is not for x86 systems, so this is no topic for this thread. @Wheaten Is there an approriate thread where you could move @DannyB’s post?

yep, there is :wink:

Ehm…I created a new topic, because I know Touch plugin is not needed for x86…dont know how it got moved here…sorry Im new to Volumio forum

You post: Intel NUC 8i5PB, volumio 3.435 from April 2023, screen is a hdmi 1920x480

And obviously there is an unexpected issue with it.
However, no logs no fun…
https://volumio.github.io/docs/User_Manual/Sending_logs_for_troubleshooting.html

Hello gkkpch
Here the log (still learning how to navigate this forum :slight_smile: )

http://logs.volumio.org/volumio/BsRBZ57.html

Hope you can find something. I did do some test. I ran xrandr for display 0, tried to use my 8.8 inch screen. It assigned it to DP1 port, HDMI showed disconnected, then another DP2 disconnected.
Then I tried the other HDMI. Same thing. HDMI stayed disconnected, just the DP connection changed. I do not have DisplayPort on this NUC. No DAC yet, so the audio out is pointed to HDMI port in Volumio.

Danny

Seems that in the current Beta release V3.502 the media servers are populated again!!!

Thanks Gé

Hello, I always encounter this white page at boot on X86 and then it goes to Volumio screen. Is there a way to change this white screen display? System version 3,324

Please update to the latest version, V3.449

In older build’s this only happened on the first boot (after clean install), then reboot and it should not happen anymore. In the latest version this has ben resolved.

1 Like

Thank you for the information

Using Volumio x86 latest version on an old mac mini.
Everything working beautiful.
As I connected this to an big TV screen with a remote keyboard/mouse, would like to increase mouse cursor size.
Being trying with
$ gsettings set org.gnome.desktop.interface cursor-size [sizeInPixels]
command, which does not return any errors, but cursor keeps same size.

Any help, please?

Gracias

Not sure if you have the same issue that we should have solved by capping the resulotion to 1900x1080
Are you using a big TV with a higher than that resolution?
Which exact Volumio version did you install?
People should stop saying “latest” :wink: , this put support on the wrong foot many times.

Version is 3.449 Released Thu 30 Mar 2023.
Not sure how to check resolution or how to cap it!

Update: just uncommented the lines you refer to… Rebooting right now
Update2: Resolution changed, but mouse cursor still small

well, the fix is not as it ought to be, but I will have a look.
As for your issue, when the resolution changes and the mouse is still too small/ did not change, then I have no solution, sorry…

1 Like