[PLUGIN] Touch Display

Makes sense as to why I couldn’t find the plugin then, thanks. I do have that User Interface Via HDMI working currently via pikvm, just not sure if touch will work if I hook it up to a portable touchscreen.

i have recently bought this display:https://www.amazon.com/dp/B0B2F6QSFZ/ref=twister_B09YJ5C9WD?_encoding=UTF8&th=1
But when i want it to work with volumio i does not match the screen.

how can i fix this i have tried to edit the config and userconfig files with the following:

hdmi_cvt 1600 480 60 6 0 0 0

But that does not seem to work.
please help

Please post the complete “/boot/config.txt” and “/boot/userconfig.txt”.

Also check that the line endings in “/boot/userconfig.txt” are “LF” (not “CRLF”).

And if you’re using a rPi4, make sure to comment out the line:
#dtoverlay = VC4-KMS-V3D

2 posts were merged into an existing topic: X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Hello, I bought a 7.9inch 400×1280, IPS, DSI,
Unfortunately I can’t configure it with volumio. Will someone help? or did i drown the money.


Raspberry Pi 3 Model B

HiFiBerry DAC2 Pro

7.9inch 400×1280, IPS, DSI

kernel 5.10.92

Have a look here.

Where is the screen rotation feature on the latest plugin??? It’s a joke, right?


Seems indeed that the screen rotation is missing

I’m already looking at it.

everything ok here, v3.3.5.
I am updating now.

after update to v3.3.6 rotation settings are gone.

1 Like

It is an already known issue. I will do a new version soon.

@andre_maier @Wheaten @michel8166

3.3.7beta is available and should fix the missing rotation setting.

1 Like

updated to 3.3.7 beta, all good now :ok_hand:

Super fast as usual!

1 Like

Hi, I’m trying to enable a Hyperpixel 4" touch screen with my rpi 4b running volumio. I’ve tried several times with the recommendations or solutions I’ve found doing some research in the forum and in the web. No success so far. Screen works fine if I load standard RPI OS, so the issue is not with the screen. Latest test was with Touch Display plugin 3.3.7 and Now Playing 0.3.7.
Some errors I see in the live log:

(==) Log file: “/var/log/Xorg.0.log”, Time: Thu May 18 19:56:47 2023
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
info: touch_display: Using Xserver unix domain socket /tmp/.X11-unix/X0
Fatal server error:
(EE) no screens found(EE)

error: touch_display: Connecting to the Xserver failed.
info: touch_display: Using Xserver unix domain socket /tmp/.X11-unix/X0
info: CoreCommandRouter::executeOnPlugin: system , getPrivacySettings
info: CALLMETHOD: system_controller my_volumio retreiveBackendEventStates undefined
info: CoreCommandRouter::executeOnPlugin: my_volumio , retreiveBackendEventStates
info: Received Get System Version
info: CoreCommandRouter::executeOnPlugin: system , getSystemVersion
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
volumio-kiosk.service: Main process exited, code=exited, status=1/FAILURE
volumio-kiosk.service: Failed with result ‘exit-code’.

attached the full live log.
live log volumio hyperpixel.txt (44.9 KB)

any help will be greatly appreciated.


What did you do to get the display working?

Please post the results of

cat /boot/config.txt

cat /boot/userconfig.txt

ls -al /usr/share/X11/xorg.conf.d

ls -al /etc/X11/xorg.conf.d

Here you are, thanks

volumio@music-server:~$ cat /boot/config.txt
initramfs volumio.initrd

include userconfig.txt



volumio@music-server:~$ cat /boot/userconfig.txt

Add your custom config.txt options to this file, which will be preserved during updates

volumio@music-server:~$ ls -al /usr/share/X11/xorg.conf.d
total 32
drwxr-xr-x 2 root root 4096 May 18 21:17 .
drwxr-xr-x 1 root root 4096 May 18 21:17 …
-rw-r–r-- 1 root root 92 Feb 7 2019 10-amdgpu.conf
-rw-r–r-- 1 root root 1350 Apr 4 07:50 10-quirks.conf
-rw-r–r-- 1 root root 92 Apr 6 2019 10-radeon.conf
-rw-r–r-- 1 root root 1429 Mar 31 2019 40-libinput.conf
-rw-r–r-- 1 root root 2747 Jun 26 2017 70-wacom.conf
-rw-r–r-- 1 root root 647 May 18 19:45 99-fbturbo.conf

volumio@music-server:~$ ls -al /etc/X11/xorg.conf.d
total 16
drwxr-xr-x 2 root root 4096 May 18 21:25 .
drwxr-xr-x 1 root root 4096 May 18 21:22 …
-rw-r–r-- 1 root root 316 May 18 21:25 95-touch_display-plugin.conf