X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

You should read my original post I never simply said it’s not working. I said I was struggling to install so that’s clearly a boot issue isn’t it, as for telling you how I fixed it you’re obviously the smart arse you figure it out. What a uplesent little man you are

1 Like

@craggychris

Not sure if your complaint in regards to be rude is valid, looking at your reply.
At least @gkkpch apologized if the reply sounded to harsh.
Please keep in mind that people support you in their free time and only request adequate information.

Your info is very limited, like HP t520 and doesn’t boot.
For us there is no way to support it.
you made a remark:

Did you read the topic header yourself?

If you want to reply, I am open to it. But please react wiht some decency.

Hi i install the so in win but cant see interface. I can in webui but no in laptop screen

I presume you installed on a usb stick and booted from there on your laptop?
But that is pure guessing. You need to tell us a bit more, to be able to help you. Which laptop, which version of Volumio?
Look in thread X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)
Read the first post, it tells you what we need.
Then add your issue as a new item.
Report back in case you get stuck

Hi,

Just got a TP-Link AC1300 MU-MIMO USB adapter, which I can setup and connect to my wireless network. However after every reboot the connections is lost. No clue why?
image

Version: Volumio V3.378-x68
Log: http://logs.volumio.org/volumio/R9tGCD6.html
lspci:

volumio@volumiox86:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 36)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 36)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 36)
00:11.0 SD Host controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SDIO Controller (rev 36)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 36)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 36)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 36)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 36)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
volumio@volumiox86:~$

inxi -Fxxxz:

volumio@volumiox86:~$ inxi -Fxxxz
System:    Host: volumiox86 Kernel: 5.10.139-volumio x86_64 bits: 64 compiler: N/A Console: tty 0 dm: N/A
           Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop System: Dell product: Wyse 3040 Thin Client v: N/A serial: <filter> Chassis: type: 3 serial: <filter>
           Mobo: Dell model: Cherry Trail CR v: A00 serial: <filter> UEFI: Dell v: 1.2.4 date: 01/18/2018
CPU:       Topology: Quad Core model: Intel Atom x5-Z8350 bits: 64 type: MCP arch: Airmont rev: 4 L2 cache: 1024 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11520
           Speed: 609 MHz min/max: 480/1920 MHz Core speeds (MHz): 1: 525 2: 872 3: 848 4: 888
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers vendor: Dell
           driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b0
           Display: tty server: X.org 1.20.4 driver: none unloaded: fbdev,modesetting,vesa tty: 143x24
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: cht-bsw-rt5672 driver: cht-bsw-rt5672 message: bus/chip ids unavailable
           Device-2: Intel HDMI/DP LPE Audio driver: HdmiLpeAudio message: bus/chip ids unavailable
           Sound Server: ALSA v: k5.10.139-volumio
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: e000
           bus ID: 01:00.0 chip ID: 10ec:8168
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: TP-Link type: USB driver: rtl88x2bu bus ID: 1-4:3 chip ID: 2357:012d serial: <filter>
           IF: wlan0 state: up mac: <filter>
Drives:    Local Storage: total: 7.28 GiB used: 3.10 GiB (42.5%)
           ID-1: /dev/mmcblk1 model: H8G4a size: 7.28 GiB serial: <filter> rev: 0x8 scheme: GPT
Partition: ID-1: / size: 3.61 GiB used: 2.21 GiB (61.3%) fs: overlay source: ERR-102
           ID-2: /boot size: 168.4 MiB used: 61.2 MiB (36.3%) fs: vfat dev: /dev/mmcblk1p1
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 165 Uptime: 4m Memory: 1.86 GiB used: 365.9 MiB (19.2%) Init: systemd v: 241 runlevel: 5 default: 2
           Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32
volumio@volumiox86:~$

volumio@volumiox86:~$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 15
       serial: 54:48:10:e8:2c:0a
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.10.139-volumio duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.199 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:16 ioport:e000(size=256) memory:91404000-91404fff memory:91400000-91403fff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@1:4
       logical name: wlan0
       serial: 1c:61:b4:7b:45:70
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl88x2bu driverversion=5.10.139-volumio ip=192.168.1.52 multicast=yes wireless=IEEE 802.11AC
volumio@volumiox86:~$

Currently solved by doing a factory reset.

Hi,
Can you conforme that the mini pc model z83f is compatibile with volumio?

Thanks and best regards

|Marca|‎MINIS FORUM|
|Produttore|‎BESSTAR TECH LIMITED|
|Dimensioni del collo|‎20.6 x 13.2 x 5.8 cm; 600 grammi|
model|‎JP-USB1923|
|Fattore di forma|‎Fattore di forma ridotto|
|Marchio processore|‎Intel|
|Tipo processore|‎Atom|
|Velocità processore|‎1.92 GHz|
|Numero processori|‎4|
|Dimensioni RAM|‎4 GB|
|Tipologia di memoria computer|‎DDR3 SDRAM|
|Dimensioni Hard-Disk|‎64 GB|
|Descrizione Hard-Disk|‎EMMC|
|Interfaccia Hard-Disk|‎USB 2.0|
|Coprocessore grafico|‎Intel HD Graphics 400|
|Descrizione scheda grafica|‎Intel® HD Graphics 400|
|Tipo memoria scheda grafica|‎DDR3 SDRAM|
|Interfaccia scheda grafica|‎Integrato|
|Tipo di connettività|‎Bluetooth, Wi-Fi|
|Tipo wireless|‎802.11bgn, 802.11ac|

I have a Z83II box, which runs Volumio3 (beta version currently under testing) well. In any case, it’s simple enough to try running from a USB flash stick without installation to the hard disk.

Hi and thanks for the answer.

I ask because i have not yet bought the machine.

In case you confirm that you could provide me with the beta version I would buy it.

Thanks.

Federico

Hi.
The latest volumio 2 version available does not work with the z83: it does not recognise the wifi hardware.
Could you please let me download Volumio 3?

Thanks

If you encounter problems then please respond in that thread (making sure that you read carefully about what info you need to provide, including how to post a system log).

Hi again,

Still problems with the wifi
I get this message:


I do mot know if anything can be done
Thanks!

I think that something might possibly be done, and that @gkkpch might well be interested in your problems with this device. Please have a look at this post, and add your device details and problem (wifi). It is important that you read the first post carefully, and add all the requested information.

Yes, this is a typical symptom of a missing driver, actually more likely missing firmware, for the embedded wifi hardware module.
Without the info @chsims1 pointed to, there is nothing much that can be done.
Please use the referred post, also to prevent other members getting similar issues in the future.

Dear all,
after 1 year I have retried with the installation of the latest version of Volumio (Volumio-3.378-2022-09-30-x86_amd64) and faced the same problems with the wifi (same error message received)
Following your instructions I have created a log file: http://logs.volumio.org/volumio/6D6QW65.html
Please let me know if you think that the issue can be solved or if I shall leave aside the installation on this HW. If I you need more support from my side I will give.
P.S. with the LAN cable connected the system works, only for test since I cannot leave the cable pass by.
Thanks for your kind support.
Federico

@Federicob

Did you read the topic as previous requested?

  • You gave full image name
  • You gave the log
  • but missing the Output from “lspci” and “inxi -Fxxxz”

I looked at the log and apparently it complains about an unrecognized wireless (version?) chip.
As @Wheaten mentions, output from “inxi -Fxxxz” would be welcome as it will report the hardware details like network components etc.
Looks like Bluetooth fails for similar reasons.

Hi,
I have read that inxi -Fxxxz is a tool to get info from the configuration of the system.
Is there a post on how to use it? Or a step by step procedure.
thanks,
Federico

just open a ssh connection to your device and type:
inxi -Fxxxz

Hi,
I am building a kind of colture on this, at least for me.
I have installed Open SSH client and server on Windows.
I have opened the terminal and digited: ssh volumio@127.0.0.1
the system asks for the password; I have tried with “volumio” and “Volumio”, but these are not recognised as correct password…

For some reason I doubt the the given IP is correct.
127.0.0.1 is the machine where you opened the SSH session.
You need to enter the IP of volumio.
So type
ssh volumio@<ip of volumio>

There is no need to install the server part as your windows machine will not act as a SSH server.