X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

I discovered a working prototype of an RTL8812BU (used for a custom solution) in my scrap box and will use this to test RTL8812BU driver support on x86.
I can’t say when this will be done, but it is on top of my to-do list for x86.
A few other Realtek AC1200/ AC1300 dongles will be added at the same time.

Great thanks to you for your rapid, clear and compherensive answer! Now it seems fully clear how to proceed with updating to Volumio 3.

I would encourage other Volumio users to consider using an old laptop with a decent DAC (in my case Topping E30 or ESI U24XL) connected to it. The arrangement is very practical, you need for music listening only one, rather compact main device, which includes a display and hard disk. You can operate the system as well as listen to your own music saved on the internal hard disk, music from streaming services and web radios with a single device. If I did not have it already, I would consider buying a compact old laptop for Volumio use.

Or, instead of a laptop, use a re-purposed Intel Atom based Thin Client like this Dell Wyse. 2nd hand you get them for less than 50€ on ebay and other auction platforms. There are more of those thin clients (HP, Fujitsu, Igel), some of them have an AMD processors, others have an Intel. Powerful enough to run Volumio 3 without any issues. Onboard audio can be reasonable, but as you mentioned, a USB DAC does the trick.

image|Dell Wyse 3040

OK, TP-Link Archer TU3 is now working, so will other dongle’s with an RTL8812BU chip.
Super fast link to my router, 876 Mbps
I will add this to the next x86 version.

Now there are more Realtek devices to add.
The driver sources are there, I lack further dongle’s to test with, so it is up to the community.

For your info, going dead cheap, nearly cost price for community members.
Dell Wyse 3040 opportunity

I just found that the image Volumio-3.179-2021-12-20-x86_amd64.zip cannot be installed on an old 686-laptop, although that could be expected on the basis of the information on Volumio download webpage (one of the download alternatives is for PC (X86/X64)) and the name of the zip file includes x86. The laptop gives an error message about a unsuitable version. Is this a permanent situation or will there be a Volumio 3 version, which can be installed on x86 computers? In case such version will not be available, it would be nice to have the last Volumio 2 version still downloadable for older computers.

1 Like

Sorry, i386 has been adandoned for good, there is not going to be a 32bit version of Volumio 3.
The small number of 32bit devices left does not justify the maintenance work we would have.
You can install Volumio 2 for x86 if you wish, but it is unsupported and may stop working at one point (certificate issues etc.).
You will find the version and download information you need when you click on the blue banner at the top of the community forum pages

Thank you for useful and clear information! In fact for me it is no surprise that i386 machines are no more supported. It just the same as with Lubuntu. We must accept the fact that an i386 machine will run only Volumio 2 and obsolete Lubuntu versions (v. 12.04 or older) and without support as long as everything works. Anyway it is an alternative to find practical use for old equipment.


It does now, some realtek ac1200/1300 drivers have been added the last few days. TP-Link Archer T3U works like a charm.
Available with any version >= 3.195

Sorry for the sudden disappearance, I’ve had some RL matters to attend. I’ll try with the latest volumio image, or if you still want me to test that pre-version, I can do that too

I definitely got the UI at some uncomfortably small resolution over vga, but I don’t remember if I set nomodesetting manually

Meanwhile it has already been integrated in the Volumio 3 release, so you can use x86 version 3.179 or later.

1 Like

Networking with tigon still does not work (I wager because broadcom module is missing still). Sound, uh, works, but only after putting device to sleep and waking it back up, does not work straight after boot. Running 3.179

Perhaps this is as “good” as it gets, dissapointing but there is not much else that can de done I’m afraid.
Could you create a log as a last ressort?

Hello My hardware,

Model: MSI MS-163C (VR601) Laptop(Pentium Dualcore)
Booting From: HDD
Sound Card: Creative x-fi usb 5.1(Optical out → DAC) and My DAC’s USB input (PCM2704)
Volumio 2.916

I’m using Volumio 2.916, running verry well. Specially Creative x-fi USB’s sound is good.

I tried Volumio 3.179. When I’im using My Dac’s USB input sound is same with 2.916. but When using Creative x-fi usb 5.1, the sound is worse than before.

Another Question,

I keep my media files on my computer’s hard drive(INTERNAL). Can I install the new version without deleting these files? (Booting from HDD)

Best Regards

Unfortunately not, there is no OTA update from V2 to V3.
But even then, your data would have been lost.

Re: Dell Wyse 3040 (edited and added by moderator)

Wow, great, thank you. It worked like a charm. One tip to others attempting this, they’ll have to allow the device to boot from a memory stick in the bios. It’s disabled by default. This is on top of the boot order.

It works great with the internal sound card. Using a Usb Hidisz 9 dac it has occasional drops. I’m wondering if it’s due to power not being adequate or something with volumio. The same dac works flawlessly with volumio 2.9 on an old 32bit laptop.

Not when the unit has been reset to factory defaults, that is what I would advice anyway.
Just finished setting up 10 of them following the procedure above, works perfectly.

Try another usb cable, usb port or a powered usb hub, that may help. Hidizs seems to be picky on usb3.0 ports, just google a little (e.g. audio science review). I tested with 3 different USB audio DACs, none of them gave any issue, playing upto DSD128.

The goal: install Volumio on a laptop hard drive.

I have searched a lot for this and have tried several ways, but nothing worked. The most recent tips were from 2018 and for v2. The official guide mention a mac once and then only for running from the USB. I want to install on the hard drive, having the laptop as a standalone Volumio server.

I have linux laptops, created the bootable USB. Volumio runs from the USB, but that is not what I want.

I tried the Oracle Virtual Box but that uses a Windows machine to build stuff.

Any information on how to do this with v3 and using only Ubuntu machines would be highly appreciated.


1 Like

Volumio is an OS not an application .
If you download the x86 version, boot from USB, run the setup, you can navigate to: System settings and there is an option at the bottom to put it on a HDD/SSD.
Be aware it will overwrite your disk.

1 Like