X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

It does now, some realtek ac1200/1300 drivers have been added the last few days. TP-Link Archer T3U works like a charm.
Available with any version >= 3.195

Sorry for the sudden disappearance, I’ve had some RL matters to attend. I’ll try with the latest volumio image, or if you still want me to test that pre-version, I can do that too

I definitely got the UI at some uncomfortably small resolution over vga, but I don’t remember if I set nomodesetting manually

Meanwhile it has already been integrated in the Volumio 3 release, so you can use x86 version 3.179 or later.

1 Like

Networking with tigon still does not work (I wager because broadcom module is missing still). Sound, uh, works, but only after putting device to sleep and waking it back up, does not work straight after boot. Running 3.179

Perhaps this is as “good” as it gets, dissapointing but there is not much else that can de done I’m afraid.
Could you create a log as a last ressort?

Hello My hardware,

Model: MSI MS-163C (VR601) Laptop(Pentium Dualcore)
Booting From: HDD
Sound Card: Creative x-fi usb 5.1(Optical out → DAC) and My DAC’s USB input (PCM2704)
Volumio 2.916

I’m using Volumio 2.916, running verry well. Specially Creative x-fi USB’s sound is good.

I tried Volumio 3.179. When I’im using My Dac’s USB input sound is same with 2.916. but When using Creative x-fi usb 5.1, the sound is worse than before.

Another Question,

I keep my media files on my computer’s hard drive(INTERNAL). Can I install the new version without deleting these files? (Booting from HDD)

Best Regards

Unfortunately not, there is no OTA update from V2 to V3.
But even then, your data would have been lost.

Re: Dell Wyse 3040 (edited and added by moderator)

Wow, great, thank you. It worked like a charm. One tip to others attempting this, they’ll have to allow the device to boot from a memory stick in the bios. It’s disabled by default. This is on top of the boot order.

It works great with the internal sound card. Using a Usb Hidisz 9 dac it has occasional drops. I’m wondering if it’s due to power not being adequate or something with volumio. The same dac works flawlessly with volumio 2.9 on an old 32bit laptop.

Not when the unit has been reset to factory defaults, that is what I would advice anyway.
Just finished setting up 10 of them following the procedure above, works perfectly.

Try another usb cable, usb port or a powered usb hub, that may help. Hidizs seems to be picky on usb3.0 ports, just google a little (e.g. audio science review). I tested with 3 different USB audio DACs, none of them gave any issue, playing upto DSD128.

The goal: install Volumio on a laptop hard drive.

I have searched a lot for this and have tried several ways, but nothing worked. The most recent tips were from 2018 and for v2. The official guide mention a mac once and then only for running from the USB. I want to install on the hard drive, having the laptop as a standalone Volumio server.

I have linux laptops, created the bootable USB. Volumio runs from the USB, but that is not what I want.

I tried the Oracle Virtual Box but that uses a Windows machine to build stuff.

Any information on how to do this with v3 and using only Ubuntu machines would be highly appreciated.


1 Like

Volumio is an OS not an application .
If you download the x86 version, boot from USB, run the setup, you can navigate to: System settings and there is an option at the bottom to put it on a HDD/SSD.
Be aware it will overwrite your disk.

1 Like

That was clear and exactly what I was planning. :slight_smile:

Ah, System Settings! That was what I was looking for. I suggest they add that to the docs.

Also, the hotspot is activated by default, making the wifi network invisible, that took a while to find out.

But I can go on and test stuff, thanks!

You shoul have asked :slight_smile:

The hotspot has the advantage that you can setup the system on the first boot, by simply connecting your PC via WiFi to the hotspot.

I noticed that some of the onboard wireless chips/ drivers with the x86 platform will do hotspot but can’t scan for wireless networks in parallel.
So in some cases the hotspot will be active but you will not be able to connect to a wireless network. This is ok with notebooks, or for pc’s with monitor/ keyboard connected, because you can switch off the hotspot, wait a few seconds and the pick from the freshly scanned list.
However it is a nuisance when you have a headless setup.

I am using latest volumio x86 3.251 on my Intel NUC 11gen machine (model name is nuc11tnki5).
NUC Specs Link
It works best on my NUC except one thing, Onboard ethernet controller which is “Intel® Ethernet Controller i225-LM”
I couldn’t make it to work with volumio, so I am using external USB Ethernet Adapter now.
If you could support to volumio work with Intel NUC 11gen machines with ethernet support, It would be very helpful for all NUC users.

1 Like

Hi, I am posting this along another reply for Intel NUC 11gen.

When I used 2.5gb ethernet adapter by replacing gigabit ethernet, I felt that audio quality much improved.
It could be the the reason for this that 2.5gb controllers handling common mode noise better than gigabit ethernet controllers. Please google it if you curious about common mode noise and how could it affect audio qualify.
Anyway I bought an 10gb ethernet adapter using aQuantia AQtion NIC. (AQC107)
But I couldn’t make it to work with volumio.
If you provide support for that ethernet controller, I could test the audio quality with 10gb ethernet adapter.

Tinker S installed the latest official version 3.251 on the board… In the settings I do not see how to set I2S or select a DAC. How to do it? In the Audio selection menu - HDMI, HDMI, SPDIF, CONNECTOR.

Volumio3 X86 GUI not responding on assigned IP (VERSION: 3.251).
Once boot ends up, I try to reach volumio gui from any another devices on showed IP at login without success.
NOTE that everything is ok following the same steps using raspberry pi (same version) instead of X86.
Current configuration: boot from internal HDD; nothing changes booting from USB.
I tried with both ethernet cable connected and wi-fi on and with ethernet only or wi-fi only: the only way to reach configuration wizard is via hotspot (tried static IP or using DHCP) but at the end no way to reach the gui on the desired IP leaving hotspot (timeout, server unreachable). Ping correctly responding on assigned Volumio IP (via ethernet and via wi-fi) from any devices and viceversa (so no network connection issue).
I’d like to share output file from lspci and inxi -Fxxxz command uploading them but got message: “Sorry, new users can not upload attachments.”.
So I paste them below:

00:00.0 Host bridge: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation NM10/ICH7 Family SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 04)
01:00.1 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5288 PCI Express Card Reader (rev 01)
02:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe

inxi -Fxxxz-output:
System:    Host: volumio Kernel: 5.10.95-volumio x86_64 bits: 64 compiler: N/A Console: tty 1 dm: N/A 
           Distro: Debian GNU/Linux 10 (buster) 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Mini 110-3000 v: 0490100000202B00110300000 serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 148A v: 79.4B serial: <filter> BIOS: Hewlett-Packard v: F.15 date: 01/14/2011 
Battery:   ID-1: BAT0 charge: 0.0 Wh condition: 51.4/55.1 Wh (93%) volts: 4.0/10.8 model: Hewlett-Packard 5100 type: Unknown 
           serial: <filter> status: Charging 
CPU:       Topology: Single Core model: Intel Atom N455 bits: 64 type: MT arch: Bonnell rev: A L2 cache: 512 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 6650 
           Speed: 1455 MHz min/max: 1000/1666 MHz Core speeds (MHz): 1: 1417 2: 1449 
Graphics:  Device-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:a011 
           Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa alternate: intel tty: 128x37 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:27d8 
           Sound Server: ALSA v: k5.10.95-volumio 
Network:   Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet vendor: Hewlett-Packard RTL810xE driver: r8169 
           v: kernel port: 2000 bus ID: 01:00.0 chip ID: 10ec:8136 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci v: 2.3.0 port: 2000 bus ID: 02:00.0 
           chip ID: 1814:3090 
           IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 70.37 GiB used: 10.22 GiB (14.5%) 
           ID-1: /dev/sda vendor: Toshiba model: MK6034GSX size: 55.89 GiB speed: 1.5 Gb/s serial: <filter> rev: 1A 
           scheme: GPT 
           ID-2: /dev/sdb model: xD/SD/M.S. size: 14.48 GiB serial: N/A rev: 1.00 scheme: MBR 
Partition: ID-1: / size: 50.75 GiB used: 18.3 MiB (0.0%) fs: overlay source: ERR-102 
           ID-2: /boot size: 170.8 MiB used: 60.2 MiB (35.2%) fs: vfat dev: /dev/sda1 
Sensors:   Missing: Required tool sensors not installed. Check --recommends 
Info:      Processes: 121 Uptime: 5m Memory: 975.9 MiB used: 203.6 MiB (20.9%) Init: systemd v: 241 runlevel: 5 default: 2 
           Compilers: gcc: N/A Shell: bash v: 5.0.3 running in: tty 1 inxi: 3.0.32 

Thanks in advance.

Drivers have been selected, support should be in the next release.

1 Like