[Work around found] (Formerly added driver Realtek 8192eu NOK in 3.198)Wifi issue with latest update


Volumio 3 was working fine prior to 3.198.
I updated and the Wifi dongle TP-Link with Realtek 8192eu doesn’t work anymore, so i lost wifi with the update.

From the Beta trial, i tried to install it manually with ssh command to download the driver & install. But message is "Pi revision number a02082. Pi 3B v1.2. Driver for 8192eu doesn’t exist for this update " = this current kernel.

http://logs.volumio.org/volumio/gUnBv6h.html if needed.

I will downgrade to the previous revision.
If you know a Wifi usb dongle available in Europe that work for sure in the future, i will buy. (tired of trying to discover which chip has a working driver…)


Seems to be the same issue that Volumio has responded to in this thread → Volumio 3.198 removed rtl8192eu driver (for DLINK DWA 131 wifi dongle)? - #4 by volumio


  1. I tried to download the Volumio image corresponding to the last working version for me but the link shared on the forum to do so doesn’t work. It used to focus on the 2.X series maybe something changed for 3.x
    Could you help with that ? (if not i only have 3.152)
  2. Any pointer at a working usb dongle would be nice !!!

Have a nice day

1 Like

What was the version number of the last working image for you please (not sure which were considered stable)?

Just before 3.198!
Everything worked fine last week before the update… :upside_down_face: (but i don’t remember the number. Try to stay up to date as much as possible)

Have a look at the community Changelog, there should be links.

The new images have a 5.10.yy kernel that doesn’t contain any of the extra out of tree Wi-Fi drivers.

I only find this https://community.volumio.com/t/community-based-change-log-for-volumio-3/53248
but it is mentionned as alpha/beta whereas the release i was using was the standard channel i guess.

Is it OK?
It would really be nice to keep a link to a few older “stable” releases to avoid those problems
With 2.x releases, i think we had access to older releases easily. Now the server is not accessible

Perhaps we should have something device-specific like what I have done for Odroids for a long time

See first post in this example

Yep, a few previous releases seems a good balance?
The new plugin store offers 5 previous releases FWIW…


Workaround by installing 3.197 from https://community.volumio.com/t/community-based-change-log-for-volumio-3/53248

a. the mention “alpha or beta” made me uncertain about the quality of the status/quality of the image. Was it the same as the one installed through the plugin ?
b. Odroid-specific thread/link is a very good example
For Volumio 2.xx, something simiar existed. (i used to be able to re-download 2.698 for the Allo Kali & Piano Dual Mono issue)
c. If the update plugin stores a few releases, that would be very good if it could be possible to easily go back through the plugin (i haven’t tried to see if possible right now).
It would be have been easier than tracking down a post, redownload, flash…you know the drill! :stuck_out_tongue:

In any case, thanks for the pointer, the answers!
Have a nice day

I just bought a USB dongle BrosTrend AC650 AC5L because it said it was supported for all kernel up to 5.15, Rasbian. (see below)
Noyaux Linux jusqu’à 5.15, Ubuntu 21.10 ~ 16.04, Debian 11/10/9/8, Linux Mint 20/19/18, LMDE 4/3/2/1, Raspberry Pi OS (Raspbian) 10/9/8, MATE, GNOME, Kubuntu, Lubuntu, Xubuntu, Ubuntu Studio, Budgie, Kylin, MX Linux, OS élémentaire, Zorin OS, KDE néon, antiX Linux, Q4OS, Parrot OS, PureOS, Bodhi, deepin, Linux Lite, SparkyLinux, Peppermint OS, Devuan

Worked with 3.197, updated Volumio to higher, then nothing anymore.
Have some difficulties knowing which chip is used / which driver i should have but i am bit tired of this thing. It feel we are back in time (2002 and hunt for proper chips with driver)

Anyway, if Volumio shop were to sell Wifi dongle that work out of the box, i would take 2 !