Wifi dongle / Volumio 3 and update 3.198, REALTEK 8811CU


Following issue with a formerly working USB dongle (see https://community.volumio.com/t/work-around-found-formerly-added-driver-realtek-8192eu-nok-in-3-198-wifi-issue-with-latest-update/53523), i purchased a BrosTrend AC650 / AC5L which was mentionned to work with different flavors of Raspbian.
Same thing happened
Works OK with 3.197 and kernel 5.4
Doesn’t work with 3.198 and kernel 5.10
The company’s installer didn’t work also because Volumio’s setup seems particular / non standard.
I used to read that updating Volumio with standard command (apt and so on) could break things. Maybe less so with Volumio 3 but i didn’t try.

Would it be possible to have a list of working chips/driver or even be able to purchase a compatible Wifi dongle from the store ?

This is a known issue, due to the external drivers not being available for kernel version > 5.10.73.
It is work-in-progress and should be solved with the next release.

1 Like

Thanks for the quick reply.
Will watch closely the notes of the future releases.

Take care

Which dongle I could use with 3.512??
I cannot find it at the community


For RPi? x86? Tinkerboard?

It’s for RPI 3B+ or 4. Want to try both RPI’s


RPI3B+ and RPi4 have onboard WiFi/BT module, they don’t need an additional dongle

Yes I know, still I want to use a dongle.

Early 2022, i purchased one Asus USB AC51 wifi dongle.
Worked with my Raspberry Pi 3+ at the time
Still works with the latest volumio, 3.512
Amazon offers free return if it doesn t work

Thanks, I will try that one.

Is it working out of the box?

1 Like

Yes, it was. That why i bought it. Another thread had the same kind of topics and info was given there (just can t find it right now)

I got one. :slightly_smiling_face:

Maybe stupid question, how to disable internal WiFi and start using and configuring the WiFi dongle?

here the answer to your question

the only difference is the file to be written, instead of adding the two followings lines on config.txt, add them to userconfig.txt, so they will be maintained with OTA software updates


If you’re going to edit the userconfig.txt file inserting the SD-card to a windows PC, please don’t use notepad, but install and use notepad++ to edit the file

It’s working nevertheless the speed of the Asus dongle is very low only 28Mb/s.
Is that configurable?

I had the same issue as my 2.4Ghz & 5Ghz networks had the same name. Volumio would choose the 2.4Ghz…
I renamed the 5GHz one with a specific name and gave Volumio the password only for the 5GHz one.
Speed was much improved. I posted a pic of the speed difference but can’t find it again.
If you have the same kind of setup, maybe look into it
If not… i don’t know

ps my problem with network is usuall congestion when others family members are on Youtube and Netflix… :grinning:

1 Like

Quite difficult to rearrange WiFi as I also have AiMesh configuration with several Asus routers.
Went back to a cable for the moment.

Thanks for your suggestion !