Volumio with lcd 20x4 customized

This seems to fix it

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -

I then try to run

sudo apt full-upgrade

but now it returns

E: Sub-process /usr/bin/dpkg returned an error code (1)

yes, there is such a problem. you need to ask questions to the pydpiper*s author on github.
…or return to a version lower than 2.907… maybe…

Work well on Volumio 3 (3.101). Checked today :wink:.

Im using Volumio 2.909 (whatever the latest DL is from volumio)

Still no progress.

Which installation approach did you use?

Also do you have a link to the version of of Volumio you are using? I tried searching for 3.01 but could not find it.

I will give this a try. Did you use the plugin version of pypdpiper or the original version with more a manual install?

everything is as above in this thread.

So after switching to Volumio 3 Buster Beta I was able to complete this install flow without any errors

sudo git clone https://github.com/dhrone/pydPiper
cd ./pydPiper
sudo ./install_docker.sh
sudo ./install_volumio.sh
sudo nano ./pages_lcd_20x4.py
[my example: pages_lcd_20x4.zip (2.4 KB)]
sudo systemctl restart pydpiper.service

However after rebooting I am still not getting a readout on the LCD.

I did have a question about this step:

sudo ./install_volumio.sh

Do I need to enter anything here for the configuration prompts?

I did not see this step specifically mentioned in the guide.

Also are there any additional steps I need to do ?

what display are you using for pydPiper? how is it connected?

I am using this 20x4 LCD display from Sunfounder

I have it connected to RPI4 : SDA 3, SCL, 5 , GROUND 6, VCC 4.

You need start sudo ./install_volumio.sh. Least you need to specify the driver - “hd44780_i2c”, width - “100”, height - “32”, page file - “pages_lcd_20x4.py”, musicdistro - “volumio” , i2c address - “0x27”, i2c port - “1”.
for the rest of the parameters, just press the “enter” key and they will remain by default.

Ok tried that and rebooted the Pi. Still nothing when the music plays.

Does it matter that I have an Allo DigiOne installed? I’m using a GPIO splitter to feed the LCD display. I know that the DAC uses pins 3 & 5 for I2C. From my understanding this should be ok as long as the devices have different addresses.

sudo i2cdetect -y 1 or
sudo i2cdetect -y 0
Your display datasheet:
Default Address: 0x27, 0x3F.
Check if the position of sda and scl is correct. There is a contrast control on the display board. Twist it. Try all this if there are no errors on the command line when running pydpiper.service.


Here are the I2C devices

UU is the reading of when only the DigiOne is connected.

The 27 is the LCD display.

I can confirm that the SDA & SCL positions are correct.

I tried adjusting the contrast controls (and it adjusts contrast) but nothing else. This is the default look of the display

When I run: sudo systemctl restart pydpiper.service I get no errors nor confirmation of success. Just a clear terminal.

1 Like

look for the error. misspelled driver parameters or pages file.

Step 2. Edit the pydpiper.service file

A systemctl services file has been provided with examples for several different popular configurations. You will need to enable the appropriate ExecStart line for your particular configuration. You do this by removing the ‘#’ character at the start of the line for the ExecStart that is appropriate. It is possible that you will also need to edit some of the values for the ExecStart command if your configuration is different than what was provided.

IMPORTANT: There must be one and only one ExecStart enabled within the file.

The general format for the ExecStart lines is as follows:

ExecStart=/usr/bin/docker run --network=host --privileged -v /var/log:/var/log:rw dhrone/pydpiper:latest python /app/pydPiper.py --<musicdistro> --driver <driver> --width <width> --height <height> --i2caddress <i2caddress> --i2cport <i2cport> --rs <rs> --e <e> --d4 <d4> --d5 <d5> --d6 <d6> --d7 <d7> --timezone <timezone> --temperature <temperature> --lmsplayer <lmsplayer> --pages <pagefile>

Definitions for command line Parameters

<driver> – Driver for your display. Possible values are ‘winstar_weg’, ‘hd44780’, ‘hd44780_i2c’, ‘ssd1306_i2c’

<musicdistro> – Sets the type of music player pydPiper is installed on. Possible values are ‘volumio’, ‘rune’, ‘lms’

<width> – width of your display in pixels. If you are using a character display, each column is 5 pixels wide <height> – height of your display in pixels. If you are using a character display, each line is 8 pixels high

For I2C displays <i2caddress> – The I2C address your display is installed on. Normally 0x27. <i2cport> – The I2C port your display is attached to. Normally 1.

This is what I entered into the prompts triggered by:

sudo ./install_volumio.sh

For the last command:

sudo systemctl restart pydpiper.service

Should it be pydpiper.service or pydpiper.volumio.service being passed into the above command?

pydpiper. service.
everything is correct for you and should work. further I am powerless. examine the log file of the program.


I did a fresh flash of the latest version of buster and re-installed using the install guide on https://github.com/dhrone/pydPiper

Thank you so much for helping me work thru this :slight_smile:

I have to see about tweaking the formatting (note the un-used line)
but so excited to have it working now.