Volumio 3 Buster general issues

This is a list of currently known, general Volumio 3 problems:

  • Bluetooth is not working correctly
  • Local lib by artist show albums and tracks, but click on album art gives nothing
  • Volumio web radio picks are not available in beta, but will be for the released version
  • Userconfig.txt is not preserved. Is overwritten with default values during update process.
  • When scanning library from NAS, spinning wheel missing
  • USB Auto-update not working
  • the WiFi network configuration with static IP continues to be erased
  • Browse by artist for some album does not work

There is no need to report these as a bug.


Error: ENOENT: no such file or directory, open ‘/sys/class/net/eth0/address’

See http://logs.volumio.org/volumiobuster/eWZYg2m.html
Near timestamp 11:46:03

Missing eth0 is “normal” for some x86 notebooks/ tablets, they just have wireless!!

1 Like


tested version: 2021-02-26-x86_amd64-volumiobuster-3.047

There seems to be a weird resampling when playing webradio.
You can see the bit rate of the stream coming from the radio station (128k, 192k, 320k).
The SPDIF or HDMI sync is varying from 44.1kHz to 48kHz.
At 192k and 320k stream quality the SPDIF / HDMI sync is always at 44.1k.
At 128k stream quality webradios the SPDIF / HDMI sync is sometimes 44.1 sometimes 48k sync.

The attached NAD C510 amplifier is capable (and working) to sync up to 192k on SPDIF and HDMI.
Volumio “Auto resampling” is configured to be off.

Can you please explain why and what kind of resampling is active in the box? :slight_smile:

volumio@smx:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Host Bridge (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Device 5a85 (rev 0b)
00:0e.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster (rev 0b)
00:0f.0 Communication controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Trusted Execution Engine (rev 0b)
00:12.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series SATA AHCI Controller (rev 0b)
00:13.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port A #1 (rev fb)
00:13.1 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port A #2 (rev fb)
00:13.2 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port A #3 (rev fb)
00:13.3 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port A #4 (rev fb)
00:15.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series USB xHCI (rev 0b)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Low Pin Count Interface (rev 0b)
00:1f.1 SMBus: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series SMBus Controller (rev 0b)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
03:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 02)
volumio@smx:~$ inxi
CPU: Quad Core Intel Celeron J3455 (-MCP-) speed/min/max: 2268/800/2300 MHz Kernel: 5.10.17 x86_64 Up: 21m
Mem: 523.5/3789.1 MiB (13.8%) Storage: 1020.82 GiB (1.6% used) Procs: 170 Shell: bash 5.0.3 inxi: 3.0.32
volumio@smx:~$ inxi -Fxxxz
System:    Host: smx Kernel: 5.10.17 x86_64 bits: 64 compiler: N/A Console: tty 0 dm: N/A Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop Mobo: ASRock model: J3455-ITX serial: <filter> UEFI: American Megatrends v: P1.40 date: 07/14/2017
CPU:       Topology: Quad Core model: Intel Celeron J3455 bits: 64 type: MCP arch: Goldmont rev: 9 L2 cache: 1024 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 11980
           Speed: 2280 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 2196 2: 2258 3: 2266 4: 2235
Graphics:  Device-1: Intel vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5a85
           Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa tty: 184x50
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster vendor: ASRock
           driver: snd_hda_intel v: kernel bus ID: 00:0e.0 chip ID: 8086:5a98
           Sound Server: ALSA v: k5.10.17
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: e000
           bus ID: 01:00.0 chip ID: 10ec:8168
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1020.82 GiB used: 16.13 GiB (1.6%)
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 1B6Q
           scheme: GPT
           ID-2: /dev/sdb type: USB vendor: Intenso model: Rainbow Line size: 29.69 GiB serial: <filter> scheme: GPT
           ID-3: /dev/sdc type: USB vendor: SanDisk model: Ultra size: 59.62 GiB serial: <filter> rev: 1.26 scheme: MBR
Partition: ID-1: / size: 25.93 GiB used: 33.8 MiB (0.1%) fs: overlay source: ERR-102
           ID-2: /boot size: 170.8 MiB used: 57.4 MiB (33.6%) fs: vfat dev: /dev/sdb1
Sensors:   Missing: Required tool sensors not installed. Check --recommends
Info:      Processes: 170 Uptime: 21m Memory: 3.70 GiB used: 528.1 MiB (13.9%) Init: systemd v: 241 runlevel: 5 default: 2
           Compilers: gcc: N/A Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32


Known from an Intel Atom configuration with the bytcr-rt5640 codec: sound “non-chipmunk” only with setting resampling to 16bit.
Doing further investigating to make this work out-of-the-box (may not work for all rt5640 devices).

Also for SBCs with only WiFi like the PiZero and OpiLite… :slight_smile:

Low hanging fruit, as it isn’t critical, but should be fixed in

Regarding “Plugin Lifecycle”:

If the promise is rejected in the “onStart” function of a plugin the red dot in “Plugins Management” shows the plugin “inactive” while the switch is set to “On” position.

After reloading the “Installed Plugins” page the dot is green and status shown as “active”. Accordingly in /data/configuration/plugins.json the value for “enabled” is “true” and the value for “status” is “STARTED”.

I think this is the same on Volumio 2 but shouldn’t the plugin remain disabled (switch position “Off”) and its status be “inactive” if it fails to start?

Hi all,

could it be made possible to integrate an option to „retry to start a plugin that is only available in dev mode“ ?

I guess this could be helpful for testing and therefore for the plugin devs as well


when uploading a new background jpg image (appearance menu)
:x: there is no preview icon generated

  • Volumiobuster-3.053-2021-03-06-x86_amd64.img
  • Volumiobuster-3.054-2021-03-09-x86_amd64.img
  • Volumiobuster-3.055-2021-03-12-x86_amd64.img

It looks like this:

You are able to use the new background but the preview icon is not generated.

I am able to upload a background file “picture.jpg” and a 300x200 px “thumbnail-picture.jpg” via the UI - then it looks fine. :wink: It’s the generation process after the initiial upload, that’s not working.

May be this snippet out of the logfile can help… Is it because thumbnails are generated by a plugin and the plugin system is not included in this beta yet?

Mar 13 16:28:01 smx volumio[735]: Uploading: Klingenberg004.jpg
Mar 13 16:28:01 smx volumio[735]: Background Successfully Uploaded
Mar 13 16:28:01 smx volumio[735]: info: CoreCommandRouter::executeOnPlugin: appearance , generateThumbnails
Mar 13 16:28:01 smx volumio[735]: info: CoreCommandRouter::executeOnPlugin: appearance , getBackgrounds
Mar 13 16:28:01 smx volumio[735]: error: Failed to generate thumbnails: ReferenceError: f is not defined


edit 2021-05-11 :
This issue is solved in 2021-05-07-x86_amd64-volumiobuster-3.073



in version Volumiobuster-3.055-2021-03-12-x86_amd64.img
there is some i18n / l10n information missing.
When navigating to a certain artist in TIDAL the chapter headlines are not available. Instead of the translated text the variable names are displayed:


I tried German and English - the texts are missing there and probably in other languages as well.


Same issue:

edit 2021-05-11
This issue is NOT solved in 2021-05-07-x86_amd64-volumiobuster-3.073

edit 2021-05-22
This issue has not been solved in Volumiobuster-3.077-2021-05-20-x86_amd64.zip

Not sure if this is a Buster specific problem, but it is here in both Arm & x86 that I have noticed that on the hotspot running on first boot with the ‘first config wizard’, the chosen wifi network password field is not visible on my Android mobile (but occasionally is, just to be awkward ). I can see it ok on a connected laptop, but even here the field is very far to the right (outlying the green border lines).

Tidal playback stops after playing one song (6 seconds before the end if this song) in a list of songs (i.e. an album)
Version: Volumio beta 3.055 (Volumiobuster-3.055-2021-03-12-x86_amd64.zip)

Today everything is working fine again with Tidal.
Seems to be a server-based problem that apparently has been solved…



now I see the “Tidal problem” again. Every time I start a sequence of songs (i.e. an album) playback of Tidal stops after he first or the second song in the list. After that playback is not possible until I wait a few minutes and start a single song or I change the Playback Potions to another output device.

Since I didn’t see such things over the last couple of months I’m now tending to the opinoin that this issue has its cause in the beta program.

May be somewhere in MPD or ALSA ?

Version: Volumiobuster-3.055-2021-03-12-x86_amd64


In a intermediate version out of december 2020 (2.857) the playback and UI (tidal, albums, webradio, etc.) is completely stable and robust.

There is definitely an issue with the beta 3.x regarding playback of tidal / albums…

Here’s a log (Volumiobuster-3.058-2021-04-10-x86_amd64.img) when this problems (playback of WEBradio and Tidal noch stable) occur:

2021-04-13: (Volumiobuster-3.055-2021-03-12-x86_amd64)
Tidal is stopping again - 6s before the end of the track playback mutes, then no further playback is possible…



20 posts were split to a new topic: Pi-hole with Volumio 3?

i just started installing Volumiobuster-3.073-2021-05-07-x86_amd64on my Volumio 2 Systems.
On an Intel X86 System ( Asus P5G41T/M_LX3 MB, Core 2 duo, 6GB) most of the time everything works fine ( except known issues) , but sometimes the Media Servers ( Synology 920 NAS) ist not shown - even when i play music from that NAS ( because the link is still stored from the last session) at the same time or from Internet Radio - so Networking is o.k. !.
I had that just once after app 10 restarts. I run Volumio Buster form SSD - the system has no USB 3 and boots very slow from USB 2 so i copied the system on a small SSD.
(Thats a very good option to do that from Volumio itself)
Waiting for some minutes did not help.

This post is a “Volumio 3 beta for x86” issue, not a general one.
Please post this again and stick to the rules outlined in the first post of the “Volumio 3 for x86” thread.
We need hardware info and logs, without it we are not able to offer support.

A post was split to a new topic: Access/Hot Point Password

The user interface had numerous display issues when running the setup wizard. Controls, especially drop-down menus would disappear when I clicked on them, then reappear, only to disappear again after attempting again to access them.

I noticed the browser attempting to connect to external web sites. It was failing, of course, because my only network interface was attached directly to the device operating as an access point. My browser had no outside access. I eventually succeeded by attaching a second WiFi controller, a USB device, I had available, to maintain the separate WiFi connections. Plainly this option is not always available.

Generally, a device controlled through a web interface should be able to serve the entire interface internally. Expecting either the device or the client to have internet access at all times when attempting to control the device presents to me as a bad design choice.

I may be misunderstanding the design based on a few small observation available to me, but I certainly stand by the recommendation to maintain a design free from internet dependencies.

I would recommend you to read the very first post of the beta test instead of complaining. In case you have difficulties with the quality of the beta, you should not have joined the beta program.

@gkkpch: Are you referring to the post that begins with the following invitation?:

Help us improve the Volumio experience … let us know what works & what doesn’t.