Volumio with 3.5" TFT Touch Screen (GPIO) RPi 3B+

Great it’s working! :grinning:

Do you have a TP-Link switch? Experience the same behavior with this switch.

@siod that was what i had with volumio 2.xx version switched to 3.xx and fixed :slight_smile:
i have rpi4 4gb

No, my router is an Asus RT-N56U.

mmh, I dont know where I can get ver 3.x.x !?

it’s still in beta not all have plugin’s in store

1 Like

Nothing has worked for me. I give up. the Chinese screen to the drawer forever.

how do you mean @cutandaweb ?

I have no idea about Linux. I have bought a Chinese screen and I have followed the instructions in the thread without errors.

In the end, the system has stopped working.
I have made the decision not to keep trying and not to install anything that is not directly supported (based on my knowledge and for the sake of system stability).

@cutandaweb please wait for gvolt he knows a lot about screens.

@gvolt can you help him with his screen.

@cutandaweb I think I could guide you through the installation step by step. Are you willing to make another attempt to get the screen working?

Thank you wholeheartedly. but I prefer not to try it anymore

very thanks, this is useful, resolve my problem

excuse me. I get an error when I run the following command: sudo cp tft35a-overlay.dtb / boot / overlays / Error code cp: missing destination file operand after’tft35a-overlay.dtb / boot / overlays /’ Referenced URL 3.5_inch_Volumio.pdf - Google Drive

IMHO you just need to run

sudo cp tft35a-overlay.dtb /boot/overlays/tft35a.dtbo

If you do that, you will get the following error: cp: cannot stat’tft35a-overlay.dtb’: No such file or directory

Did you download “tft35a-overlay.dtb” succesfully? If so, you need to change into the directory where “tft35a-overlay.dtb” has been saved to before you execute the provided command - or you have to give the full path to “tft35a-overlay.dtb” like:

sudo cp /path/to/tft35a-overlay.dtb /boot/overlays/tft35a.dtbo

1 Like

Before that I get the following error (sorry for linux beginners) sudo: mkdir / etc / X11 / xorg.conf.d: command not found

Command has to be:

sudo mkdir /etc/X11/xorg.conf.d

=> No blanks/spaces.

Hm, I thought you were following the instructions you have linked above… then you should have a directory called “LCD-show” with a subdirectory “usr” where you should find the file “tft35a-overlay.dtb”.

If you don’t have/find the directory “LCD-show”, you could do a step-by-step installation:

  1. Install the Touch Display plugin.

  2. Download the display specific overlay:

wget https://github.com/goodtft/LCD-show/raw/master/usr/tft35a-overlay.dtb

  1. Copy the overlay to “/boot/overlays/tft35a.dtbo”:

sudo cp tft35a-overlay.dtb /boot/overlays/tft35a.dtbo

  1. Open “boot/userconfig.txt”:

nano /boot/userconfig.txt

  1. Add the following lines:

It could be necessary to add a rotation value to the overlay later on.

  1. Save “/boot/userconfig.txt” by typing Ctrl+x then y and Enter.

  2. Download “99-calibration.conf-35-0” as it might be necessary to calibrate the screen:

wget https://raw.githubusercontent.com/goodtft/LCD-show/master/usr/99-calibration.conf-35-0

  1. Create “/etc/X11/xorg.conf.d” in case it’s missing and copy “99-calibration.conf-35-0” to “/etc/X11/xorg.conf.d/99-calibration.conf”:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo cp 99-calibration.conf-35-0 /etc/X11/xorg.conf.d/99-calibration.conf

  1. Open “/usr/share/X11/xorg.conf.d/99-fbturbo.conf” with

sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf

and change

Option "fbdev" "/ dev / fb0"


Option "fbdev" "/ dev / fb1"

Save the file hitting Ctrl-x, y and Enter.

  1. Reboot.

  2. If the display should not have the orientation you are looking for, add a rotation parameter to the overlay in “/boot/userconfig.txt” so it looks something like this:


This would rotate the display (not touch) by 90 degrees clockwise.

  1. Reboot once again.

  2. If the display rotation appears to be correct now, check if the touch function is already properly aligned to the display. If this should not the be case try to find out by what amount touch has to be rotated. Then head over to the Touch Display’s configuration page and set this value in the rotation setting.

  3. Reboot and check if touch is properly aligned to the display now. It is possible that setting the rotation in the prior step does not suffice. This would be the case if the screen’s touch axes are inverted or swapped which is not uncommon on these kind of screens… Then you would have to find out how the axes are inverted or swapped to be able to find a correction.

Edit: Corrected command in step 3.

1 Like