Volumio 3.395 Fast Beta-Test

Thanks for your great feedbacks guys. With your reports we were able to discover a memory leak in the new implementation. This was resulting the system-wide crashes you’ve been experiencing.

So, me and @mervinio were able to find a solution to avoid those memory leaks (and further improve the responsiveness). We also increased the efficiency of the cloud aggregator, you should see snappier browsing of TIDAL and QOBUZ.

Version is 3.396 and this is what is fixed:

Fix Pause and long tracks playback in TIDAL and QOBUZ
Faster retrieval of long playlists
Bigger artwork on small displays
Fix for discovery crashing
Various fixes for Highresaudio.com streaming
Fix crash on some specific networks when browsing mdns

Let us know how that goes! If all good, we’ll release to the general public.

@Lintbf I suggest not to try beta releases if you don’t feel comfortable testing and you prefer a stable system :wink:

Hi Mi,

just updated my rPi4-8GB to V3.396. Will report back my findings.

Hi ,
I am ok with testing , but we did not receive any feedback from you and I have understood that is a fast check :slight_smile: I will update and see if the issues arise again . Now that it is fixed , I am curious .

Yeah we did not communicate as quickly as we would have liked :wink:

1 Like

Updated to 3.396. Found a weird bug.

Volumio on RPI4 8GB wired. Using Tidal and going to my Topping D90SE with USB. Started playing the 2018 remastered Pink Floyd - Animals album and noticed that in the web ui said it was streaming MQA at 48khz 24bit, but on my topping display it was showing 192kHz being played. No oversampling enabled anywhere.

This is not a bug and has been discussed many times on this forum.
Search the forum for “MQA Container” Or look at: Volumio 3 web interface shows 44.1kHz 16bit but - #11 by Wheaten

1 Like

Tested with a rPi4-8GB, cabled network.
Only Qobus, Spotify enabled

Fix Pause and long tracks playback in QOBUZ
Tested with a 9:32 track. Play back is causing no issues. even after a 6 hour pause, the song continuous without problems.

Faster retrieval of long playlists
Playlist with 385 tracks. Loaded within 10 seconds. First manual selected track from this list started within 7 seconds, , loads within 2-3 seconds.

Bigger artwork on small displays
Dynamic scaling is still not optimal. Used resizing with browser

Fix for discovery crashing
No experience with this

Various fixes for Highresaudio.com streaming
Not tested

Not tested

Fix crash on some specific networks when browsing mdns
Don’t have this issue within my network

Ran a 2nd test just playing a playlist, some issues occurred:
log: http://logs.volumio.org/volumio/2GfhCrt.html
getTrack 5, stuttered 3 times before continuous play
gettrack 14, interruption sound for 2 seconds
gettrack 24,25, Sometimes after a pause, Qobuz (sound output) stutters a bit, When this happens the time slider gets out of sync. Seems it’s not restoring itself. This screenshot is form the start of song. but the slider is at 20%. This continuous for the remainder of the list.
Unless I skip to the next track, than the slider resets itself.

in these occasions, the seek value is way out of it’s comfort zone:
{"status":"pause","position":0,"seek":202314,"duration":261,"samplerate":"48 kHz","bitdepth":"24 bit","channels":2,"random":false,"updatedb":false,"repeat":false,"bitrate":"1898 Kbps","isStreaming":false,"title":"87402763","artist":null,"album":null,"uri":"","trackType":"qobuz"}

{"status":"play","position":0,"seek":202335,"duration":261,"samplerate":"48 kHz","bitdepth":"24 bit","channels":2,"random":false,"updatedb":false,"repeat":false,"bitrate":"1943 Kbps","isStreaming":false,"title":"87402763","artist":null,"album":null,"uri":"","trackType":"qobuz"}

Until now , so far so good with qobuz , also the progress bar is ok now

Just installed the latest system update. System reboot and now playback errors. Am I the only one?


1 Like

I updated to the latest beta and this Volumio on my test system has been running like a 1 for many hours!
I almost only use Qobuz and Radio, rarely my FLACs. I’m very satisfied.
I noticed the improvements immediately.
Thanks very much!

Can you send us a log if you can?

Do you have a premium or free account?

From which version did you upgrade from?

@volumio Qobuz is stuck …
I have tried also from other sources but only after a reboot was working again
Also other sources was not working until a reboot


1 Like


Please find the log above with a short description of issue.

1 Like

…also free account.

Also experienced Radio Paradise plugin not working.

It is out of beta now… updated during coffee break as suggested by Volumio’s fb post… damn my listening session is ruined due to completely broken manifest UI. Running on Asus Tinker Board. Thats all what was left after update :smiley:

Yeee, I just discovered that I had SD card with Volumio version what I built myself a month ago as educational experiment. It lacks Manifest UI and streaming support - nothing what I need for my listening session, my listening session is saved :).

Tinkering can be fun, but it’s perilous :wink:

Glad you are still up and running

Failed upgrade was on unmodified offical version. I downloaded new image and try it tomorrow.

Updated to 3.396 still restarted on “Add New Drive”
3.396 log