Volumio 3.395 Fast Beta-Test

Hello Thank you for your very valuable work, you are great - I love Volumio!
After the end of the Qobuz playlist, i.e. after a few hours, Volumio stops playing…
It looks like it’s playing music, but there’s no sound.
After pressing the pause button, you notice that Volumio no longer reacts or reacts very sluggishly.
At some point the interface actually shows Pause. Then on play - Volumio not responding. It looks like the 17th track won’t be played anymore. Although I’m not sure how many times the playlist was repeated and whether it was the 17th track both times… (I had activated queue replay) If I play the same playlist after a reboot and browse through the tracks, everything works very well good. Unfortunately I forgot to select a different playlist or source. I’ll catch up.
However, access to the interface (web and app (android) works normally.
I found the whole thing exactly the same with two different Qobuz playlists.
The reboot command works normally. After that everything works fine again.


Allo HifiBerry DAC2 HD (My test system, otherwise I only use Allo BOSS2)
Hello Nirvana
Volume 3,395
Qobuz Hi-Res Masters: Indie-Folk Playlist (6:22)
Volumio Android App
Volumio web interface


Directly from Volumio

http://logs.volumio.org/volumio/bYW4Tu9.html (happened just before I posted my comment)

Qobuz just stopped . Ui is not responding anymore

Nothing is working anymore . I need to reboot
And btw , is there a possibility to revert to previous stable one versions without reflashing
I guess it will be a great addition .

Hi ,
Volumio 3.395 but the same behaviour observed also in v3378 .
iPhone 13 Pro iOS 16.1 app version
After put the Volumio application in background after some minutes if I open again , is not responding . I need to kill the app and open again to be able to access the Volumio ui.
I have observed the same behaviour also if I access Volumio from web browser .
Thanks for your help

@volumio any news regarding a new version ?
Because I am will install latest stable version .

1 Like

A post was merged into an existing topic: What would you want from your ideal music player operating system?

Same issues as prior without the repeated restarts.
Three systems all on 3.395. All on same wifi network.
#1 and #3 are physically on the same desk as WIFI access point for testing purposes.
#2 is directly above but on the next floor up.

Status. USB library is attached to #1. #2 &#3 can not connect to it with the +Add New Drive scan under Sources. Both systems restart and continue scanning without success.

#3 can see #1 from Remote Control Devices. Cannot see #2
#1 cannot see #2 or #3
#2 cannot see #1 or #2

To switch between devices requires closing app and restarting app on phone or tablet.
Clearly no multiroom under these conditions.

Note- shared library has worked reliably in past versions
Multiroom was available but erratic which prompted me to update system
Never got back to previous functionality

Will post logs

Log of system #1
Log of system #3
Log of system #2

Well, this is certainly timely. I use Volumio on a miniDSP SHD Studio, 90% streaming Qobuz. I grew so frustrated that my wife volunteered that I should get rid of it an buy something less frustrating. So, it’s up for sale (see USAudio and the miniDSP user forum classifieds). Now when was the last time your wife actually encouraged you to spend money on a new piece of stereo equipment? That’s the best evidence I have of seriously deficient software!


And the log with the app not responding

1 Like


Hi Tom,
Not sure why the harsh response.
If you have issues or things are not working out, you can ask for help on the forum.
So far the only topic I’ve seen is an explanation to you that Volumio is a operating system and not an installable app.


Here is what I responded to Wheaton with. I actually didn’t know what to post to the user community. My best advice to the Volumio development team is to spend some time with successful UI’s like those of Bluesound and Spotify. They work well and are intuitive. Try to get some perspective outside of your geek bubble, if you actually want to appeal to a broader customer base.

Wheaton - Sorry for being so caustic, but my year-long experience with Volumio was not good. For context, I stream Qobuz for music and Spotify for podcasts. Previously, I used a Bluesound Node 2i streamer which, as you may know, uses the services’ apps (i.e., the Qobuz app) for the UI when controlling music search and selection, unlike Voluminio. Be that as it may, I had no problem using the Bluesound, Qobuz or Spotify UI’s without having to resort to the community forums for advice.

Specifically, Volumio latched onto one track I once played from Spotify. It would play that track every time I started the Volumio app up on my tablet. Worse, when I tried to select an album or artist and play the offered list of tracks Volumio would revert to playing that one latched-on track after every song. I came to hate that latched-on Spotify song so much that I turned off and uninstalled the Spotify plug-in in an unsuccessful attempt to rid myself of that detestable song. No dice. Volumio haunted me with that damn song. At one point I almost threw my tablet at the wall - and my wife said just spend the money and get something that works.

There you have it. My blood pressure rose just relating this.

Tom Reepmeyer

Hi Tom,

I understand that continuous repeating the same song gets pretty annoying. Not sure what happened as this is not normal behavior, even though the Spotify is still not 100%, this one is new.
Sorry to see you go

Hi @volumio
Any news when a new version will be released ,? It is quite frustrating to Listen to qobuz in this conditions …

Thanks for your great feedbacks guys. With your reports we were able to discover a memory leak in the new implementation. This was resulting the system-wide crashes you’ve been experiencing.

So, me and @mervinio were able to find a solution to avoid those memory leaks (and further improve the responsiveness). We also increased the efficiency of the cloud aggregator, you should see snappier browsing of TIDAL and QOBUZ.

Version is 3.396 and this is what is fixed:

Fix Pause and long tracks playback in TIDAL and QOBUZ
Faster retrieval of long playlists
Bigger artwork on small displays
Fix for discovery crashing
Various fixes for Highresaudio.com streaming
Fix crash on some specific networks when browsing mdns

Let us know how that goes! If all good, we’ll release to the general public.

@Lintbf I suggest not to try beta releases if you don’t feel comfortable testing and you prefer a stable system :wink:

Hi Mi,

just updated my rPi4-8GB to V3.396. Will report back my findings.

Hi ,
I am ok with testing , but we did not receive any feedback from you and I have understood that is a fast check :slight_smile: I will update and see if the issues arise again . Now that it is fixed , I am curious .

Yeah we did not communicate as quickly as we would have liked :wink:

1 Like

Updated to 3.396. Found a weird bug.

Volumio on RPI4 8GB wired. Using Tidal and going to my Topping D90SE with USB. Started playing the 2018 remastered Pink Floyd - Animals album and noticed that in the web ui said it was streaming MQA at 48khz 24bit, but on my topping display it was showing 192kHz being played. No oversampling enabled anywhere.

This is not a bug and has been discussed many times on this forum.
Search the forum for “MQA Container” Or look at: Volumio 3 web interface shows 44.1kHz 16bit but - #11 by Wheaten

1 Like

Tested with a rPi4-8GB, cabled network.
Only Qobus, Spotify enabled

Fix Pause and long tracks playback in QOBUZ
Tested with a 9:32 track. Play back is causing no issues. even after a 6 hour pause, the song continuous without problems.

Faster retrieval of long playlists
Playlist with 385 tracks. Loaded within 10 seconds. First manual selected track from this list started within 7 seconds, , loads within 2-3 seconds.

Bigger artwork on small displays
Dynamic scaling is still not optimal. Used resizing with browser

Fix for discovery crashing
No experience with this

Various fixes for Highresaudio.com streaming
Not tested

Not tested

Fix crash on some specific networks when browsing mdns
Don’t have this issue within my network

Ran a 2nd test just playing a playlist, some issues occurred:
log: http://logs.volumio.org/volumio/2GfhCrt.html
getTrack 5, stuttered 3 times before continuous play
gettrack 14, interruption sound for 2 seconds
gettrack 24,25, Sometimes after a pause, Qobuz (sound output) stutters a bit, When this happens the time slider gets out of sync. Seems it’s not restoring itself. This screenshot is form the start of song. but the slider is at 20%. This continuous for the remainder of the list.
Unless I skip to the next track, than the slider resets itself.

in these occasions, the seek value is way out of it’s comfort zone:
{"status":"pause","position":0,"seek":202314,"duration":261,"samplerate":"48 kHz","bitdepth":"24 bit","channels":2,"random":false,"updatedb":false,"repeat":false,"bitrate":"1898 Kbps","isStreaming":false,"title":"87402763","artist":null,"album":null,"uri":"","trackType":"qobuz"}

{"status":"play","position":0,"seek":202335,"duration":261,"samplerate":"48 kHz","bitdepth":"24 bit","channels":2,"random":false,"updatedb":false,"repeat":false,"bitrate":"1943 Kbps","isStreaming":false,"title":"87402763","artist":null,"album":null,"uri":"","trackType":"qobuz"}