Raspberry + Kali + Allo Piano 1.1 dead due to shortcut

I have a raspberry pi with kali reclocker and Allo Piano 1.1. This DAC was a very initial model they sold back in 2013?. Everything was working nice and smoothly, but yesterday I wanted to pack the whole system in a metalic case I was reusing from and old sat receiver. Long story short: I think I it got shorcut because everything turned off suddenly.

Plugged everything on again without the metalic case and seems to work: I can access the volumio url, I can “play” things (both from NAS, web radio or airplay), reclocker seems to work (changes light when sending 44.1Khz signals) but Allo Dac seems not to work. I can’t get any sound from its L+R connections.

I’ve been troubleshooting with the source configuration through volumio configuration, but nothing works (granted is well configured: I2S activated and Allo Piano selected). Finally, I have taken out the Piano DAC and kept rpi with kali reclocker, configured the headphones output in volumio, hooked headphones to the rpi and it works, so I concluded that the DAC should be dead (though the leds on it do light on green).

¿Any advice?

And in case I have to replace the DAC, ¿any advice? I guess I can only go to the Piano 2.1 if I want to keep the Kali Reclocker, ¿right?

Thanks in advanced!

did you try upsampling?
[Hardware and Software Interaction ?] Volumio 3.4xx + Kali reclocker + Piano 2.1 DAC, Dual Stereo output not the same - #9 by michel8166
There are some boards out there if you want to keep the kali.
for example:
AUDIOPHONICS DAC I-Sabre ES9038Q2M Raspberry Pi / I2S & SPDIF / PCM DSD USB-C Power Supply - Audiophonics

1 Like

Thanks for the reply.

I’m not sure how to do the upsampling. Followed the thread attached, but the command indicated doesn’t work: (in my case, I tried both with allo-piano-dac considering is the 1.1 version, but also with plus, and nothing happens)

dtoverlay=allo-piano-dac-plus-pcm512x audio,glb_mclk

Find attached the screenshot with volumio playing a 16bit flac 44.1Khz whilst showing alsamixer

Sorry, perhaps I have not chosen the best topic to explain.

you find this in settings - payback options - audio Resampling
turn target bit depth to 32bit and save.
Solved - No sound (just noise) after update allo piano+ kali - #2 by judydudi

do you get static noise or no sound at all?

No sound at all… Definitely, something is gone… Considering what to buy now to take advantage of Kali, I don’t want to get rid off it.

Too bad, every slave dac should work with the kali reclocker.

I have to set up someone’s kali reclocker and piano 2.1 next week… I’ll check a few things to see if everything is going okay there.

Piano 2.1 is not sold any more, too bad :frowning:

I was considering Audiophonics DAC I-Sabre ES9038Q2M

Any other recommendation?

I have an unused Piano 2.1 and a Kali…
PM me if interested :wink:

1 Like

I’m trying with a new Piano 2.1 and the old Kali and Raspberry Pi 3. So far, no sound. Find bellow the log just in case someone could help. The situation:


Everything seems to work. The raspberry gets sound over the headphones connector, hence the raspberry works.

Kali seems to be working, because is the one that gets the power (iFi) and supplies the raspberry and DAC.

Piano Dac 2.1 should be OK because was previously owned by balbuze and he confirms it works.

However, no sound at all. AlxaMixer recognizes the PianoDACPlus: find bellow screenshot

I don’t think it’s a matter of dual-mono vs dual-stereo. I have tried both configurations with both connections of RCA cables (dual-mono is outer connectors, dual-stereo es just lef-right) and I got no sound at all. Needless to say that cables, amp and speakers work ok.

Any ideas?

As volume mixer in volumio, try to set digital instead of master…

I couldn’t figure out how to change it. Is there any key? Using arrows reduces or increases volume.

did you try setup without kali?

Yep. No sound either… very strange 'cause everything seem to work (leds, web portal). If anything, volumio is connected through rj45 cable to the LAN, not wifi.

simply like that

1 Like

perhaps irritating, but you could try an earlier version. I had the same problem with a few dac’s that I couldn’t hear anything at first and then got them to work with a previous version. An update to the current version then also worked!
Downgrade Version - #2 by M1ck

1 Like

Hardware volume control only offers me this options:

No worries judydudi, i have no more options, so I will give it a try now

try main analogue…
And @judydudi is true, mine was on old version (2 years old?)… I didn’t test with an update…

nothing either. I’m going to try the downgrade flashing the card and keep you updated!