Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

@Roberto_Grieco
Hey, it seems, that is depend on sound card. Can you please try to enable hdmi out instead and look if Spotify play without break.

1 Like

I have the same issue with skipping tracks on Spotify. Oddly, if I install and activate FusionDSP and Spotify, Spotify seems to play through tracks completely. Unfortunately I seem to have a different problem with that combination - I get crackles and pops in the music that I don’t get with Spotify (and no PPY/Fusion). Still trying to sort that out.
I know just enough to be dangerous but - wonder if something gets installed with FDSP that helps Spotify play tracks through?

@Roberto_Grieco
Please try the configuration with ‘modular alsa’ and disabled spotify integration.
With the most of sound cards this not working (scrampled sound for Spotify) but with HDMI output this works without problem. Maybe with your USB DAC. Can you try this

@michel8166
your pcm output device is busy. Please do not change any settings with running sound. Please select another song after change, not the same.
And when you switch the source press stop at first and search then another song.
In some circumstances a reboot is needed after switch the alsa mode.

Hey @fjmarch
Fusion DSP interrupts the audio pipeline and feeds back in after the DSP. Therefore the sensible Spotify output is not more the input for peppyalsa. The fusionDSP output works better as input for peppymeter.
Have you breaks with spotify, if DSP disabled, the also please try ‘modular alsa’ with disabled Spotify integration.

I did a new installation of volumio.
everything installed on DSD native separate pipe, internet radio plays and everything okay.
Spotify integration on and a reboot.
Spotify pressed play and then nothing happens, on the next song, nothing either.

I get this error every time and I really don’t press to the next number too quickly.
I first stop everything that is running before I use Spotify.

could it be that in my case it has something to do with the fact that in the new version (3.611) dtoverlay dac slave has been added to dacs that work in master mode.

Starting Live Log...
time="2024-02-13T20:17:38+01:00" level=debug msg="fetched first chunk of 16, total size is 7991800 bytes"
time="2024-02-13T20:17:39+01:00" level=trace msg="seek to 0ms (diff: 0ms, samples: 0, bytes: 0)"
time="2024-02-13T20:17:39+01:00" level=error msg="failed handling status request" error="failed loading context: failed loading current track (load context): failed creating stream: ALSA error at snd_pcm_open: Device or resource busy"
error: Failed to send command to Spotify local API: /player/play: Error: Internal Server Error
time="2024-02-13T20:17:39+01:00" level=debug msg="fetched chunk 1/15, size: 524288"
time="2024-02-13T20:17:39+01:00" level=debug msg="fetched chunk 2/15, size: 524288"
time="2024-02-13T20:17:39+01:00" level=debug msg="fetched chunk 3/15, size: 524288"
info: CALLMETHOD: system_controller system enableLiveLog true
info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog
info: Launching a new LiveLog session

I remember that I have the same on 4.0.4 Spotify and I back to 4.0.3.

But now 4.0.4 works ( I think slower than 4.0.3 but play after 2 seconds

yes this is possible, to locate the problem I would remove the dtoverlay driver and select HDMI output and check again if Spotify running

HDMI works.

I installed Spotify version 4.0.3 and now it plays but no movement on the meters.
selected DSD native separate pipe.
spotify intergation on, no sound or movement vu meters.

If you reinstall spotify, then its important to switch the spotify integration to off save and then on again, to re-route the alsa output from spotify plugin.
But I think, an older version not solved the problem with your soundcard driver.
You can try another overlay driver for this card

If I now enable Fusion DSP integration, the VU meters work, but I have to turn my preamp almost full to get sound.
I think you are right and it is my DAC. I’ll try another driver and see if that helps.

I’ll stop using it, I can’t get it to work.

perhaps in the future I will purchase another DAC that can play standard frequencies and not just 24 bit/192 khz.

It’s strange that in previous Volumio versions I could use the standard audio resampling, but not anymore (I could have tried that)
I’m curious what will happen if I update a friend’s streamer… probably the same problem but with a Fifopi Q7 reclocker.

Hi!

I installed vers 1.4 and everything works just as supposed! Great contribution!!
Thanks

Best Regards/ C

@2aCD i tried your configuration with modular alsa and spotify integration disabled but the problem of skipping traks is always the same…unfortunately the situation has worsened. as soon as a track starts playing you hear a noise for 1 second and no music and then it automatically goes to the next track

Ok that was only a try, not recommend. Is the sound the same as you enabled the Spotify integration with modular alsa?
And try to enable in ‘Playback Options’ the audio buffer size to 12MB.

@2aCD with modular alsa and spotify enbled the sound is Ok but the track skip but after random time playng…

Also with audio buffer = 12MB?
And please try the HDMI output.

A post was merged into an existing topic: Volumio x86 + PeppyMeter

@2aCD I tried the 12MB buffer and HDMI output, and Peppy + Spotify were ok, tracks don’t skip but my system doesn’t have an HDMI connection to my amp but the sound start from volumio on raspberry go to my SMSL C100 external dac by USB connection and finally goes to my amplifier by an RCA connection. But setting the HDMI output I cannot listen to music from my amplifier…but only from the speakers of my Waveshare display…Therefore this solution of setting HDMI out to solve the skipping problems is not good for me. can you still help me?

1 Like

Thanks for the great update @2aCD.

Made a small mod to the file “UIConfig.json” and “UIConfig_V0.json” to increase the time out to 86400 seconds.
Now I am able to control Peppy via my remote and/or GPIO to turn it on/off by using:
On:
bash /data/plugins/user_interface/peppy_screensaver/peppymeter/run_peppymeter.sh
Off:
rm /tmp/peppyrunning

as complete bash script with one button:
cd ~
nano peppy.sh

#!/bin/bash

# Check if volumio_peppymeter.py is running
if pgrep -f "volumio_peppymeter.py" >/dev/null; then
    # If it's running, kill both volumio_peppymeter.py and run_peppymeter.sh processes
    echo "volumio_peppymeter.py is running. Killing processes..."
    rm /tmp/peppyrunning
else
    # If it's not running, start run_peppymeter.sh
    echo "volumio_peppymeter.py is not running. Starting run_peppymeter.sh..."
    XAUTHORITY=~volumio/.Xauthority /data/plugins/user_interface/peppy_screensaver/peppymeter/run_peppymeter.sh &
fi

I thought to share it as it was requested multiple times over the last years. Since the impact on code is minimal. (or not even needed if people find 3600 enough)