Project with PeppyMeter/PeppySpectrum Screensaver Plugin for VOLUMIO

I have been running volumio with peppymeter flawlessly for over a year and all of a sudden a couple of weeks ago started running into issues. I currently (and have always had - no changes - no new plug-ins) PI4 & Topping D10 Dac and always run the most current version of volumio.
It started with the app becoming unresponsive and then I could not get volumio to respond at all - playing music from local files, Qobuz, Tidal, but could still get into settings/plug-ins. Nothing helped until I switched off Peppymeter. Once I did that, no problems. As soon as I turned it back on, the problems would occur again.
Decided to try a fresh install - completely started from scratch, even used a new SD card. After reinstalling everything back to what it was, it seemed to work normally again . . for one song and then poof, same problems started occurring. Switched off peppymeter, and that solved the problem again.
I searched through a lot of posts, but havent seen any widespread issues with the new version of Volumio (except having to do with Spotify, which I do not use)
Are there any know issues at this point with the new version? Since nothing else changed (literally nothing else), its the only thing I can think of.

how did you install Peppy, as plugin from post 7 or…?

installed as Plugin from post 7

please post the log and the output of:
cat /etc/asound.conf

# cat /etc/asound.conf ---------------
pcm.!default {
    type             empty
    slave.pcm       "volumio"

pcm.volumio {
    type             empty
    slave.pcm       "volumioMultiRoomServer"

# This PCM switches output to the ALSA target named by the file /tmp/multiroom/server/
pcm.volumioMultiRoomServer {
   type volumioswitch
   target_file "/tmp/multiroom/server/"
   control_fifo "/tmp/multiroom/server/switch.fifo"
   format_append "true"
   format_1 "DSD_U32_BE"


# This PCM switches output to the ALSA target named by the file /tmp/multiroom/client/
pcm.volumioMultiRoomClient {
   type volumioswitch
   target_file "/tmp/multiroom/client/"
   control_fifo "/tmp/multiroom/client/switch.fifo"

# This PCM performs any necessary rate/format/channel conversion before sending on to the Server FIFO
pcm.volumioMultiRoom {
    type plug
    slave {
        pcm "volumioMultiRoomFIFO"
        rate 48000 
        format "S16_LE"            
        channels 2        
    rate_converter "speexrate_medium"

# Write to the FIFO watched by the Server
pcm.volumioMultiRoomFIFO {
    type volumiofifo
    fifo "/tmp/multiroom/server/fifo"
    clear_on_drop false
    lead_in_frames 16384

# This pcm is used by pcm.volumioMultiRoomServer and pcm.volumioMultiRoomClient to play audio on the local output
pcm.volumioLocalPlayback {
    type empty
    slave.pcm "postMultiRoom"

# This pcm is used by pcm.volumioMultiRoomClient to discard audio and allow for faster switching
pcm.volumioDiscard {
    type null

pcm.postMultiRoom {
    type             empty
    slave.pcm       "volumioOutput"

# There is always a plug before the hardware to be safe
pcm.volumioOutput {
    type plug
    slave.pcm "volumioHw"

pcm.volumioHw {
    type hw
    card "D10s"

I still miss the log and are you sure you have installed the plugin correctly, as there are no entries for peppy in your asound.conf

cd ~
mkdir ./peppy_screensaver
miniunzip -d ./peppy_screensaver
cd peppy_screensaver
volumio plugin install

Hi - thanks for your quick response. Apologies, didnt realize you were asking for the entire log (its now attached below). I believe that I installed the plugin properly as it was working fine for over a year and I only just started having issues while nothing else in the setup changed. I tried once again this morning turning on the plugin, and it again worked fine for a few songs but then the entire thing became unresponsive - meters showed onscreen, but no movement, album cover art shows, but will not play and no buttons (play/pause, next, etc) react when clicked. Tried changing sources, but that does not help. Turned off the plugin, and everything went back to normal
Thanks for your help

For starters, try to load a smaller playlist, currently there are over 500 items. If tracks are no longer accesible, it might result in weird behavior. Just load an album from Qobuz for testing.
At least your asound.conf is correct now.

I don’t see anything concerning in the logs, besides the big load of tracks.

Yep - I think thats part (if not all) of my problem. Playing from Albums seeems to go OK, but when I try to play from tracks or playlists, is when the problems begin (only when peppymeter is turned on). Seems like I am out of luck then, since I dont want to remove favorites - may try deleting some playlists and see if that makes a difference
Thanks again for trying to sort out

1 Like

Hello everyone!

I have a question that couldn’t find in this thread. Are there any custom designs for a 7.9 wide 1280x400 screen with vu meters and play info?


1 Like

How about this: (you didn’t spend much time on searching, only this topic has +30 post on 1280x400)
But we’ve created a special section, to make it easier to find them:


Dear Andy, I am looking for similar enclosure or chasis to build a Volumio Streamer with waveshare 11.9 Inches screen with a RPI 4 , DAC, Power SMPS Inside. Can I get your suggestions and recommendations on the exact size or dimensions of the enclosure.

I assure you I was looking for several days, but I only found spatial info here and there. What you have posted is it possible to pin it somewhere? It would be very useful for future members and I thank you for this info! The thread is awfully long and too complicated!

1 Like

Euh, I’ve created a brand new category for the templates, can’t get it more sticky:

Hi Rajiv, sorry for a late reply. The box that I have a 7.9" touchscreen display was built by my friend in Thailand and he gave it to me during my visit. There are only the display and RPi4 piggy backed to the display controller with some extensions cord to the back. Nothing fancy but it looks good with my other components.

I wish I could help. BTW, it a wooden box.

1 Like


I am trying to put new skins into Peppy player but it is not working , i drag the file’s from left to right and merge the meters.txt from the left to the meters.txt to the right.
I can see the new meters in Peppy but nothing starts like normal in about 20 sec.
Please help

Dear @Biba our friend @Andy_Yong has posted a nice tutorial on You tube for the same

Are you sure you have followed all the steps in the video ?

Yes but in the file on de screen that you can see , it is not the same file as in de video.
The meters.tx that he change are not in a standard Volumio setting, in the 1024 x 600 that i download is not a add file just a meters.txt.
And i merge it with the meters.txt on the right site and i see the skins but no screensaver started.
I replace the meters.txt from the right with de meters.txt from the left and thats nog working also .

Can you send your meter.txt so I can help you take a look?


Hi, will you be able to peppy meter work with 1280 x 480 resolution? Thanks for your hard work.