Project with PeppyMeter/PeppySpectrum Screensaver Plugin for VOLUMIO

I have got it working, it seems there was a corrupt file, i remove everything en than install it back en now it works great.
Thanx for the message.

I see. I tried using 1280x400 but it is cut off at the bottom. I am using 1280x720, it works with some skins.

How do i create one myself? Is there a guide on how to make one? Thank you.

i gave you the link in my previous reply

oh sorry, i didn’t realize it was a link. Thank you so much. I’ll try to figure it out, i just built my Volumio setup a few days ago, this is all new to me. lol I bought the Eleclab 10.3 inch touch screen 1280x480. now im thinking of just returning it to get the waveshare 7.9.

1 Like

I received the 7.9 waveshare touchscreen and have everything up and running. How do i install skins for 1280x400? I cant seem to find the custom folder for it. I see all the other custom 1 to 6 folders but not the one for wide (2 channel 1280x400). Thank you.

@WarPath Upload to data/plugins/miscellanea/peppy_screensaver/peppymeter/wide

I have here the download link (wide (1280x400) to the complete file, including custom.

1920x515 fix

1 Like

I’m not sure how but I have borked my peppy install. The meters come up but don’t move. I tried a fresh volumio install but still have the same results. Not really sure where to start diagnostics. I’m on 3 installed with the plugin instructions.

did you follow these instructions?

I did the “download as plugin” instructions from post 7. Is this method different?

Running latest version of Volumio and peppymeters is no longer work. Got this error “Failed to open audio output”.

With peppymeter plugin disabled then no problem with playing.

Peppymeter worked before but after update of Volumio it no longer work.

this should be the same…

@Wheaten he buddy can you check if it’s still oke?

Can’t check, no hardware currently available for testing.

1 Like

in the peppymeter config, how do you have Alsa config set? I have to have it set DSD native just to not have an error

It plays if set to native but there are a lot of stuttering.
I think my Pi 2 not able to keep up with the new version of Volumio and peppymeter.
If I turn off peppymeter it plays well.

I just did a clean install on my rPi4-8GB, Allo digione.
Volumio: V3.512
Peppy: V1.3.0

It just works!.

It’s possible that a rPi2 has problems dealing with the workload.
please post a full log, as only giving info “It’s not working” doesn’t give us much info to work with.

log uploaded…

A I said stuttering when playing radio and local music.

The rPi2 can’t deal with the workload.
The log is full with entries like:
Decoder is too slow; playing silence to avoid xrun


Any news / updates about launching this as a plugin?


1 Like

For Information - I tried with Pi3 and same problem with audio. So either turn off peppymeter or use Pi4.