Previous stable version of volumio download link since latest version (3.569) breaks the pirate audio plugin


I’m using volumio with the pirate audio DAC and corresponding plugin. The latest version of volumio (3.569) causes this package to break - see :

I’ve tested on the beta/alpha version (3.584) which fixed the pirate audio screen and GPIO buttons but introduces too many bugs to volumio (the release notes specify unstable alpha build, please do not install).

I was wondering if it is possible to get a download link to the previous stable version of volumio so that I can install a working pirate audio plugin for the meantime until the next stable version of volumio is released. I think the last stable is 3.546 or 3.512 according to


1 Like

I’ve tried using[versionNumber]/Volumio-[versionNumber]-[YYYY-MM-DD] with the substituted version number and release date for 3.512 but to no avail.

It might be worth having a version history for easy download on the volumio website for others in situations like this in the future (similar to how operates)?

uhm you think they are not there? they are, only the date doesn’t match log :stuck_out_tongue:
(now deepblue is turning in to a red spicy meatball ( I’m getting the Fire extinguisher to cool him down.) )


Volumio Rpi - 3.512

1 Like

what kind of bugs did you found? knowing them would be very helpful



1 Like

Thanks for getting back to me with the links so fast both of you!

I’ve re-flashed to version 3.584 to try and encounter the bugs again (I was having audio playback stutter issues before when using it) but I don’t appear to have any issues, so it might have been a corrupted audio file or something.

I will have a further play around and report back with any bugs.

Cheers :slight_smile:

The GPIO permissions bug was solved (the new kernel was naming it differently) and we’ll release a fix version soon.

1 Like

Hi, I tried the links, are they working?
Because I would like to try the installation on RSP Zero
but the version released on 2024-02-21 is not working for me.
I tried link to 2.799-2020-07-16 and but they are 404
Could you help me pls?
Thanks for the responses.

tested the links here they are still downloadable.which ones do you need ?

but if possible, I would like to try the latest working version on RSP W, pls

i asked and any stable version should be good to go…

for example :

404 Not Found

this is the latest 3.631 version for rpi

if you need a other version say what version and we can look if it’s still there.
but the 2.799 isn’t there any more.

unsupported version 2.917 is the

all version in between 2.917 and the 3.631 we can find, best practice is always use latest version.