Pi4 and HiFiBerry DAC2 Pro

My setup is Raspberry Pi4 4GB
HiFiBerry DAC2 Pro (from PiHut)
Official 7" touch screen and Smartipi Touch Pro case.

I installed Volumio 2.882 today and it will not recoginise my DAC. I was quite surprised as I followed a guide online and the person said they used this exact one and it seemed to work for them. I’ve tried setting it to every HiFiBerry DAC in the option list (my exact model isn’t in the list) and restarted every time but no luck. I get no sound at all out of the DAC.

It’s strange because if I set it to not use I2S the headphone out on the pi works fine. It actually doesn’t sound that bad and has made me wonder about just using it this way instead. The interesting thing is, that if I have it in this mode there is a little green LED on the DAC itself. Still no sound out of it. However if I try and only the I2S options, the LED is off.

How do you go about getting a DAC added to the list. Does the actual DAC manufacturer need to do something to make it supported?

Has anyone managed to get this combo to work. I think I’ll just return this DAC and maybe get a different one. I thought this one was a good compromise between quality and price £45

read the last part of the pdf

Overlay for config.txt:

1 Like

Cheers for that.
I added that to boot\config.txt but still it doesn’t work. I tried setting it to use HiFiBerry DAC and HiFiBerry DAC Plus but still I get no sound and the little led is not on on the DAC itself. Am I missing a trick?
Also, I presume when you say add it to config.txt, it doesn’t matter is I add it to userconfig.txt instead does it? I’ve tried both and neither work but if you add it to config.txt I believe it will be overwritten with updates where as userconfig.txt is not.

i2s on and pick hifiberry-dacplus out of the list, add it in userconfig.txt

Sorry that doesn’t seem to work. After a reboot I’ve still got no sound coming through, the light isn’t on either. One good thing is that I’m not getting the ALSA error at least.

In the list there is “HiFiBerry DAC Plus” which isn’t exactly what you’ve written but I guess it’s that one you’re talking about?

Can you explain to me what this line is doing which you’ve had me add into config.txt

it seems to have the same name… with a space or not… for the config is doesn’t

it’s what HIFI Berry is saying to add a device tree overlay of your dac

but what kernel is 2.882 using? maybe see more to do … can you check it for me.

and for the pi3 is a solution i didn’t find if it’s works for the pi4

How do I check what kernel is it?

uname -r or uname -a or
cat /proc/version

OK I seem to have got it working. I saw something on the HiFiBerry forum relating to the config.txt file


I added the following lines to my boot\userconfig.txt file and it works now

unam -r

that’s the last of the posts i found it working on pi3 didn’t find it for pi4
you could test it oke
you will need to update the Linux kernel to at least version 4.18.12 your above that.
so no need for update

i would try the force_eeprom_read=0 in userconfig.txt it worked on pi3

if it’s working please post it…

Did you not only add the force_eeprom_read line, but also add the dtoverlay line?

In general there are no known issues with current 5.4 kernels and 4.19 kernel will also work (without headphone support) when not using the EEPROM.

Yes I think we posted at the same time. These are the lines I added and it worked. Hopefully it will help someone else struggling with the same thing. It would be really nice if they got it added as an option in the list so it could work without needing to edit the file. It seems like quite a popular option.
Thanks so much for you help and quick responses.

i’m happy that it also works for the pi 4… glad to help.

The only issue I can see is that the volume slider on the screen doesn’t work. It doesn’t matter if you have it a 0% or 100% the sound output is the same.

you could try the software controle maybe that works for you.

You’re just too good to me. That works.
I hadn’t realised the setting had changed to Mixer Type = none so changing that to software worked.
Thanks again

happy that it worked :slight_smile: now you can enjoy your set-up :slight_smile:

1 Like

I’ve been getting by with volume control issues until now! Thanks dvo!!!

Checking back in with this thread in April 2022 since editing the boot file didn’t work for me. Had to buy a different DAC, but would love to see if Volumio is resolving this issue so I can eventually buy another Pi and use it in that one.