Peppy meter not working properly

Yesterday I have installed new peppy screensaver V1.5.0, a brand-new volumio OS 3.631 and peppy meter skins from Gelo5 77 1280x400.

Peppy Meter plugin settings.

  1. Alsa configuration: modular alsa
  2. Screensaver timeout:4
  3. Needle cache: OFF
  4. VU meter: random
  5. Random mode: interval
  6. Random interval: 15

Touch display plugin settings.

  1. Screen timeout: 6
  2. No screensaver while playing: ON
  3. Control GPU memory: ON
  4. GPU memory size: 128

Memory info
Memory: 1864840 Ko
Free: 391296 Ko
Used: 1473544 Ko

Software info
Mpd version: Music Player Daemon 0.23.15 (0.23.15)

Storage info
INTERNAL storage - Size: 56472Mo
Used: 1256Mo
Available for storage: 52299Mo (93%)

Now I am facing some issues in peppy meters working. Peppy meter is not turning on automatically or taking too much time to activate peppy meters, suppose if it is turned on
the peppy meter needle is not working when music is playing, causing the touch screen to freeze and stop reacting. Additionally, when playing internet radio, the song’s time/counter are no longer visible. But YouTube has it available… I brought up all of these problems to the Facebook volumio group and volumio community forum both requested a solution. Mr. Michel Alofs made a little more of an effort to assist me, but he was still unable to resolve the issue. I think the peppy meter developer can assist me more effectively with this problems.


@2aCD or @Gelo5 can you pick this up.

Turn off Random mode. Turn on one skin and check the effects.

Multiroom -off

Thank you so much for quick support. Settings done as you me mentioned… but peppy is not turning on . also song duration is not displaying when playing radio stations…Youtube is showing…Also mailed to 2aCD and Gelio 5 earlier today… still waiting to the kind support from experts.


Are you sure this is a “clean” installation?
Have you uninstalled Peppyscreen and installed the new version?
PS. TouchDisplay 3.3.5 version?

Do it again on a clean SD card, volumio (3.631), touch (3.3.8), peppy (1.5.0)
It has to work

Radio stations do not always provide song times

1 Like

Indeed. I tried formatting my 32GB SD Ultra card with the most recent versions of the Volumio OS 3.631, Peppy Screen Saver 1.5.0, and Touch Display Plugin 3.3.8, but it didn’t work. Peppy doesn’t switch on by itself. If it is enabled after a few minutes, the touch screen is hanging and the peppy needle is not moving… Anyways i will try again the steps from the beginning…then i will update you…

Thank you


@dvo @Gelo5 I was the one who helped him a bit through Facebook.
@Naveen do it right the first time and not if this happens, otherwise you could run into problems… pay attention to that :wink:

Yeah, something is going wrong, Had a fresh Volumio install (with latest one from the zip in post 7, yesterday) and peppy didn’t start. If i tried the same calling it manually, but it keeps throwing random segmentation faults (PM V1.5.0).
So I took the backup SD from before the fresh install, (PM V1.4.0), that one worked.

Also the uninstall from V1.5.0 seems broken. It leaves folders intact. Needed to manual remove them in order to reinstall them.

1 Like

pygame is updated for 1.5.0 so you could not use a old version because it doesn’t overwrite
a old version. that’s why you need to use a clean install of all.
and he had to use the touch plugin 3.3.8 instead of the 3.3.5
it could be that he runs in to errors mine hanged at 70%
switched repository mirror discribed here to install it :

it was a fresh Volumio install…

1 Like

yes but he was still running touch plugin 3.3.5 instead of 3.3.8

@gelo5 had it running so it should work.

( i didn’t use peppy in my install yet and i updated it all OTA so no clean install. )

Confirmed working!

Geekworm X1001 NVMe Hat
Volumio v3.638
Inland 2TB NVMe 3.0x4 (no more Micro SD Card)
Touch Display Plugin 3.3.8
PeppyMeter Screen Saver Plugin - 1.5.0
Power Supply - Official Raspberry Pi 27w

v1.4.2 peppy also cannot be uninstalled.
system version: 3.631.

1 Like

uninstall would not work, even if you could remove it all because of pygame older version that is installed.
fresh install is needed for the 1.5.0 version.

Then we’ll do a new install and see if it works.

Disagreed! Yesterday, I tried to uninstalled the 1.4.2 and of course, it gave me an error. I had everything set up on my 1TB NVMe so I just deleted the whole folder of /data/plugins/user_interface/peppy_screensaver then reboot. After reboot, the 1.4.2 was gone and I was be able to install the 1.5.0. I don’t remember if I had to do a “Factory Reset” or not. :slight_smile:

Anyway, today I just replaced the 1TB with a 2TB NVMe and did a fresh install and everything is working fine.

** Verified - No “Factory Reset” needed!

1 Like

This was what @2aCD was telling not me :slight_smile: i still didn’t installed it.

1 Like

Yes, something goes wrong with the uninstaller.
And it has nothing to do with V1.5.0…

Agreed! I’m sure Falk will fix it very soon. :slight_smile:

new install system version 3.631, peppy v1.5.0.

@Naveen everything works, also random (mode interval) interval set to 15, playing internet radio.
the screen continues to work and does not stop or an error with the touch.

@Wheaten I also tried the uninstall button, same problem, error.

my settings