No Spotify Connect / Allo USBridge - Sparky - Mytek Brooklyn DAC

Dear Volumio music lovers,

I have an Allo USBridge with Sparky SBC and Mytek Brooklyn DAC. I have installed the plugin “Volumio Spotify Connect2 1.0.5”. Still Spotify cannot connect to the Volumio Allo USBridge. I also have the plug-in “Spotity 2.0.2”. This seems to work, but it does not include my favorites and play lists.

How do I:

  1. Get Spotify connect working, or
  2. get my playlists and favorites etc. in the Spotify Volumio GUI ?

Best regards,

Volumio Information

Volumio Version:2.852
Hardware: Allo USBridge Sparky
DAC: Mytek Brooklyn

You probably have the same issue as there - please try the steps from there :slight_smile:

If you are comfortable with ssh, could you also let me know if the Volumio API gives us the correct parameters?
You could check by examining the configuration file for vollibrespot

# VLS config
cat data/plugins/music_services/volspotconnect2/volspotify.toml

Also confirm that this matches what Volumio should use

cat /data/configuration/audio_interface/alsa_controller/config.json

Dear Ashthespy,

I’ve been playing around in “http://volumio.local/dev/” with the rules you mention. The logs I get are really enormous. Hundreds (thousands?) of lines. Is it useful to share this and find a needle in the haystack?

Best regards,

Hey Olaf,

What would be best is to open up two tabs - \dev page in one tab, volumio.local in another. Stop all other things in Volumio, and then enable the live log, and then recreate the minimum steps to reproduce your problem.

In this case it would be:

  1. Enable LiveLog
  2. Stop any playback.
  3. Attempt to connect from a Spotify Client
  4. Copy the logs here :slight_smile:

Hi Ash,

Thanks for your reply. This is what I get in de livelog in the /dev page when I follow your steps:

Starting Live Log…
process exited with code nullNo journal files were found. Failed to get data:
Cannot assign requested address

In the Android Spotify app I can see the Volumio as device to play from.

Best regards,

Dear Ash,

Don’t know what happened to font of my previous reply. I tried the livelog again and in an other place of the browser window found this:


Can you make sense of this?
Kind regards,

Ah, it looks like the Sparky build needs sudo for the journal files. So LiveLog will not work. Sorry!
You will have to use ssh. There should be a guide on the Volumio docs page, let me know if you don’t find it :slight_smile:

But how did it work back here? :thinking: Or was this using the “send log” button?

Dear Ash,
I’m slightly familiar with Putty and SSH. I wouldn’t know what sudo commands to use to activate LiveLog on the Sparky (I am a music lover and no computer whizkid). With search “LiveLog” in the community webpage I didn’t find anything useful (I think).
What and where is the “Volumio docs page”?
Could you send / post the right info?
I’ll get to it in some days.
Thanks in advance,

Sorry for the confusion –

LiveLog is just a small “feature” where you can see the log messages directly from the browser by visiting the http://volumio.local/dev/ page. It looks something like:

To see the same information from the terminal (putty/ssh) you would need to run the following commands

# Volumio logs
journalctl -f 
# vollibrespot logs
journalctl -f -o cat -u volspotconnect2.service

Note you might need add sudo before these commands depending on the version of Volumio your running

Dear Ash,
With putty ssh the commands you propose have no result.
The “…/dev” page results in a link to a log file which is far to big to copy in this reply window.
Any suggestions?
Best regards, Olaf

I am very confused, can you please share a screenshot of this very big log file?

Here’s an example:

Ah, as suspected - this is the normal Send Log or bug report link which lets you share a detailed log for debugging
The process is described better here in a step by step fashion:

This isn’t the LiveLog - that is just a few lines further down the page. Do you not see it on the dev page?

Either way, you issues is mostly the same as I mentioned back in No Spotify Connect / Allo USBridge - Sparky - Mytek Brooklyn DAC - wrong mixer setup.

Can you try the steps I posted in that thread?

It should solve your issue…

I did set the Playback options > Volume options > Mixer type > None.
Spotify Connect works now. Volume control in the Volumio “app” does not.
Still happy with Volumio.

If you want volume control, please set it to Software - None means no volume control :wink:

Dear Ash,

I know, but when I set it (again) to Software, than Spotify Connect will not work and I will still/also have no volume control. That was the situation why I started this help request; no spotify connect and no volume control (The latter has also a separate help request). At least one of the issues is solved now.

I think I’ll accept that volume control has to be done on the Brooklyn DAC and not in the Volumio “app”.

Kind regards,

Aha - I am very curious to see what is going on. It shouldn’t work like this.
When you set the volume control to Software even Spotify connect should work (using software volume).
Would you mind doing some more debugging with me? (copy pasting into the terminal via ssh) If so, send me a message, I will guide you how/what has to be done.

Hi Ash,

I won’t mind to do some debugging with you. Accept that I’m not an ict specialist and have a busy live, so I wont react quickly.

For a start I had a look into the Mytek Brooklyn manual. Here’s a citation:
“9.2.13 USB Volume [HID]
When this option is enabled the DAC main outputs signal level can be controlled by OS volume fader. Click small speaker icon shown in Windows taskbar to see the fader. If the icon is not visible please go to your system settings „Notifications & actions” (Win10) and enable it.
Attention! When AES, SPDIF coaxial or SPDIF optical input is used and the DAC is still connected to a computer via USB port the USB Volume option must be disabled. Otherwise the DAC can damage your speakers as it can play too loud.”

Just a thought: I have the Allo USBridge connected to the Mytek USB input. I have the Mytek USB Volume option disabled, because I have also SPDIF inputs to the Mytek.
Could this be the explanation the volume control with the Sparky and Volumio won’t work any way?
On the other hand, why should this influence the working of Spotify Connect?

Kind regards, Olaf

Yes - this is what I would like to check - the DAC doesn’t seem to expose the hardware DAC when connected through the USB bridge.
Since Spotfy Connect depends on Volumio’s API to report the right card and mixer setup, it fails here for the card and mixer reported by Volumio. I made a design choice to not fail silently, but exits the application when it has such things happen :grimacing: Probably not the best choice, but I don’t like silent failures…

From your logs, this is what is picked up from the API -

[Vollibrespot] : Setting up new mixer: card:hw:1 mixer:SoftMaster index:0

Similarly, since this seems to be an ALSA issue - Volumio fails to use the Software mixer
as seen from your logs:

Nov 25 07:16:37 volumio volumio[828]: error: Cannot set ALSA Volume: Error: Alsa Mixer Error: amixer: Mixer hw:1 load error: Broken pipe
Nov 25 07:16:37 volumio volumio[828]: info: Setting volume on startup at 75
# MPD is also failing with
Nov 25 07:16 : exception: Failed to register /var/lib/mpd/music/USB/rootfs/var/run/samba/ncalrpc/np: inotify_add_watch() has failed: Permission denied
Nov 25 07:16 : exception: Failed to register /var/lib/mpd/music/USB/rootfs/var/run/samba/winbindd_privileged: inotify_add_watch() has failed: Permission denied
Nov 25 07:16 : client: [1] opened from local
Nov 25 07:16 : exception: Failed to access /var/lib/mpd/music/USB/rootfs/run/sendsigs.omit.d/rsyslog: No such file or directory
ALSA lib control.c:1373:(snd_ctl_open_noupdate) Invalid CTL SoftMaster
Nov 25 07:16 : exception: Failed to read mixer for 'alsa': failed to attach to SoftMaster: No such file or directory

I just re-read your post and now it’s clearer to me - setting mixer type to Software doesn’t work for you from Volumio correct? :thinking: If I understood that correctly, then it’s going to be hard to debug.
But - a quick ssh into your device with Putty, might give us more clues. Please run the following commands with your DAC connected, and the mixer set to Software

# This is to see what you have 
aplay -l
# And what corresponding mixers does it have
# And check again with the right card
amixer -c0 scontrols
amixer -c1 scontrols

I made jpg images of the Putty screen with your commands. However, when I reply I get “Sorry, new users can only put one embedded media item in a post.”
How do I proceed?