New Volumio Spotify Plugin Open Beta-Testing

I made a fresh installation of volumio V 3.396 with spotify plugin V 3.07 on a RP4.
I can search for music, albums… but when I try to start a title nothing will happen.
Tried this in normal and in pluin test mode with same result :frowning:


I have the same issue on my brand new Volumio Rivo streamer.

It takes patience, endurance, multiple attempts, but in the end I get it to work. And when it works, it’s quite stable too.

I was a bit too optimistic here, tonight I barely got it to work. This might become a showstopper for my brand new Rivo…

No improvements here for me, same annoying volume changes, and multiple dropouts needing reboots.

This is a community plugin, not part of the core Volumio…

It’s not like they advertise Spotify… :roll_eyes:

1 Like

Fair point McMuffin. That’s not what I meant to say.

It’s not that I blame Volumio, but for me Spotify is my main source for listening music. So the inconvenience is actually quite big for me, and could mean I have to find my solution elsewhere.

The ‘bad’ thing is though, the Volumio Rivo sounds so darn good! That makes it hard to return it :pleading_face:

It’s exactly why I created my plugin Dstmmix, please try it !

1 Like

I guess my comment’s tone was lost…

The distinction of functionality via core code or a community plugin is just semantics, when all these streamers are sold advertising Spotify support.

Given the time that has passed, priorities of the developers is pretty clear, so you won’t be the only one jumping ship…

Hi Huubster.
Can you clarify 2 things?

  • If I recall correctly, you were asked to put plugins in test mode to install pandora. then you installed the spotify plugin. Given what we discovered lately (a glitch in the plugin system). Can you:
  • Disable plugin test mode
  • Uninstall spotify plugin
  • Restart
  • Install the spotify plugin
  • Check which version is installed and report back here please
  • Let us know also if it works, and how you use it (via Connect functionality or via browsing via the UI)


In any case, for products, we’ve initiated the official Spotify integration request. We’ve not heard from them yet. But our plan for products is to deliver official implementation (given that Spotify grants us the SDK).

Weren’t you gone?

1 Like

Hi Volumio,

Thanks for reaching out, really appreciated.

I think you hold me for someone else, I’m not aware of that request to me. I also haven’t done that (yet). But no worries, I’m happy to help and share my experiences to make things clearer :slight_smile: I’m a newby to Volumio, so here is my short story:

  1. When I received my Rivo about a week ago, I installed Spotify Plugin, which was 3.06 at that time if I remember correctly
  2. It was somewhere this weekend that I updated the Spotify plugin to version 3.07
  3. For me nothing changed, connecting from Spotify to Rivo is still not working all the time

Initially I only used the Spotify app itself, so the Connect functionality. Later on I discovered the Volumio UI. If the Rivo is not showing up in Spotify app, 2 distinct situations occurred to me:

  1. Spotify UI in the Volumio UI was not available, as if the Spotify plugin was not installed (it did show up in ‘installed plugins’ though)
  2. I was in the Spotify UI of Volumio and loading pages, playlists or starting a song was not working

So the Volumio UI seems not to be a work-around for me if Spotify connect is not working.

If you want me to try some other things like test mode etc, please let me know.



I’ve looked at your link where you explain how your plugin works. I’m not a software tinkerer myself, though I’m in IT, hehe. I’m not a RPi user of any sort, I bought the Rivo for a reason, amongst which being a complete solution for a nitwit like me. It seems like a hassle to make it work, won’t I interfere with the Out of the Box software of the Rivo if I do all that kind of stuff?

1 Like

you can basically benefit from a working LMS install that will help you enjoy your music instead of waiting volumio team fix every single music service that are broken/unstable lately. It’s off topic here but I didn’t want to let you without solution

Could still be a good idea to reinstall the plugin so you are sure that is correctly installed, since there was an issue earlier that not the latest version was supplied from the plugin section.

  • Uninstall spotify plugin
  • Restart
  • Install the spotify plugin

I did that during my test this week-en and it did the trick for me on my old primo :+1:

Thanks for the tip. I just did so, let’s see what happens!

Yeah, for me both 3.0.6 and 3.0.7 have been rather stable without any hickups on my Primo mk1

And then with plugin test mode disabled? I must be lucky because since I updated the plugin to 3.07 (test mode still enabled and not an uninstall/restart/install), everything is working really well. As I’ve backed up my SD card I’ll try testing with the suggested method anyway.

I’ve only installed the stable versions, so never activated the test mode for plugins.

OK, I did …

  • plugin uninstall
  • plugin test mode off
  • restart
  • plugin v3.0.7 install

Everything still working very well, selecting tracks via plugin and via my phone’s spotify app.

While trying to follow these instructions, I get an error trying to uninstall version 3.0.6.

An error occurred while uninstalling the plugin: Error

How do you get around that? I’ve tried rebooting a couple times already.

1 Like