MQA - Does it work?


I have read the mountain of topics and posts on this one. No one so far seems to be able to get MQA from Tidal to work on Volumio.

I have an iFi Zen Dac which is MQA certified and works fine with MQA on my Windows PC through the Tidal app. However on my Volumio PC in my music room it is limited to 48KHz/24Bit. I have followed the suggestions I have found in other posts and made sure the audio quality for Tidal is set to: “Hi-Res”, no plugins or other audio resampling enabled, and the volume is 100. Now I have a question around the volume. When it says make sure the volume is 100 I have set the Mixer Type to: “None” as the only other option I get is “Software” and I don’t want to use that! (I did try with “Software” and volume at 100 but that did not work either). In any case setting Mixer Type to None should be the same as volume 100 and allow the MQA to pass through, correct?

What I would like is a definitive YES or NO from the devs at Volumio as to whether or not MQA works with Volumio. And if it does, how do we get it going?!!!

I have paid my money for Volumio Virtuoso, pay monthly for Tidal, and have just purchased a Dac that is MQA certified only to find that it may not even work!

If anyone has a solution please let me know.

Thanks in advance.


Hi John,
the last thing we can check is: are you playing tracks which are MQA in TIDAL? They are signalled by an “M” icon near them.
Let us know

Hey Michelangelo

Thanks for the quick reply. Yes the tracks I am trying definitely have the “M” symbol to signify MQA. I have tried the DAC on my Windows PC with the Tidal App and can get these tracks to output in MQA (there is a light that comes up on the DAC to say they are working). However in Volumio all I can get is 48KHz/24Bit. It seems like a lot of other people are having the same problem.

With regards to the question of the volume needing to be set to 100. I assume if I set the Mixer Type to “None” this should be the same as volume=100 and allow the MQA to pass through, correct?


I have exactly the same issue. Setup is Volumio feeding a Zen DAC. Works fine streaming MQA from Roon. Additional info, I only get Roon to work if I let the DAC render not decode and render. Not sure if this helps. I haven’t tried a lot of things as I use Qobuz most of the time.

Hey there

Thanks for the reply. Yes I would be keen on Qobuz, but it’s not available in my country. :confused:


I read the spec sheet for your DAC and found something interesting: it has not any LED indication of the stream type.
So, how do you know if it is unfolding MQA?
Can you confirm?

If that’s the case, there is no way to know if MQA is actually unfolding or not, but I would assume in your case it is but Volumio is not reporting MQA logo (we never do it, for several reasons).

BTW, you see this resolution because MQA is a lossy format, and therefore it is streamed at a lower resolution.

How do you know when you stream via PC that MQA is working?

EDIT: I found out that it has a LED, and should become magenta when MQA is detected.

Now, let’s find out if this DAC has MQA unfolding or if it requires first stage unfolding, if the latter is true, it won’t play MQA on Volumio since we don’t do MQA first stage unfolding because: 1) proprietary MQA technology cannot be used in open source code. 2) We would have to pay MQA a fee.

Hey Michelangelo

Yes I get the Magenta LED on my Windows PC with Tidal Masters.

I cannot find anywhere in the literature or online if the Zen Dac requires first stage unfolding. I have sent an inquiry to AMR/ifi and will post back here once I get a response.


Hi Michelangelo

This is the response I have had back from iFi:

Thanks for reaching out to us.
The Zen DAC is an MQA renderer so it must have software decoding in Tidal, then the Zen will do the rest of the unfolding.
Therefore either Tidal or Volumio not helping.
In Tidal ‘Passthrough’ should be disabled:
We hope this helps.

So it sounds like I cannot get MQA to work with Volumio as it does not do the first unfold.


Thanks a lot for this post.

I own a Zen DAC two. LED turns magenta playing a TIDAL master on my Windows 10 Notebook.
Will other external DACs also not be able to encode MQA using Volumio?

The DAC will have to be able to do the decoding and not only the rendering.

I’m choosing between Pro-Ject PreBox S2 Digital and SMSL M500.

You can see the decoding capable DAC’s in, where it reads “MQA-enabled Digital Audio Converters provide full decoding for the highest possible sound quality”.

I had the Pro-Ject PreBox S2 Digital and I can recommend it a lot.
One of the best price\quality DACs I’ve ever had. It has been designed by legendary John Westlake (which is also part of our community).
IMHO you can’t go wrong with that

Volumio is OK for MQA playback, but the DAC need to do complete unfolding…

M500 can do unfolding of MQA data stream supplied from volumio. There are on display text MQA, green or blue circle and sampling rate… If certified MQA track is playing there is a blue dot, else green…
For example : Louis Armstrong : What a wonderful World : volumio shows : 48 kHz 24 bit, M500 shows MQA blue dot, 192 kHz.

If the data speed is not enough, M500 shows 48 kHz and normal audio data source…

Tapatalkkal küldve az én CLT-L29 eszközömről

I have an SMSL M500 dac with RPi4b/Volumio which I run with mConnect on my Android phone. Up until this morning Tidal MQA files were played OK through my system, and I get either the green or blue led/light shown on my dac, but never the purple light.

However, things change for the worse (?) this morning. No more MQA indication showing on the dac display despite playing Tidal MQA files. I played about with the settings in Volumio but still no joy.

Playing Tidal MQA with my MacBook Pro with USB out to the SMSL M500 dac, I get the MQA indications on the DAC. So some things have changed in Volumio that I/We are not aware of!

Ah…need to check data speed in my setup. This could be why I’m having no MQA.

My Tidal/Rpi4b/Volumio/SMSL M500 is doing great again after I reinstall Volumio. When playing MQA tracks from Tidal, the dac indicates MQA being played, either green or blue lights showing on the display of the dac. :slight_smile:

Hi musaziz,

nice to hear that :slight_smile:

What can You san about M500 ? Do You like it ?

I send Tidal MQA tracks from Volumio (Hifiberry digi + pro) to NAD D3045 amplifier (has internal DAC) via optical spdif connection. The amplifier shows mqa led. I confirm its possible to play mqa tracks on Volumio.



I have a Project Pre Box S2 DAC with full MQA support.
I`m running the latest Volumio installed today on an Allo Usbridge Sig and on an Android Tablet.
I have configured a My Volumio account and bought the Volumio app on the tablet.
I have a Tidal Hifi subscription, with Master files.

I could not configure Tidal as Beta version, I just get an error. I have configured Tidal normally and it`s working but I have 2 issues:

  1. After a while (20 minutes), MQA files stops showing on my DAC, it doesnt show the MQA logo anymore on the DAC display. I have tried every setting and nothing. After a factory reset from Volumio app, I can see again MQA for about 20-30 minutes, then its not showing MQA anymore on the DAC display.
  2. The MQA files are limited to 44Khz when playing from Volumio? If I play a track from Tidal from My PC, I can see 192Khz on the DAC display, but if I play the same track trough Volumio, it shows 44Khz.

Please advise. Thank you.

1 Like

Hi, you have to install Room Bridge Plugin in Audio services menu on Volumio. Its working prefeclty for me. I had the same problem until I have activated this plugin. I have a smsl SU-9 DAC connected by USB to a Pi 3 as bridge for Roon

1 Like

Why doesn’t volumio go an other approach? Do software unfolding of MQA so all DACS can be used.
The Pi 4 has enough power to handle that.