[GUIDE] Wolfson Cirrus Audio Card / Raspberry Pi 1 - Modell B V2011.12

I got the Wolfson card working on a RPi 1B by following various posts and guides dotted around these forums and official guides etc. I thought I’d try to write a basic step-by-step for anyone who wants this all in one easy recipe (which is likely to include me in six months when I’ve forgotten what I did…)

Running Volumio 2.861

Enable ssh access and log in from a terminal/powershell (user volumio, password volumio)

cd /boot
sudo nano userconfig.txt (this is an existing file)
add this as a new line:
ctrl-o to write ctrl-x to exit

cd /etc/modprobe.d
sudo nano cirrus.conf (this is a new file)
add these as separate new lines:
softdep arizona-spi pre: arizona-ldo1
options snd slots=snd-soc-rpi-cirrus,snd-bcm2835
ctrl-o ctrl-x

cd /volumio/app/plugins/system_controller/i2s_dacs
sudo nano dacs.json (this is an existing file)
Add this line to the list of RPi DACS (Keep the same spacings, it’s quite obvious how it should fit. I added it in the correct alphabetic position but I don’t know if this is necessary. The comma at the end is important!)

Exit ssh and reboot

ssh back in and download and extract the scripts file:
wget http://www.horus.com/~hias/tmp/cirrus/cirrus-ng-scripts.tgz
mkdir bin
cd bin
tar zxf …/cirrus-ng-scripts.tgz

Then you need to execute the appropriate script. I wanted analogue output from the line-out (green) port:
sudo ./Playback_to_Lineout.sh

Reboot (might not be necessary, but whatever)

Now you can use the web interface. Select the RPi-Cirrus from the Output Device dropdown menu (not from the I2S DAC menu, which is selected off on my machine)

Set volume control to Hardware and select linear (not natural) for volume curve (natural gave a very distorted sound) steps of five is a good choice for detents. Set volume to 50.

Select HPOUT2 Digital as the mixer control name (There is a huge list of options for this so be sure to pick the right one)

Enjoy sweet sounds!

1 Like

After a reboot the RPi-Cirrus entry appears in the I2S DAC list. So I enabled I2S, Volumio asks for a reboot, then re-select the HPOUT2 Digital Hardware volume control.
Keep the response as Linear.

Another update. Now running on the Buster beta. The system gave an error trying to use the i2S bus gui controls. I deleted the changes to dacs.json and reverted to selecting the playback device from the top menu with I2S selected off.

Could you please add Volumio Beta issues to the proper area and not clutter your own additions to threads that have no relation with it?
Thank you!

This isn’t a Volumio Beta issue, that was incidental. This is about getting the Wolfson card to work. The Wolfson card is not (currently) supported in Volumio or the Beta.

Dude, i can’t thank you enough. I had a pair of pi and wolfson gathering dust. I had it working earlier (10 years ago) but it was based on Wheezy.

Now when i wanted to use it again, it ran into typical wolfson issues. I had a choice of using a USB DAC but nah, the purist in me wasn’t too happy to settle for anything less.

I2S > USB , any day!

And i found your article / blog. SUCH A LIFE SAVER.

if you live around SE / London (England) , i offer to buy you a beer / coffee.

Have a great day.


1 Like

Haha! Glad to have helped :slight_smile: None of this was my original work, I just tried to collect all the available info into one place. Anyway,I live in Germany, so I’ll just tell myself “This one is from James” when I next have a beer. Cheers!

all these difficult choices:

1 Like

Hi again! Having enjoyed those sweet sounds - thanks to your excellent guide and assistance - since early June, the sound is now far from sweet, quite distorted in fact. I’ve recently done an update to Volumio, which meant first doing a factory reset, then back to your guide and my own notes to reinstall the Wolfson card as playback device. The distorted sound developed prior to the update and I hoped the latter might fix it, but no such luck. I’ve checked the playback settings and tried one or two other mixer control options, but so far no joy. Any suggestions?

it could be that your HAT is broken, if suddenly the sound became distorted

I don’t I’m afraid :frowning: Probably need to look at logs. Maybe upload your log and ask for the Volumio devs to help?


I’ve got an RPi II with the Wolfson and had volumio working quite well. The Micro SD got messed up so I’m doing a clean build on a new card.

I follow the steps and get to aplay -l and get to see the wolfson card. Similar to @nickc, I am seeing that the UI is no longer accessible after running the lineout bash file. Any suggestions on how I can diagnose these issues?

Update I simply ran Reset_paths.sh and then was able get this working. Thanks @pauljwells for the writeup