FusionDsp : the complete Dsp center for Volumio3!

HI ballbuze.
I been reading through the Github comments.
Am I correct in assuming this will hopefully help in general stability when tracks are changing between different samplerate and bit depth ?

I have had a few crashes recentlty ( system stays silent until reboot) usually these are happening when I’m towards the end of a session and start randomly picking tracks.

Volumio3.546 and Fusion1.0.49 (PEQ)

Worth a try either way I suppose

Yes, it should improve stability in that case! Please test and feedback!
Thanks for your help

FusionDsp v 1.0.51 see above

Had a mess about today.

Clean install of V3.569 and the only plugin FusionDSP 1.0.51

Trying my hardest to break it. chopping back and forth between tracks
Not once did it stop play where i needed to reboot.

However, what I did notice is how quickly it now changes track, which is good but it seems to start 1/2 to 1 sec into the begining of the track ie. chopping the beginig 1/2 sec off.
Sometimes even starting 10 seconds into the begining.

Volumio log http://logs.volumio.org/volumio/Jc66WnC.html
where is the CamillaDSP log gone ? the one in tmp is empty.

1 Like

Yes it is faster due to the change done.
camilladsp.log is still here, but if no error or warning, it contains nothing.

Nov 16 16:30 : player: played "NAS/Server/E/The Eagles - Hotel California (1976) -2013-HDTracks [FLAC]/01 - Hotel California.flac"

# cat /tmp/camilladsp.log ---------------

# cat /tmp/cec-client.log ---------------
cat: /tmp/cec-client.log: No such file or directory

# volumio plugin list ---------------

This command will list installed plugins on your device

----------------------- Installed Plugins:
    prettyName: 'FusionDsp',
    name: 'fusiondsp',
    category: 'audio_interface',
    version: '1.0.51',
    icon: 'fa-sliders fa-rotate-90',
    isManuallyInstalled: false,
    enabled: true,
    active: true

Let’s see for your issue…

Not sure if you are asking me something but… is this helpful

At 13:26 is when I paused it, had lunch then ( under orders :D) go and repair our dishwasher.
When I came back at 16:06, didnt press play, just tapped another track, is when it started the track ~10 seconds in. But it has done this before without the break in the middle

Im currently setting it up with all my plugins and mods to see how it goes under normal listening conditions ie. Just using it normally. Should get 2-3 hours tonight of play time :slight_smile:

Nov 16 13:25 : player: played "NAS/Server/C/Chase & Status/Chase & Status - 2 RUFF Vol. 1 [320](2023)/06 - On The Block Feat. Avo & Horrid1.mp3"
Nov 16 13:25 : player: played "NAS/Server/C/Chase & Status/Chase & Status - 2 RUFF Vol. 1 [320](2023)/08 - Get Got.mp3"
Nov 16 13:26 : player: played "NAS/Server/C/Chase & Status/Chase & Status - 2 RUFF Vol. 1 [320](2023)/08 - Get Got.mp3"
Nov 16 13:26 : player: played "NAS/Server/G/Guns `n` Roses/Guns N Roses - Appetite for destruction 1987 FLAC/03 - Nightrain .flac"
Nov 16 16:06 : player: played "NAS/Server/G/Guns `n` Roses/Guns N Roses - Appetite for destruction 1987 FLAC/03 - Nightrain .flac"
Nov 16 16:08 : player: played "NAS/Server/C/Chase & Status/Chase & Status - 2 RUFF Vol. 1 [320](2023)/02 - Liquor & Cigarettes ft. Hedex & ArrDee.mp3"
Nov 16 16:09 : player: played "NAS/Server/C/Chase & Status/Chase & Status - 2 RUFF Vol. 1 [320](2023)/02 - Liquor & Cigarettes ft. Hedex & ArrDee.mp3"
Nov 16 16:10 : player: played "NAS/Server/G/Guns `n` Roses/Guns N Roses - Appetite for destruction 1987 FLAC/03 - Nightrain .flac"
Nov 16 16:10 : player: played "NAS/Server/C/Chase & Status/Chase & Status - 2 RUFF Vol. 1 [320](2023)/02 - Liquor & Cigarettes ft. Hedex & ArrDee.mp3"

Used as normal last night ~3hours
Everything was pretty much the same as the test above.
Fine while working its way through a playlist on its own, the tracks started where they should.
Only when I selected different tracks in the play list you could notice the begining 1/2 sec missing, but that was only 50% of the time, the rest of the time was fine or unnoticeable and only once, I think, did it start ~10 secs early.
Most importantly was the fact it did not crash.

Thanks for your feedbacks.
if you’re comfortable with ssh, could you replace


by the one attached and reboot?
remove the fake extension from name!
thanks for helping
camilladsp-js.js.removethis.txt (4,4 Ko)



Just had a good mess around with, trying to break it.
Its does seem about right now. no more losing tthe first 1/2 second of the track.

The only thing I have noticed is when changing tracks with different sample rates coming from 44.1 to 192 or above you get a little “squelch” sound at the begining maybe a tenth of a second.
doesnt happen going back down to a lower sample rate only goin up to 192 and above.
With the original 1.0.51 camilladsp-js.js its not there.

Something else I have noticed with all the reboots having to be done.
Usually if you hit the power off button or restart and it will do it immediately.
With FusionDSP plugin enabled and at least one song played clicking power off or restart takes a couple of mins. Disabling the pluging and its back to normal again.
This doesnt happen in 1.0.49

1 Like

first of all thank you for developing this amazing plugin letting Volumio to be a fully digital HIFI network device.

I am using a rpi4 (2GB) running Volumio 3.569 (premium account) and FusionDSP 1.0.51 (no other sw/plugings installed). I have copied my convolution filters (wav) named filter-4100.wav , filter-4800.wav upto filter-192000.wav for left and right channel . In FusionDSP I select the 4100 files and I get “variable-samplerate” notification as from user manual.
Playing is ok at all sample rates except when a 192kHz rated song is streamed from Qobuz or played locally : no sound even if Volumio playing timeline is running.

I also loaded in FusionDSP only the left and right 192000 filters and still no sound . In Camilla view I see DSP not running.

The log reports :
— info: camilladsp spawned new process with pid 1704, instance 1, run: true
— /bin/dd: error reading ‘/tmp/fusiondspfifo’: Resource temporarily unavailable


Could you help on this ?

Thanks for your feedback.
Some questions…

  • are you sure of the naming of filters 4100?
  • are you sure 192kHz filter is working?
  • if yes, can you send log? Go in IP/Dev and copy paste the link for log here.


you are totally right : problem was the 192kHz filter file itself . Once recreated with rePhase and uploaded to FusionDSP problem solved (sorry my fault).

Thank you again for your outstanding contribution.

Enjoy your music!
And if something is wrong or if you have a question, you’re welcome :hugs:

I have a problem in camillaDSP gui, when I try to mark the config file as active, the A icon is in the “shadow” and appear this message is : “check the backend configuration”

I have a Raspberry Pi 3B, I use .wav convolution filters from 44100 to 192000 Hz, left and right channel. With fusiondsp 1.49 every frequency works and even the resampling function works without hesitation.
I updated to version 1.51 and only the 44100Hz frequency works with the filters, everything else including resampling stutters.
I can’t resolve it in any way.
Often the entire system also crashes.

My log:


Check your PSU. You have plenty of undervolltage in log. That may explain…

I noticed the undervolts and have already ordered another original power supply.
But with version 1.49 there are no problems.
It seems that version 1.51 uses more resources than the previous one.
I’ve tried all the power supplies I have but nothing changes.
Thank you for your attention and for the beautiful work done with your plugin.
I’ll try to do more tests when the new power supply arrives, in the meantime I’m using fusion dsp 1.49 which is fine.

I have had nany issues with havingbto reboot volumio after songs wont play. I use fir filters with rephase. Installing better heatsink helped but did not solve the problem. Finally, i discovered that the pi4 i ordered from amazon had a 2.5a power supply. 3a power supply is required for pi4. Once i replaced it, problem seems to be fixed. Just the bit of additional load on the pi4 from activating dsp was enough to take it over the top.

Helo i trported on another thread that the problem with playing songs hanging and needing to reboot seens to be solved. The orobkem was the pi4 i purchased from anaxon had a 2.5a power supply instead of the required 3a supply. Once i replaced it i have been running for a week no hanging and only one reboot. The other thing to look out for is overheating and i installed a better heatsink. I think low cost pi4 manufacturers are sometimes just using old pi3 power supplies. Im using 131072 taps no probkem now.
Cheers tony