FusionDsp : the complete Dsp center for Volumio3!

I have a problem in camillaDSP gui, when I try to mark the config file as active, the A icon is in the “shadow” and appear this message is : “check the backend configuration”

My log file is the following:
ERROR [src/bin.rs:344] Playback error: ALSA function ‘snd_pcm_open’ failed with error ‘ENOENT: No such file or directory’
ERROR [src/processing.rs:50] Message channel error: receiving on a closed channel

How can I solve these errors?

Did you change the output setting in CamillaDsp GUI? It should remain unchanged

No I didn’t.
I attach devices screenshot, gui error screenshot and the log error screenshot:

So output device is not correct.
Go in FusionDsp UI and read the help provided. There is something about the use of CamillaDsp GUI.

Hello Simone_Fusion, just a quick comment that my experience is exactly the same as yours: DSP plugin 1.49 works fine (and has for many months) but after the upgrade to 1.51 my Pi3 streamer basically refuses to function: hangs, stuttering, and total silence from any of the streamed sources. Downgrading to 1.49 restored volumio health. I have been using the same power supply for years.

very interesting feedback.
We need to investigate.
@Simone_Fusion @GlowTube can you provide log with v0.0.51? after the problem occurs

I had similar problems with the primo I, the latest update of volumio, latest update FusionDSP and Roon bridge. (See post in ‘Volumio with Roon’)

The primo I was no longer recognized in Roon. After a reset to factory settings and installation of FusionDSP version 1.0.49, Roon recognizes the primo I and it works correctly again.

Same here, with .51 analog in from a Hifiberry DAC+ ADC Pro did not work (no sound).
with .49 no problem so far…

We investigate…
Sorry for the inconvenience

I get the same error message when trying to make a filter active.
“Mark this filter as active
Disabled since the backend is not able to store the active config file
Check the backend configuration”

You use pure CamillaDsp UI?
Does it work with v1.0.49?

Yes, CamillaDSP UI

FusioDSP 1.0.51

pyCamillaDSP 1.0.0

Backend 1.0.0

Will test with 1.0.49

Edit: same error in 1.0.49

You have to fetch config from dap and don’t change output ‘postDsp’

I can’t fetch an config which is not active. I can upload files, but it won’t work when I can’t make the config active because of the “backend” error.

Play something and while playing fetch config.
For my information, what is the reason you want to use pure CamillaDsp UI?

So use DSP Type: “Convolution filters”
And import WAV filter from REW?

Any guide on how to configure the filters in REW for this usage?

I’m following this how to use CamillaDSP: RPi4 + CamillaDSP Tutorial | Audio Science Review (ASR) Forum

For Rew, search internet…
Why don’t you simply use convolution filter in FusionDsp? You just have to select your file…
Read online help in the plugin.


Have you figured out why the backend doens’t work in CamillaDSP?

Hi balbuze
I am reporting a problem (maybe integration) with FusionDSP and Volumio.

I am using 3.569 Volumio and 1.0.51 FusionDSP

Since a few days I am using a “Hifime S2 digi” toslink-usb converter which is correctly detected by Volumio . The converter can manage upto 192k but with a windows PC I set the internal sample rate to 44100/16 as the incoming digital signal from a cd player. Volumio is then connected to my usb DAC.

When I select the digital converter in Volumio as source to play the resulting sound is distorted . After some investigation, I found in Camilla GUI that the capturing rate is continuosly between 44100 and 48000 .

Any idea on how to fix it ? Thanks for your great work and support

Hello! I don’t know why under the latest Volumio3, if I turn on the FUSIONDSP plugin, the sound stutters and crackles. It’s like downloading the RPI4B 8gb card. (I disabled all other plugins). Anyway, Volumio3 is not stable in itself, I encounter many small annoying errors. But FUSIONDSP shouldn’t crack… Thanks.