Error Failed to open "alsa" (alsa). Failed to open alsa device "volumio" no such device

have a connection by my ios.
But when i press play i got a red message box " ERROR. Failed to open “ALSA” (Alsa)
Failed to open alsa device “volumio” no such device.

How to

Best regards


I get this when my DAC is turned off. I have 2 different USB DACs connected to my Pi and I change them. When I’ve tried playing the one turned off, I get this.

Confirm your DAC is on. Then confirm its selected/active under playback devices. And for me a restart of Volumio often helps.

How do i confirm that the DAC is on?
How can I see the playback option. It´s not listed in the connected IOS Volumio app

Are you using an external DAC or a HAT (something connected to the 40pins on your Pi)?
If it’s an external DAC, it should be plugged and on.
If it’s the HAT, make sure you connected it to the Pi correctly.

1 Like

I got the HifiBerry DAC+ ADC pro and on top of that a Hifiberry Aamp60. The DAC is a hat, but the Aamp60 is analog and only connected to the DAC and not the pi it self

1 Like

Ok so if Volumio gives that error, I think the HAT isn’t connected to the Pi. Or the HAT is broken. Outside of this, I can’t think of a reason. You selected the HAT under playback options (and selected the HAT), correct?

1 Like

I have the same problem with Volumio-3.251-2022-03-31 on raspberry 4 (8Gb RAM) and Sound Card HiFiBerry Digi2 Pro (connected to the amplifier with Toslink optical cable)
I choose as I2S dac “HiFiBerry Digi” that with a raspberry 3 and everything is the same, it works.
Also the config.txt files on rasp4 and 3 are the same but on the rasp4 nothing is heard.
what can I do?
Thanks bye


The Hifiberry Digi2 Pro may be incompatible with your Raspberry Pi 4, there was a revision to the Pi4 last year that broke some things:

Digi2 Pro / Raspberry Pi 4 1.5 incompatibilities | HiFiBerry

I bought the Digi2 Pro and ended up returning it for this reason, hope this helps.

Please send a log. It is required to understand the problem.

1 Like

Thanks for the reply, what do you recommend to take in his place?
Hi :slight_smile:

What do you mean by “register”? (the error screen?)
Thanks bye

I mean Sending logs for troubleshooting - Volumio Documentation

I sent the error message and that with raspberry 4 and Hifiberry Digi2 Pro does not work while with Raspberry 3 everything is ok.
Let’s update on possible improvements, Thanks bye

I really wish I had something to recommend, I purchased the HifiBerry Digi+ Pro because I saw it in the list of supported hardware under I2S but apparently that one no longer works under Volumio version 3, at least for now. I tried to install version 2.917 which is the version it last worked but I don’t know if the image I got was corrupt or the installation is different than version 3 but it is not working for me.

I am new to Volumio and had everything working until I tried to use the HifiBerry Digi+ Pro (Which I chose because it is in the I2S list of devices) in order to use spdif coaxial out to my DAC, my hardware and software are as follows:

Raspberry Pi4 8GB
Hifi Berry Digi+ Pro
Schiit Modius DAC (which does work as a USB device with Volumio 3)
Volumio 3.251

System was working fine until I added the HifiBerry, then I got the Alsa error, I looked around the forums here and tried the fixes suggested.

I tried turning off I2S and choosing the headphone out and then rebooting the system and then turning I2S back on and selecting the HifiBerry Digi+ Pro from the list, still got the error.

I tried choosing some different HifiBerry devices from the list and also the Generic I2S device, some of those would not give the error but did not pass sound.

After all this, I did send my log, at least one post in the forums said that some I2S devices are having problems under Volumio 3 and it is hopefully being worked on.

I tried to install the last version of Volumio 2 on a different micro sd card but could not find the IP address using Fing or see the Wifi hotspot to complete the setup, either my image was bad (although it did seem to install properly twice) or there is something different about the installation process instructions that I was not able to find.

So this is where I’m at, I’ll continue to use my DAC as a USB device and hope there is and update to 3.251 that then allows me to use the HifiBerry Digi+ Pro unless someone here can suggest something I haven’t tried, thanks!

This was hurting my brain for a while and I have a solution at least for my setup.
Setup - Hifiberry Digi+ Pro with RPi 4 something like 1.4, it’s before the 1.5 that HFB say is problematic.
Symptom - power system off. Then power it on. Now ALSA troubles on pressing play.
Fix - 1. Power up and wait for system to be FULLY loaded again (note this takes a while even after webUI is accessible)
2. then go to the audio output, switch off I2S DAC and select Headphones (HDMI might work too not tried)
3. SAVE!!
4. Reboot
5. Play something even for a second. Just let the track location start progressing. This seems unnecessary but appears to help.
6. STOP the playback. Essential or it’s gonna still be screwed. From memory.
7. Back to Audio Output. I2S DAC ON again.
8. Select Digi+ Pro - there’s no Digi2 Pro as further evidence that God no longer watches over us :wink:
10. Reboot.
11. A minor miracle - the thing starts to play correctly through the Digi2 Pro. Evidence that God had half an eye on and is an audiophile. :smiley:

It shouldn’t be this awkward… but at least it works I suppose. Got me pretty tempted to find another hat with better quality componentry - wouldn’t have expected incompatibility with v1.5 and partial incompatibility with v1.4.

Peace out :v:


I tried everything you said and can confirm that there is still a problem with version 1.5, I would have thought like you did that more recent hardware would be more compatible and not less. At this point, unless there is an update to the RPi 4 firmware that becomes available or Volumio can figure out a way to patch the system to work with HifiBerry, I may have no choice but to replace the Pi 4 or find a Pi Hat that works.

Yeah I doubt there’s a workaround at all for 1.5. Pretty frustrating.

1 Like

I returned my HifiBerry hat and purchased the Allo DigiOne, it worked right off the bat and sounds really good to my ear.


I have the same problem with Orchard audio Pecan Pi Dac. Two weeks ago everything was OK.