Error Failed to open "alsa" (alsa). Failed to open alsa device "volumio" no such device

Thanks it worked! Just upgraded to 3 and have wasted most of the day getting back to where I was.

Just got this error , using a Schitt Modi 2 Uber as my DAC, checked connections, still errors, power cycled Pi3 and Uber, that resolved it

Oh my god this actually worked, THANK YOU so much!

I was certain that it will NOT work because - WHY would I need to jump on one leg and hold my left ear for something like this to work? :laughing:

But it did work and I am very thankful.

My board is Raspberry Pi 3 B+ (PCB v1.2)
with HiFiBerry Digi+ HW 1.3
Volumio v3.378

This is killing me. I have a Rasp Pi3 with IQaudiO DAC+. I originally used volumio v3 and got exactly this problem. The 'solution; did not work. I reburned the chip to the latest v2 and it does have the old interface, but the problem remains and the solution still doesn’t work. Is there ANY way to get this working??

1 Like

I also have this issue since upgrading my Raspi400 to the latest software…
The Dac is a USB M2Tech Young ( Burr Brown) that worked nice with the previous software release…
Let me know what can I do for fixing the error alsa device already used???

1 Like

Hi all,
I experienced what might be the same issue last night. I’m running volumio on Ras.Pi 3 with an Iquadio Dac Plus.
A few nights ago, I installed the current version of volumio added the HAT, and all worked fine.

This issue started when I tried to add a power button-- GitHub - Howchoo/pi-power-button: Scripts useful for the Pi power button
I pulled and installed that file, and immediately experienced the “Alsa failed to open” error. When I switched my audio output to the normal onboard headphone jack, it worked fine.
I fixed the issue by uninstalling the pi-power-button program and restarting. The DAC worked immediately after.
It looks like the audio DAC HAT uses the same pin as that project, so the it stopped working as soon as I added that additional project. I’m not sure if this is the same issue as any of you were experiencing, but maybe check the Digi+ Pro documentation for pins used if you have any other projects loaded.
Hope that helps anyone out there. But, in reading through this board more thoroughly, it looks like people’s issues stem from RasPi 4, version 1.5 not integrating well with HiFi berry Dacs. Well, in any case, I thought I’d post in case anyone else has the same issue as me.

Not sure if that’s impacting the rest of you.

1 Like

I also have this issue with Rpi3 and Pimoroni Audio Amp SHIM. Worked fine on 2 and was working initially, suspect the culprit was installing the Rotary Encoder II plugin - so looks GPIO related.

Should you encounter this error again, my best advice would be to take out your SD card and re-install Volumio from scratch.
Once it is all configured, write down your settings and find anotehr SD Card. Install Volumio to that one and apply the settings. Check if they work.
So in case you need it, you’ll have a back-up system ready to go.

You can also install something else to that back-up card…

Me, my Volumio 2.9.17 stopped working. I could do whatever I wanted : no go. Reinstalled. There you go :slight_smile: At first try, it worked.

MAGIC :slight_smile:

You are my god! Works fine for me!

I know this thread is a little older but still today it’s an issue. My Volumio Pi has been doing this for a few months. No hardware was changed and it worked perfectly for over a year before, so I assumed it had to be software.

After trying several other things, for me the solution was to do a fresh install of Volumio with the latest image (although my system was already updated when the problem accured).

please post logs, so we might have a understanding why it’s failing. At least the fresh install solved your problem…

I have a pi4 2018, dont know the version.
A audiophonics digi pro interface

AUDIOPHONICS DIGI PRO Interface Numérique WM8804 pour Raspberry Pi

Volumuo fresh install 3.546.

And the same error message. No such device.

The hifidigi+ card is not working.
I also have a bug with squeezelite plugin which is not working.

Do you have news tu correct this?
Do i have to buy a pi3, or another digi card?

J ai testé avec un autre pi4, version 1.2 et ça fonctionne…

I had same problem with Innomaker RPI-Hi-Fi DAC. It was working fine for few days, recently I connected GPIO power button and next day I had alsa device error. I had to remove the button and reinstall volumio from scratch.

hey so I had a hifiberry dac 2 pro on an rpi 4 that worked. I moved my office and it sat in the garage for a year. I got a new micro sdhc and put the latest on there and it stopped working [FAILED TO OPEN ALSA].

I read that that dac isnt supported so I bought a hifiberry dac 2 HD because another post said it was supported. DIDNT WORK EITHER.

So I found this post and did all the crap ianjturner recommended and DIDNT WORK.

About to give up, I did this AND IT WORKED [see below]

1 - set to headphone save, DIDNT REBOOT
2 - set to i2s dac
3 - set to dac2 HD save
4 - Reboot

IT WORKS NOW but now I’m afraid to touch this thing.