X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Thanks again for your precious work :+1: :slightly_smiling_face:

1 Like

You must be overestimating me, by far… :joy: :joy:

Cheers :wave: :wave:

It works fine, thanks a lot.
I have another issue, too, but will post another question for that.

Thanks for testing this, I’ll add it for the next release.

1 Like

I just noted a typo in the last part: “Realtel ALC1220” instead of the more likely “Realtek ALC1220”.
Fix it before you patch :wink:

Thanks, my script is already correct

I have Volumio (Volumiobuster-3.111-2021-10-08-x86_amd64.img) installed and working on an intel PC.
However, when I turn on the machine it is not able to find a bootable disk.
I get the message: “A bootable device has not been detected. Please refer to the product guide…”.
If I interrupt the boot process with F10, the SSD drive shows up and I am able to select it and boot just fine.
Before Volumio I had fedora installed and it booted without issues.
I installed Volumio by booting from USB, and using the GUI to install on the disk.
I also (earlier) tried a few other versions (2 and 3) with the same result.


1 Like

Another issue I have is when I play albums from my NAS disk, I am perfectly able to start playing an album by clicking the album title.
But I am not able to play a song by selecting the song in the list of songs in the album.

(This should possibly be asked in another thread, as I guess it is not specific to X86.)


1 Like

First - let me congratulate the team on an outstanding product and for working on the upgrade to VolumIO 3 :clap:t4: I am a newcomer to the platform and have converted totally to a pi box as my daily streaming music platform. VolumIO 2 works great on my pi 3+ box and is integrated into my system, and I am waiting for the full launch of the VolumIO 3 software.

Just as a test I was playing around with the x86 platform on my ThinkBook 14 G2 ITL laptop with 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz and 16 GB RAM. I couldn’t get VolumIO 2 to boot on it at all . I was able to boot 3 beta and got it working with the Ethernet connection but I have a strange problem with the WiFi. I can connect fine to the VolumIO hot spot with my phone for initial config, but I cannot see and select any of the WiFi networks. Screen shots from my phone attached (I don’t know if they uploaded correctly), and the WiFi hardware is Intel(R) Wi-Fi 6 AX201 160MHz.
[Processing: 1876.PNG…](Hot Spot)
Processing: 1877.PNG…
Processing: 1878.JPEG…

I know this probably will not be a high priority issue for the team given the infinite variability of the x86 platforms but I have tested multiple Linux OS running on this laptop, including Debian distros and use the latest Kali Linux regularly, so I found it curious that the WiFi works for the hot spot but doesn’t show any other networks.

Thanks again for your excellent work - the user interface is the best I have seen for any product!!

Some WiFi devices can’t act as a hotspot and scan networks in parallel. Not sure if there is a solution for it.
Found similar behavior here on a test notebook, I can switch off the hotspot and once the network service restarts, wifi networks will appear.
I have not given it priority so far.
Please supply a log when you have further questions, with x86 it is difficult to give device-specific feedback without knowing how the device is configured.

no, this is not an x86 issue

Thanks for the quick response! Some questions (please excuse if they are addressed elsewhere):

  • Is there a script I can run at the console to turn off the hot spot and restart the network service?
  • How do I collect the logs? I looked in /var/logs and didn’t find anything useful there.
  • How do I enable ssh to the system? I would like to have this access to both the pi and the x86.

Incorrect bios boot settings

once you’ve turned off the hotspot (System/Network Settings) and saved, then your network will restart. You should be able to configure your wifi settings. They will be persistent, no need to switch off the hotspot at boot time.
You should start reading the User Guide from the Volumio documentation, it has all your answers.

Thanks again - I will do my homework and get back to you :grinning:. I actually had this link bookmarked but it seems to be dead now.

I would think so too, but the SSD is the only device set as a boot device in the bios. And I never had this issue with Fedora when installed on the same disk.

Well, we produce a bootable disk and support legacy and UEFI boot with it. You already confirmed that booting from the ssd, when manually selected, works.
Obviously your system tries to boot from somewhere else first, setting your ssd to the default boot device is not something we can help with, sorry.

No problem, thanks anyway!

Dear gkkpch, to my best observation it was/is a bit different :slight_smile:
This Z83-II is indeed pretty fast in indexing - much faster to what I experienced with my former Raspberry Pi II. I haven`t taken the time but I guess, it was through with the topic (indexing my 1 TB SSD) after perhaps 15 min. The described need to reboot due to stuttering or stopping was completely independant from that. The same behaviour occured when I only connected an USB drive with 10 songs. I always started with the small USB drive and later on connected the big SSD.
There were two kinds of “strange behaviour” that needed a reboot:

  1. Sound stopped after a few seconds (as if someone pressed “Pause”). Pressing “Play” again: sound stopped again after a few seconds (appeared in all beta versions I have tested: 3.083, 3.111, 3.114).
  2. “Stuttering” while playing, and going on with playing, even when I pressed “Pause” (only appeared in 3.114)

The other problem, with the SSD, only appeared with 3.114: after an evening of problem-free music hearing, on the next day, most of the music suddenly wasn’t in the index anymore. Re-indexing didn’t help.
Therefore I decided to go back from 3.114 to 3.111: Since then no problems anymore (no-restart inbetween), apart from the “first boot problem”. And of course, only analog sound output via the headphone jack /the realtek chip is quite good, imho). USB soundcard surely works as well.

When there is a newer Beta version I will give it another try (and deliver a Log). Until then I stick to 3.111 which is already big fun to me :-)!

Kind regards, Oliver

1 Like

Without logs there is not much that can be done, we keep repeating that.