X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

No problem, thanks anyway!

Dear gkkpch, to my best observation it was/is a bit different :slight_smile:
This Z83-II is indeed pretty fast in indexing - much faster to what I experienced with my former Raspberry Pi II. I haven`t taken the time but I guess, it was through with the topic (indexing my 1 TB SSD) after perhaps 15 min. The described need to reboot due to stuttering or stopping was completely independant from that. The same behaviour occured when I only connected an USB drive with 10 songs. I always started with the small USB drive and later on connected the big SSD.
There were two kinds of “strange behaviour” that needed a reboot:

  1. Sound stopped after a few seconds (as if someone pressed “Pause”). Pressing “Play” again: sound stopped again after a few seconds (appeared in all beta versions I have tested: 3.083, 3.111, 3.114).
  2. “Stuttering” while playing, and going on with playing, even when I pressed “Pause” (only appeared in 3.114)

The other problem, with the SSD, only appeared with 3.114: after an evening of problem-free music hearing, on the next day, most of the music suddenly wasn’t in the index anymore. Re-indexing didn’t help.
Therefore I decided to go back from 3.114 to 3.111: Since then no problems anymore (no-restart inbetween), apart from the “first boot problem”. And of course, only analog sound output via the headphone jack /the realtek chip is quite good, imho). USB soundcard surely works as well.

When there is a newer Beta version I will give it another try (and deliver a Log). Until then I stick to 3.111 which is already big fun to me :-)!

Kind regards, Oliver

1 Like

Without logs there is not much that can be done, we keep repeating that.

Hi gkkpch, I know :smiley:
This, my, description should also help other as well that might have the same unit. 3.111 ist fine, as I said. The next Beta I will test again an deliver a log.
LG Trollpferd

fixed by enabling UEFI boot in bios
(that is the issue I had with booting…)

Thanks for your feedback, glad you got it working :+1:

Good Morning together, on a Lenovo X220 Convertable the Touchscreen does not work, only the Pen and Touchpad-Input. I found no way to fix this…
Image Version: Volumiobuster-3.129-2021-10-29-x86_amd64.img
Log-File: http://logs.volumio.org/volumiobuster/aIGObKq.html


Welcome to Volumio for x86_64 (5.10.70 x86_64)
volumio@volumio:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM                                                                                                                                                                                                                                              Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Process                                                                                                                                                                                                                                             or Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset                                                                                                                                                                                                                                              Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connectio                                                                                                                                                                                                                                             n (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family US                                                                                                                                                                                                                                             B Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High                                                                                                                                                                                                                                              Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Ex                                                                                                                                                                                                                                             press Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Ex                                                                                                                                                                                                                                             press Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Ex                                                                                                                                                                                                                                             press Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Ex                                                                                                                                                                                                                                             press Root Port 5 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family US                                                                                                                                                                                                                                             B Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller                                                                                                                                                                                                                                              (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6                                                                                                                                                                                                                                              port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Contr                                                                                                                                                                                                                                             oller (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor P                                                                                                                                                                                                                                             eak] (rev 34)
0d:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 07)

inxi -Fxxxz:

volumio@volumio:~$ inxi -Fxxxz
  Host: volumio Kernel: 5.10.70 x86_64 bits: 64 compiler: N/A Console: tty 0
  dm: N/A Distro: Debian GNU/Linux 10 (buster)
  Type: Laptop System: LENOVO product: 4298RH4 v: ThinkPad X220 Tablet
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: LENOVO model: 4298RH4 serial: <filter> UEFI: LENOVO
  v: 8DET69WW (1.39 ) date: 07/18/2013
  ID-1: BAT0 charge: 45.8 Wh condition: 46.0/57.7 Wh (80%) volts: 12.3/11.1
  model: SANYO 42T4879 type: Li-ion serial: <filter> status: Charging
  Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19934
  Speed: 1554 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 1057 2: 2493
  3: 1381 4: 883
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126
  Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa
  tty: 80x24
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  chip ID: 8086:1c20
  Sound Server: ALSA v: k5.10.70
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e
  v: kernel port: 5080 bus ID: 00:19.0 chip ID: 8086:1502
  IF: eth0 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
  v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0085
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: wwan0 state: down mac: <filter>
  Local Storage: total: 149.05 GiB used: 970.9 MiB (0.6%)
  ID-1: /dev/sda vendor: Intel model: SSDSA2BW160G3L size: 149.05 GiB
  speed: 3.0 Gb/s serial: <filter> rev: LE00 scheme: GPT
  ID-1: / size: 141.06 GiB used: 31.9 MiB (0.0%) fs: overlay source: ERR-102
  ID-2: /boot size: 170.8 MiB used: 57.8 MiB (33.8%) fs: vfat dev: /dev/sda1
  Missing: Required tool sensors not installed. Check --recommends
  Processes: 167 Uptime: 10m Memory: 7.66 GiB used: 575.9 MiB (7.3%)
  Init: systemd v: 241 runlevel: 5 default: 2 Compilers: gcc: 8.3.0 alt: 8
  Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32

You could start with reading the opening post of this thread.

You seem to have a WACOM device, which is not automatically supported.
There is nothing I can do to fix this, but the following (old) link may help to get it working: https://www.thinkwiki.org/wiki/Installing_OpenSUSE_11.4_on_a_ThinkPad_X220_Tablet
The xorg part is what you should play with
Another link: https://wiki.gentoo.org/wiki/Wacom

1 Like

3 posts were merged into an existing topic: [OFFICIAL] Volumio Mini86 Support Thread

2 posts were merged into an existing topic: [OFFICIAL] Volumio Mini86 Support Thread


I installed the above card into a PC and booted Volumio for x86. Under Output CMedia appeared as a option (which was not there before I installed the card) , which I selected. I then made a toslink connection to the dac.

Sadly no signal is received.

Any tips?

As this is a typical x86 issue, I moved your post.
The problem is likely due to spdif mixer settings.
Could you read the first post of this thread and give me the requested information to start with? In this case the log will do.
I will then get back to you.

Thanks. This is the log from the PC, I flashed “volumiobuster-3.129-2021-10-29-x86_amd64” on it


I tried to ssh with putty - what is the default user and password?. I tried root, admin and volumio all with password volumio2

No success.

Unfortunately (not your fault) this log is too long and confusing to analyse.
It is clear though, that the C-Media card is missing in our profiles/ init routine.
Could you disable Automatic IP in the Network menu? You don’t have wlan but it currently clogs the log trying to activate.
Then please do a new log from after fresh reboot, thanks.
Also, which choices do you get from the dropdown list in the playback options? Analog, HDMI and something with “C-Media analog”?

Reset IP to, rebooted. here the log


I obviously selected HDA c-media

Yes, and that would probably be analog out on the c-media, digital is the one not listed (yet).